Previous 1 2 Next 25 Replies Latest reply: Feb 12, 2015 8:29 AM by Shane Ross
BlissNyc Level 1 (0 points)

Hi there, so Ive just upgraded from the T2i to Canon 5D Mark III and this is the first time I'm importing footage to final cut. I have FCP 7 (Mac computer) and my video files are 1920x1080, h264 codec shot at 30 fps (29.97). Previously, when importing from the T2i, I used MPEG Streamclip to convert my video files to Apple Prores 422, and then import those compressed files into FCP 7, with field dominance being UPPER, pixels SQUARE. I never had an issue of quality loss or lines through my viewer and canvas using these settings. However, after attempting to do the same with my footage from the Mark III, I got lines through my footage. After researching a bit, I was convinced that the way to eliminate the problem was to download the 5DTORGB app for $50. This has not fixed my problem! Have tried multiple combinations of different field dominance settings and nothing is working. Is this an interlacing problem? I attempted to catch a screenshot but everytime I pause the video or take a shot, the lines do not show...I do not know what is going on! My original mov files are fine, it is only once I convert and import to final cut that they get these little lines... I am desperate for answers, please someone help!!!

Final Cut Pro 7, Mac OS X (10.7.5)
  • Shane Ross Level 8 (42,795 points)

    What are your sequence settings? That camera shoots progressive, there should be no interlacing at all.


    Convert the files to ProRes, import into FCP, make a new sequence, drop a clip into the new sequence, click "YES" when FCP asks if you want the sequence to match the clip settings.  Done.


    If you see a render bar of any kind, something is wrong.  And you should have zero interlacing, if you have a progressive timeline that matches the settings of your clips.

  • BlissNyc Level 1 (0 points)

    Shane, thank you for your response. I have done just that though, as that was my initial attempt. I converted files to Apple Prores 422 and then imported, made a new sequence, dropped the clip, and matched the sequence settings to that of the clip. But, in the canvas it still is showing little lines here and there which appear throughout the video as it plays. Even more alarming is that this happens before I even drop the clips into my sequence. The viewer is displaying the files that way when I play them straight from the browser...But NO, I do not see a render bar when I bring in my files...


    As a side note: For some reason, I thought that my files were interlaced, because they were shot at 30 fps, which I was told was interlaced, whereas only the 24 fps was progressive. Is this not correct; are all my files off the Mark III inherently progressive?? This might be where I'm running into the problem..Would the field dominance therefore be NONE if the file is progressive?

  • Shane Ross Level 8 (42,795 points)

    Can you post a still here? 


    And there is a 30p...30fps (29.97) that is progressive, not interlaced.  And the Canon DSLRs are ALL progressive...they never shoot interlaced.

  • BlissNyc Level 1 (0 points)

    For some reason, when I try to take a screenshot, or even pause the video (from either the viewer or canvas), the lines do not show. I've tried to take numerous screenshots to catch the issue but the lines don't appear in stills, only when the video is playing. They are not black or gray lines or even pixelated lines, just like horizontal waves or ripples through the video, generally going from the middle area to top field. It is not continuous, but rather every now and then, though very persistant. I've tried all different settings using 5DTORGB conversion, and nothing is working.

  • Shane Ross Level 8 (42,795 points)

    OK...that might be because the VIEWER and CANVAS aren't high quality...they don't show you the exact quality of the image. IN fact, the quality lowers if your machine is having issues with playing it back full frame. It sacrifices quality in order to not drop frames.  Really, the only way to judge exactly what your footage looks like is with an external HDTV connected via and IO device, like AJA or Decklink or Matrox makes.


    But, do me a favor.  Open those converted files in Quicktime.  Play them.  How do they look? Do you have the same issue?

  • BlissNyc Level 1 (0 points)

    I definitely know what you're saying about the viewer and canvas playing back low quality, and I HAVE in fact previously had this same issue while playing back in my CANVAS, but never in the VIEWER, and I had been able to resolve the issue by matching the sequence and clip settings, then playing the clips with no lines or lost quality whatsoever...But, that was with the T2i...


    In any case, NO I do not the same issue when I play my converted ProRes files in Quicktime. It is only when I import into fcp that they start glitching. I am worried because as I said, this has never happened before where the lines appear in the Viewer, and cannot be fixed by any amount of changed settings..I am going to quickly string some clips together in the timeline, and export to see if the lines will still appear once the video is exported, since that is my main concern.

  • Shane Ross Level 8 (42,795 points)

    If the QT is fine, but looks wonky in FCP...most likely culprit is FCP. a test export, and open that in QT.  That's how you see if anything will be affected.  I bet that it'll look fine.


    Also...trash your FCP preferences, see if that helps.

  • BlissNyc Level 1 (0 points)

    On second thought, perhaps it is an issue with my playback settings? Here is a screenshot- Could the problem be that my video quality is set to Dynamic? Shouldnt it be set to Best quality?

    Screen Shot 2013-09-10 at 5.13.19 PM.png

  • Shane Ross Level 8 (42,795 points)

    Yes, that could be it. Again...test and see what happens.

  • BlissNyc Level 1 (0 points)

    Still no change....However, I did export a trial and the vid looks fine, no lines. I guess fcp is just being a little *****! It is just really frustrating me to have to work with these lines going through my clips, even if they do not appear in my exported file....I feel that there must be some hidden issue with my sequence settings....Could you possibly provide a screenshot of the appropriate sequence settings you would use to match a 1920x1080 file with 29.97 fps (already converted from h264 to apple prores 422 thru 5DTORGB) ? I know that usually it is fine to import the newly compressed prores files, and then set sequence to match clips, but since I'm having issues, maybe setting the sequence directly would help?


    This is what my sequence settings look like right now, after being matched to my prores clip....

    Screen Shot 2013-09-10 at 5.56.50 PM.png


    I am concerned because it shows Aspect ratio as HDTV 1080i (16:9) though you have told me my clips from the 5D should be progressive (so shouldnt it be 1080p not 1080i??) Being that there is not option in frame size for 1080p, i tried selecting the "Custom (16:9)" option, but it will not allow it...Just sets it back to 1080i......Any thoughts?

  • Shane Ross Level 8 (42,795 points)

    Those settings are good.  1080i is just a format.  1080i video is, by definition, interlaced.  And 720p is progressive.  It's just the name of the format...1080i. But you can have 1080 progressive footage...both fields are identical, that's all.

  • BlissNyc Level 1 (0 points)

    Okay. So it seems like there is no apparent explanation for the glitching in my viewer and canvas other than FCP just giving bad play back quality...It is really irking me, especially because no one I know has ever run into this issue, and it appears unsolveable....For now, I guess I will just begin editing regardless of the glitches and hope for the best.


    Thanks a million for your help Shane. If anything else occurs to you that may help resolve this, please let me know.

  • Shane Ross Level 8 (42,795 points)

    I did suggest trashing your preferences.  Preference Manager from does this for you...and it's free.

  • maggie197 Level 1 (0 points)



    Did you ever figure out your issue? I'm having the same EXACT problem. That wavy line shows up in FCP, but goes away upon export -- so annoying. Did you just edit it this way, or did you figure out a way to get rid of the wavy line in FCP?


    Thanks so much.

Previous 1 2 Next