7 Replies Latest reply: Sep 13, 2013 8:16 AM by BDAqua
djrjawa Level 1 (0 points)

Right: running power pc tower, dual proc, a number of external HD (mainly firewired), also two external DVDRW s.

Recently had an internal drive failure , but now up and running fine, except that now it won't recognise either of the drives' existance, just the main optical.

Tried Disk Utils, USB overdrive, even booted into open firmware to see if they'll help to see the drives (both off USB ports), used the USB fix package. So am confused. Have tried every which way of ordering the turning on, plugging in and wiring up options but to no avail.

I'm not too familiar with command line, but can execute them if properly instructed.


  • BDAqua Level 10 (121,635 points)

    Hi, are  other USB things recognized in those USB ports?

  • djrjawa Level 1 (0 points)

    Yes, sir, they are - though I've noticed a dramatic decrease in data transfer rate on the port I use for porting USB sticks for my streamer box (it doesn't support mac journaling, but is not connected). I have x11 installed, but couldn't install the MacPorts version I had that was installed on the recently deceased HD. I've used a USB Fix package before and that has fixed similar problems in the past but won't fix this. What were you thinking initially? And many thanks for yr time.

  • BDAqua Level 10 (121,635 points)

    I was thinking you needed a USB Reset possibly, due to USB overcurrent draw, but apparently not.


    Are these devices Bus Powered or do they have AC... which can still be a problem on a wide variety off devices, ignor the hissing, failure to mount or intermitent mounting was far more common...



  • djrjawa Level 1 (0 points)

    I'm thinking that they pretty much all [b]can[/b] run off USB , but are running off AC power adaptors - several now, could that be it? Just weird power levels all over the place? It's the same system essentially as I was using before my internal drive gave up (got 4.5 yrs out of it), the drive that I'm trying to make it read has been working, just not since the clean install.

    So what do you suggest - stripping all peripherals out then start with the DVD drives, then introduce the external storages? Are there any commands during the startup? I have the USB prober app and iTweax etc. Can retry the usbfix app with everything unplugged except the DVDRW s?

  • BDAqua Level 10 (121,635 points)

    Yes elimnate all, then try one.


    Open Console in Utilities & see if there are any clues or repeating messages when this happens.

  • djrjawa Level 1 (0 points)

    Ah, nuts I just remembered - when I last fsck'd on startup there was a hang over a Hub issue ; it turned some of the text pink, which was nice. It mentioned not being able to enumerate a value at one of the hubs at the address 0x4b3....; ill have to recheck that, I'm in the middle of something right now that'll take a couple of hours at least, but when that's done with I shall unplug everything to fsck the boot volume, then start plugging stuff in and fsck the bloody thing after each new addition, to see where it stumbles.

    I'm interested in the idea of a USB reset though - when my MacDaddy was doing the work on it (very competent, no problem there, definitely) he was using one USB port at back to run a wireless dongle as he was setting the thing up; the g5 might still be looking for that? I use a range extender on a LAN at home, but its a courtesy to him to include the dongle for repairs as he has to get out all the old ppc installers and so forth.

    Could you give me some quick instructions for a USB reset please? Preferably not as a page link though because I suffer a little screen-dyslexia after about 5 minutes. Sorry, but even a few pages would be too headache inducing.

    One last bit of relevant profiler info - just checking it now and both standard USB connections are reading the following (except location):

    Host controller location : built in USB

    Driver:                     AppleUSBOHC1

    Pci device id.               0x0035

    Pic revision:                0x0043

    Vendor id:                  0x1033

    Bus number: (1 then 2) 0x0b //  0x2b

    And the high speed bus is reading as     0x4b

    So where're 1 and 3? If that's a thing?


    Thankyou for your patience.

  • BDAqua Level 10 (121,635 points)

    reset FW bus, same goes for USB reset...

    Reset the Firewire/USB bus

    If your Firewire or USB isn't recognizing any device.  A solution which has worked for some whose hard drive became invisible in 10.4 was simply to follow these four steps to reset the Firewire/USB bus:

    1. Shut the machine down.

    2. UNPLUG the power lead to the computer and any firewire/USB drive or devices.

    3. leave it for 10 minutes.

    4. Connect back up and reboot.