5 Replies Latest reply: Sep 12, 2013 9:46 AM by rccharles
jpsonofjohn Level 1 Level 1

I just got my first mac laptop today and I am a little stymied. I bought a used iBook G4 with 1.33MHz and 1GB RAM. The OS X version that came with it is 10.4.11. I have found that I can update Safari from 3.0.4 to 4.3.1, however, when I go to install it, it says I need security update 2009-005 and I cannot find that anywhere for download. Am I "stuck" with Safari 3.0.4?

 

I went with a cheaper older mac laptop because I didn't know if I would like it or not and I didn't want to waste the money. However, so far I think it's much better than a PC.

 

Thanks


Mac OS X (10.4.11)
Solved by Kappy on Sep 10, 2013 11:17 PM Solved

Yes, you are stuck with whichever version is installed with the installed version of OS X. If there are updates for you to install you will find them by opening Software Update in System Preferences. Unfortunately, you will find that your uses for a G4 model will be quite limited.

Reply by Kappy on Sep 10, 2013 11:32 PM Helpful

Apple's Support site is presently in disarray. That may be why you can't find anything. I can't either.

All replies