13 Replies Latest reply: Oct 30, 2015 4:05 PM by hp79
Aidinz Level 1 Level 1

Hi,

 

I've enabled Firewall in OX 10.8 but everytime I open an application that can access the Internet, it keeps asking me that whether I want to allow permission the program to do or not. I checked Firewall in system preferences and it does have list of programs that I allowed to connect to Internet, so why it keeps asking everytime I open those programs?

 

Thanks.


MacBook Pro, OS X Mountain Lion (10.8.2)
  • p0sixDev Level 1 Level 1

    The Firewall is not needed on the mac. Its there morer for company usage.

    have a read of this, it might help clear things up

     

    http://support.apple.com/kb/HT1810

     

    Also, If you do want to kwwp it on, You can read this and it will help you configure it correctly

     

    http://www.macinstruct.com/node/165

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    If you are connected to the internet via a router you are already behind a firewall, no need for 2. Turn the Mac firewall off.

  • Aidinz Level 1 Level 1

    Thanks.

     

    I'm a software developer and I'm working on an MMO game and I need to have control over some in-house software on when they get online, that's why I need the firewall.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    Why do you need 2 firewalls?

  • Aidinz Level 1 Level 1

    Thanks.

     

    I'm a software developer and I'm working on an MMO game and I need to have control over some in-house software on when they get online, that's why I need the firewall.

  • Aidinz Level 1 Level 1

    I don't. I use the OSX's one because it's easier to control. I can't turn of the firewall in OSX, so is there anyway to remove that allow, deny question whenever I open my apps?

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    No idea, I don't use multiple firewalls, the router firewall does all I need. Adding a second just makes the system harder to use without any extra protection to gain. Sorry,

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Please post a screenshot that shows what you mean. Be careful not to include any private information.

    Start a reply to this message. Click the camera icon in the toolbar of the editing window and select the image file to upload it. You can also include text in the reply.

  • Aidinz Level 1 Level 1

    Screen Shot 2013-09-15 at 3.51.03 PM.png

     

    It's this dialogue box.

     

    Thanks.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    That is the built-in application firewall. If you're on a private network behind a router, it serves no purpose and you should turn it off. Otherwise follow the instructions in the dialog box.

  • nosiaht Level 1 Level 1

    Hi guys,

     

    I have the same problem and I just want to add my thoughts.

     

    Ok, fair enough, we don't need two firewalls.

     

    But here is the thing that concerns me. The issue for me is, this asking for permission didn't occur on my mac using mavericks and mountain lion. Why should it appear with Yosemite? I don't understand why it needs to ask for permission repeatedly when I have set the program to allow incoming connections from my firewall settings.

     

    It is also the same case with an app that I have allowed access to use the accessibility feature of my mac. Every time I launch, I have to give permission even though it is already listed on my accessibility preference to have permission. I use this app all the time, and having to repeat this process over and over and over again becomes irritating.

    Screen Shot 2014-11-03 at 12.26.06 AM.png

     

    As much as having two firewalls on at a time is not necessary, I believe it is even more not necessary for me have to go through the silly questions if I do chose to leave the firewall on (don't forget the accessibility) and have given permission to let these apps do what they do. To this, I vote that this issue should get some attention by mac and the community.

     

    Have a great one guys,

    Peace.

  • vladsch Level 1 Level 1

    It's been bothering me for a while now. More and more apps trigger this annoying dialog, including PHPStorm, MS Word & Excel for Mac. So out of frustration I went into the Firewall Options and deleted all the entries.

     

    Problem solved. No more dialogs .... For the first launch of the application. However, subsequent launches for PHPStorm trigger the pop up again.

     

    More experiments and google lead to a solution of code signing the application. Instructions here https://gcc.gnu.org/onlinedocs/gnat_ugn/Codesigning-the-Debugger.html

     

    No more annoying dialog! Just have to code sign the rest of the apps that trigger it.

  • hp79 Level 1 Level 1

    It's silly to see some people answering a question that nobody asked. I see this more often in Apple forum than any other.

    Some guy asks how do you do this, and this other genius replies "oh you don't need to do that", or "it's designed this way, you are wrong".

     

    You'll see bunch of replies on questions about how to disable that annoying bong noise when booting a Mac.

     

    Anyways, I found this thread because yes I have firewall enabled and I see coupond trying to ask for permission. I always let it do its thing but that popup keeps poping up on every reboot. I'm on Mavericks because Yosemite sucked and I don't see the Crapitan that promising either even on it's 10.11.1 version. I'll eventually move on to Capitan maybe in the next version though because I have Office 2016 now.

     

    Oh, and I have firewall enabled on my OSX because I have a sketchy software and don't want it to be able to access internet.