7 Replies Latest reply: Apr 22, 2015 11:21 AM by Pedlinron
Steelersfan.54 Level 1 Level 1

Hi guys, I'm running iTunes 11.1 beta 2 on my mac with Lion, everytime time I try to connect my iPhone it says it could not allocate a resource. i did some research and found out that by deleting the files on the /var/db/lockdown and restarting itunes it could get it to work. I did that, but had no luck I also ran some commands on terminal to make iTunes able to r/w on that folder but no luck. It appears that the only way I can get it to work is by downgrading to iTunes 11.0.5 and then upgrading back to itunes 11.1 beta 2. Since I have an Iphone 4 with os 7 gm it wont let me stay on a lower version of itunes, it HAS to be itunes 11.1. But then once I turn off my mac and trn it back on the next day and opnes iTunes, it gives me the same prob. I tried downloading different dmg files for tunes 11.1 thinking it could be the file haveing the problem but no luck.

Anyway, any ideas on how I can get iTunes to work without having to downgarde and upgrading everyday when trying to sync my iPhone???

 

-Thanks in advance!!


iPhone 4, Mac OS X (10.7.5), iOS 7.0 GM ~ iTunes 11.1 beta 2
Solved by Steelersfan.54 on Oct 16, 2013 3:06 PM Solved

I finally got it all working, I think the beta version were messing up my computer, since I upgraded to ios 7 GM and iTunes 11.1 everything works fine. I'm sorry but I can't seem to help you beyond this point :/

  • erikhagstrom Level 1 Level 1

    HI!

     

    So I had the same problem as you had and I solved by disconnecting my iPhone and then delet the files in /var/db/lockdown as well as delete all the preferences files for itunes under /Library/Preferences.

     

    After this I restarted the computer and when it was up running again I connected the iPhone.

     

    If this doesnt work go through the first step and also start up the phone (chose language, connect to wifi (or not connect, it depends if you have that possibility) etc) so that it is up running without the start guide still active.

     

    Then when this is done with the phone connect it to the computer.

     

    Hope this will work for you as well!

     

    Br

    Erik

  • marcfromfort myers Level 1 Level 1

    Ahh i get this message for both my iPhone and ipad running the beta iOS 7. Tried everything. Now I have to take my computer to the apple store cause it won't start!

  • I-need-help-please Level 1 Level 1

    Hey

    How did u you get the download for the latest itunes because i have tried and it doesnt work?? Why?? Please someonr help me cuz i also want to downgrade my ios 7 back to ios 6.1.4!!

  • Bosmankb Level 1 Level 1

    Try hitting the power button and holding down the P key R key and command and option key until you hear a chime 2x on startup. This resets your pram which often solves issues.

     

    I also recommend cleaning up your permissions in disk utility.

     

    I did the delete/var/db/lockdown part and it didnt work until i did a restart then wen i connected my iphone it worked. There may be something to not connecting the iphone till itunes is all up and running too.

  • Good Interface Police Level 1 Level 1

    I have this same thing--when I reinstall iTunes, it works, but only until I put the computer to sleep and/or reboot, and then the same old problem comes back. Deleted the lockdown folder stuff, no help.  Repaired permissions, no help. Reset PRAM, no help.  I have an iPhone 5, but had the same problem with my old iPhone 4.  Have had this problem for a year and a half now.  Have gone through half a dozen versions of iTunes upgrades, no help.  The only thing that works is having a virtual Windows machine in Parallels with iTunes in there, except that's a horribly janky solution.  Since when does Windows work better than Mac?  Come on, Apple!  Where's your support?!?

  • Steelersfan.54 Level 1 Level 1

    I finally got it all working, I think the beta version were messing up my computer, since I upgraded to ios 7 GM and iTunes 11.1 everything works fine. I'm sorry but I can't seem to help you beyond this point :/

  • Pedlinron Level 1 Level 1

    so I have read all of this and I have no, /var/db/lockdown on my computer. I even tried to reload itunes and nothing works. Cannot sync my phone or my ipad. Just keep getting the same message. HELP if you can.. Here is the message:  iTunes could not connect to this iPad. Could not allocate a resource.