7 Replies Latest reply: Apr 25, 2015 5:58 PM by ssid61
John Knowles Level 2 Level 2 (335 points)

All of my bookmarks are organized by folders (and yes I have a lot of them). A few months ago, I moved an important folder (big project I'm working on) to the top of the bookmarks list. I remember something weird happening when I dragged it and let go; Safari freaked out and rolled the folder down to the very bottom of the list. Ever since then, every time I try and move it back to the top or even close to the top it doesn't stay there -- at some point when I relaunch Safari it winds up back at the bottom. I've tried moving it on every device that syncs with my iCloud account (laptop, iPhone, iPad) to make sure it's consistent, but the damned thing just has a mind of its own.

 

Today I tried a new tactic: I created a new bookmark folder, renamed it to match the previous folder (except in all caps) them moved it to the second position from the top. Then I copy-pasted all of the bookamrks into the new folder. And the new folder suddenly disapperared and JUMPED TO THE BOTTOM OF THE LIST right in front of me.

 

????

 

Would Safari hate the name of the folder?

 

JVK

 

10.8.4, MBPro 2008, iPhone 4S, iPad 3

 

<Edited by Host>


MacBook Pro (15-inch Late 2008), OS X Mountain Lion (10.8.4)
  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Might be corrupted preferences John ...

     

     

    Open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Preferences/com.apple.Safari.plist

     

    Click Go then move the com.apple.Safari.plist file to the Trash.

     

     

    Quit and relaunch Safari to test.

  • Linc Davis Level 10 Level 10 (155,735 points)

    This issue can be caused by Safari synchronization in iCloud. You can either disable it in the iCloud preference pane, or use a rather complex workaround found by some ASC members (which perhaps could be improved):

    Back up all data. Disable Safari synchronization on all your devices.

    Rearrange the bookmarks in the Bookmarks window. From the Safari menu bar, select

    File ▹ Export Bookmarks

    and export your bookmarks. Then delete all bookmarks.

    Re-enable Safari synchronization and let it sync the empty bookmark set to all devices.

    Select

    File ▹ Import Bookmarks

    to restore the bookmark set you just deleted. It will sync.

  • John Knowles Level 2 Level 2 (335 points)

    Hi Carolyn,

     

    Thanks but this did not work for me. I'm going to try the next suggestion below and see if it works.

     

    JVK

  • Michael Viergutz1 Level 1 Level 1 (35 points)

    Thanks Lync ! Had the same problem and disabling Safari in iCloud preferences solved the issue

  • AxEffects Level 1 Level 1 (0 points)

    Hey everyone,

     

    I just saw this thread and the answer is way simple.  You don't need to disable Safari in iCloud preferences. The reason this happens is more than likely because you have two or more devices connected to iCloud at the same time. So you have all of those devices trying to write their individual favorites/bookmarks lists to iCloud fighting each other. The answer is to turn off your iPhone & iPads, any other Apple devices, and any other Mac computers you may have running; leave the Mac you are using to edit your bookmarks with on of course. Then go ahead and move anything around that you like. It will work fine. You don't need to have the other devices off to add new bookmarks, they will all add simultaneously. But when you edit, you should turn off all devices except the one you are editing from. Don't disable Safari in iCloud. You are only depriving yourself of the advantages iCloud offers. That simple:

     

    Leaving all devices on when adding a bookmark: OK

    Leaving all devices on when editing bookmarks: NOT OK

    Turn off all devices & computers except the one you want to edit Bookmarks with.

     

    Happy Happy!

  • kinofrad Level 1 Level 1 (10 points)

    Thank you that seems to have worked for me!

  • ssid61 Level 1 Level 1 (0 points)

    I was having this problem in 2015 and read that simple answer of turning off the iPhone (and whatever else connects to the iCloud).  This worked!  Thank you!