3 Replies Latest reply: Sep 13, 2013 6:11 AM by The hatter
Epicravenlord Level 1 Level 1 (0 points)

Im trying to install Adobe LR 5 that I already purchased a product key for. (non refundable) LR5 needs 10.7.0 or higher. Apple is saying that I can't upgrade my OS past my current 10.6.8! WHY NOT! I know its "older" but it still works better than 98% of the windows based computers out there!

 

Does anyone know a work around to this problem or did I just blow $120.00 ... unless I buy a new computer.

 

Anyone interested in LR 5 product key... let me know... I'll sell it cheap.


Mac Pro, Mac OS X (10.6.8)