5 Replies Latest reply: Sep 16, 2013 4:46 PM by Linc Davis
Jerome371 Level 1 Level 1 (0 points)

Hi, I can't buy an app on the store it mark always "... error (100)" ... I already tried all the tutorial you can find in the web, but no result, can you help me please ?

MacBook Air (13-inch Mid 2013), OS X Mountain Lion (10.8.4)
  • Linc Davis Level 10 Level 10 (177,910 points)

    Back up all data.

    From the App Store menu bar, select

    Store ▹ Check for Unfinished Downloads...

    You may be prompted to sign in. If that doesn't solve the problem, quit the application and continue as below.

    Triple-click anywhere in the line below on this page to select it:

    open $TMPDIR../C

    Copy the selected text to the Clipboard (command-C).

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). A folder should open. From that folder, delete the subfolder named "com.apple.appstore".

    Quit Terminal. Launch the App Store and try again.

  • Jerome371 Level 1 Level 1 (0 points)

    Thank you very much for your answer, however I follow all the step and the error (100) is still here.

    I don't understand why it doesn't work...

  • Linc Davis Level 10 Level 10 (177,910 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, or by corruption of certain system caches.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Jerome371 Level 1 Level 1 (0 points)

    Thanks again for your answer ! So in step 1 it said that the app store wants to update but i can't update.. and in step 2 -> error (100)

    And at the end of the two steps the problem is still here..

  • Linc Davis Level 10 Level 10 (177,910 points)

    What exactly happened in Step 1? Did you get the same error message?