2 Replies Latest reply: Oct 20, 2013 4:14 PM by GeoffinVancouver
GeoffinVancouver Level 1 (0 points)

I have a recurring and vexing problem where new appointments entered in iCalendar sometimes get taken out and then replaced with the words "New Entry". I am positive that this has happened repeatedly, that I really do type something into the appointment space, the letters appear on the screen, but then when I go back what I had typed is no longer there and the original "New Entry" is there instead. I have tried to re-create the problem in many ways, typing the entry, then going to a different application, and back to the calendar, but nothing I have tried lets me know how this problem is being created. Any ideas would be appreciated.

Thanks.


MacBook Pro (Retina, 13-inch, Early 2013), iOS 6.1.4
  • mbrakes Level 1 (0 points)

    I get this too - it just happened with an event where I can clearly remember I wrote some important "note to self" points in the event notes which are now gone. Thank you Apple, just what I need.

     

    I remember entering this on my iPad 3, which syncs through iCloud to my laptop, desktop and iPhone4, all running iOS6 or OS X 10.8.

     

    The TimeMachine backup is of course of no use as I can't restore my entire calendar as I don't know at what point in time iCal/iCloud decided to wipe my data, and if I restore everything then I risk wiping out new entries made in the last couple of hours...

     

    Apple have to fix this, and while they're at it also fix TimeMachine so that you can actually browse the Ical window itself in TimeMachine, reviewing changes to, and if necessary restoring, individual events. Not just to protect against iCal/iCloud itself, but against user error as well. Or else TM isn't really helpful as far as iCal is concerned, and I can hardly think of any other data being more mission critical than work appointments. Not showing up for work is supposed to be really, really bad for business...

  • GeoffinVancouver Level 1 (0 points)

    I finally figured it out. After I type something into iCal, if I go a couple of weeks ahead before I have entered it (press the "Enter" key or click on another time) then when I go back my typing is replaced with "New Entry". Amazingly, this does not happen if I just move one week ahead or if I type a new appointment on previous weeks. I can type something into an appointment time, not "enter" it, then enter something for the following week, and when I go back what I have typed is still there. I checked it out several times, trying different variations, and moving two or more weeks ahead in my calendar without first "entering" my typing results in my typing being replaced with "New Entry". That solves my problem: make sure I "enter" every appointment before I go to a different week. It's a pretty strange glitch though.