3 Replies Latest reply: Sep 15, 2013 11:45 AM by Victoria Herring
Victoria Herring Level 2 (290 points)

I have Aperture 3.4.5 and started a new library with importing of about 6000 images from some disks [DVDs] made at the time the pics were taken.  Almost all came in just fine, but there are a bunch of them which have that triangle on black "unsupported format" - but all the other pictures are just fine.  They were taken with a Canon 20D mostly and I did run reprocessing.  I don't know why they come in unsupported but thought I would ask first here.  Thanks.

Mac Pro, Mac OS X (10.7.5), 17G RAM
  • Kirby Krieger Level 6 (12,510 points)

    Have you tried re-importing a few that aren't recognized?  This would rule out problems with the drives/readers.


    I'm seeing this fairly often with card readers.  I don't use DVD's, but it's worth ruling out, imho.  You might clean the disks, too.  Can you open the unrecognized files in OS X's Preview app?

  • Victoria Herring Level 2 (290 points)

    Good ideas...I'll try them out === I did open the DVDs and brought in the images [because Toast was used to burn them I had to click and drag from DVDs but they all seemed to come in] - I have isolated the 300 or so bad ones and will see if they can be reimported or see what they look like without any Aperture processing..thanks.

  • Victoria Herring Level 2 (290 points)

    I have repaired permissions in the Finder in Show Package Contents on the folder with all the images, I have quit and restarted Aperture, I have repaired permissions in Aperture, rebuilt the database etc.  I did identify one of the 400 and pulled it to the desktop and tried to open it with PhotoshopElements9 -= it opened but all as garbage.


    I'm now reimporting th eimages to see if there is any change in them between this 'new' library and the old one.  The pics are on a set of DVDs that was burned to keep them for the future [HA!] - it was hard enough to get them off the Toast burned disks [proprietary crap] but I was able to do that = but now I have this batch that either ends up blacked out with Unsupported Image Format on front or else looking terribe  - like the image was only partly copied over - don't know yet if that's the fault of Toasting or ClickDrag or Aperture = mighe know more once the new batch is imported.  Thanks for the help.