4 Replies Latest reply: Dec 20, 2013 2:41 PM by easyringo
berocketman Level 1 Level 1

Hi folks, I'm running a 15" MBP Mid 2009.

  • 2.8 Core 2 Duo
  • 8 GB RAM
  • Nvidia GeForce 9400M 256 Mb
  • OSX 10.8.5


Just this weekend I purchased Mountain Lion and decided to start completely fresh. Used the AppStore download to create a USB boot disk. Removed all existing partitions (Read: used disk utility to erase and format as MacOS Extended (journaled)). Installed the fresh copy of OSX to this new partition. Once in the OS I configured my settings, installed iLife and Office and updated all software. All is well with OSX, now it's time for Windows 7.


I run bootcamp assistant. I resize the partitions such that Windows gets 250GB and MacOS gets 500GB. It prepares a usb stick with support files on it then makes sure it's not bootable. I insert my Windows 7 Ultimate disk and get ready to reboot.


Once I reboot I can hear the disk churning and working but the screen is completely black. Tried closing and opening the lid and nothing. Eventually my only choice is to hold the power button for 5 seconds. I use the option key to boot back into OSX fine and everything is as expected there.


For reference the disk i am using is the same exact disk I had used previously to install Windows to this very machine. I have also tested it on other PC's to verify it is bootable so that may rule out a lot of the common suggestions. I also re-burned the same iso at a slower speed and I'm getting the same results with both disks.


What I've found on the web and/or tried:

http://support.apple.com/kb/TS3173 - Seems to be related to the iMac of the same year. I'm hesitant to install iMac drivers on a MBP. However I have a feeling that the issue might be related.


http://support.apple.com/kb/TS2600 - Resetting PRAM and SMC did not resolve the issue. Still unable to boot to the Windows 7 Boot disk


http://support.apple.com/kb/TS4536 - This described a different problem as I do not have the blinking cursor, however I did try removing the USB drive that OSX prepares but no luck there either.


http://apple.stackexchange.com/questions/12275/black-screen-when-installing-boot -camp - References the first 2 KBs I found but the interesting suggestion here was to try a second monitor. The best I had available was a mini display port to VGA and using a VGA-to-DVI cable to talk to my monitor (which has no VGA port). No luck there. tried plugging/unplugging the adapter a few times.


http://forums.macrumors.com/showthread.php?t=1229631 - On this thread, Post #18 suggests that the new EFI does not allow booting off CD and apparently the USB stick needs to be bootable to make changes to the EFI to allow it to boot from CD. I'm not sure about the validity of this claim but I did download the BootCamp 4.0.4033 for the MBP mid 2009 to try to make a bootable USB - This is on my list of 'to try' items


I knew I was hitting a point where pretty soon I won't be able to self-prescribe the solution so I came to the community for answers. 

MacBook Pro, OS X Mountain Lion (10.8.5), bootcamp windows 7
  • berocketman Level 1 Level 1

    I have a case open with Apple Support. It is currently in escalation. I will update this thread once I have more information from them.


    In the meantime I have tried:


    Created a slipstreamed Windows 7 install image with the apple drivers available for my MBP in the bootcamp support files and made both a DVD and a USB install. Both drives are verified bootable, neither resolved the blackscreen issue. Either the graphics driver is not the issue or the drivers I slipstreamed into the install did not work.


    Any other thoughts or troubleshooting ideas are greatly appreciated at this time while I wait until Friday for escalation to get back to me.

  • Nemolo Level 1 Level 1

    i have exactly the same issues, i'm trying everything that came up on my mind, i'll let you know if i manage to get the installation done. Please let me know if you find the solution.

  • wadek2 Level 1 Level 1

    I am having the same problem and I think I may have figured it out. Try downloading the updates to your USB. Then Eject the USB. Then install windows from the disc. After Windows has installed then put in your USB and double click on the .exe file.

  • easyringo Level 1 Level 1

    Any luck with the issue? Having the exact same problem with the same hardware (15" mid-2009 mbp, 2.8 core duo)