1 Reply Latest reply: Sep 16, 2013 12:24 PM by baltwo
jeffgardendotcom Level 1 Level 1 (0 points)

So I have thousands of photos, saved in folders (i.e. not iPhoto or Aperture Library or anything like that, just as individual files).  When I try to open them from the external drive, I get an alert that the photo can not be opened because I do not have the correct permissions to access the file.

 

On the drive, I have read/write for all users and admin but aside from that, the "ignore permissions" checkbox is checked too. 

 

So I first tried unchecking that so maybe it'll look to the invididual user priveledges instead but that didn't work.  I then copy/paste one of the photos to my desktop, and I get the same error. 

 

Is there a way to reset all permissions on the drive for all the files ? I'm not sure how I can access the photos now  :

 

 

OS is 10.8.5 (was doing this on 10.8.4 too)


MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)
  • baltwo Level 9 Level 9 (62,210 points)

    Copy these commands into TextEdit, replace the bracketed part with your username w/o the brackets and the quoted parts with the ext HD's name, retaining the quotes.

     

    sudo chflags 0 /Volumes/"name of ext HD"

    sudo chmod a+rx /Volumes/"name of ext HD"

    sudo chown -R <your username>:admin /Volumes/"name of ext HD"

     

    Launch the Terminal app in /Applications/Utilities/, copy and paste the first one into the window that pops up, and hit the return key. When the Password: prompt pops up, carefully type in your admin password, since nothing shows on the screen, and hit the return key. Copy & paste the other two, one at a time, following each with hitting the return key. You won't get the password prompt, since the initial one's good for five minutes.

     

    Quit the Terminal app and you should be able to read and write to the ext HD. This assumes there's no OS or Time Machine backup on the HD. If there is, don't run the third command.