Previous 1 2 3 Next 93 Replies Latest reply: Mar 30, 2016 2:03 AM by escharfe
Stryker3k Level 1 Level 1



I have a 3rd gen ATV which has never really given me any trouble, but for the last 6-8 weeks or so, it has been stalling when trying to load movies where it never used to have any problems at all. I have checked and rechecked my network and conducted numourous speedtests at numourous times of the day and night and my speed tests are all pretty consistant at 21Mbps Down and 1 Mbps up and with a 20ms ping.


My ATV is connected to a Netgear D6300 via ethernet and HD video streaming is fine on other medium such as youtube via my iPhone/iPad/PC etc.

I will say though, i have noticed downloading from itunes to my iPhone or iPad has slowed recently too.


I have reset my ATV back to factory and that did not seen to fix the issue's either.


My ATV sits on a shelf under my TV and in between a XBOX360 that is not connected to power and a PS3 that is on most of the time as it is my PVR and above a Wii U that is connected to power but not turned on. I am not sure if it's location makes a difference, but it as always sat there.


Any ideas that could perhaps help me out?

Apple TV
  • griff w Level 4 Level 4

    Hi there,


    I would recommend taking a look at the troubleshooting steps found in the article below.


    Apple TV (2nd and 3rd generation): Troubleshooting playback performance


    -Griff W.

  • Stryker3k Level 1 Level 1

    Thanks Griff,


    That is pretty basic stuff of which does not really affect me. My internet is plenty fast enough and I am currently using my ISP's DNS (although i have tried it with Google's Public DNS) and it is connected via ethernet, not wireless.


    I probably should have stated above that I work in I.T and have done all my home network troubleshooting including trying 3 different routers. Everything else runs fine except the Apple TV.


    I did go in to my local apple store and the tech there told me it is an Apple server issue and he knows of plenty of people who have the same issue including himself. He said that there is nothing that can be done about it. In his words, "you try to do the right thing and purchase movies only to have them take hours to load." And thats why he has resorted back to torrenting.


    So i am not holding high hopes of getting this issue resolved.

  • RonEdwards Level 1 Level 1

    I have exactly the same problem and for the life of me can't figure out why!!! It has always been fine, it's only started happening in the last month or so!!!

  • kramerd1 Level 1 Level 1

    I have the same problem, isolated to Netflix.


    1.  Select some content on Netflix and play it.

    2.  Netflix pauses, say at 4:10 into the content.

    3.  Fast forward beyond 4:10 and it plays again (immediately)

    4.  Rewind before 4:10 and it plays again UNTIL it reaches 4:10 again.

    5. Try this on my iOS device (iPhone 4 over 3G), no issue

    6. Try this on my MacBook Pro running wifi over same network as ATV3, no issue.

    7.  My ATV3 is hardwired

    8.  I have tested the wires for noise (yes I own a TDR that does a signal strength test)

    9.  Reset AT3 by unplugging CAT 5e, HDMI, power and waiting 5 minutes.

    10.  Tried software resets

    11.  I have business class high speed cable


    Yet the results remain repeatable.   Same content, same time index, same symptom.   


    If this were a bandwidth issue or router issue then other devices on the network should have had the same problems.   If it were my ISP, then my cellular provider would have had similar issues given my thruput is much lower.  


    The fact it happens ALWAYS at the same time index is either a miracle of random chance or it means Netflix / ATV3 have software issue that the hardware is unable to deal with.


    If I talk to Apple, they just send me to Netflix, if I talk to Netflix, they just conclude it is my hardware.  This is an entertainment device.  I don't have a lot of time for entertainment and when I go to it, I do not expect to have to troubleshoot it.  


    Has anyone experienced this on Roku or Hulu?  Sould I change devices / content providers?


    I'm an Apple fan (back to the Mac Plus) , but only because the products work, and this one is not. 

  • Sld0169 Level 1 Level 1

    I have an Ipad 4th gen and until the upgrade to 7 I had no issues with video.  Now, I am having the same all of you describe.  This is what I loved best about my ipad.  Now, I am considering something else.  Hulu, Amazon videos, and all other video sources I use experience the same.... Grrrrrr

  • cabvip Level 1 Level 1

    I have the same problem and I have a window to return it until black friday comes along to see my alternatives. I use this to mirror and it is all fine. But netflix is the biggest problem with buffer. It stops like into the movie when i stream content from netflix and then i would have to switch to my ps3 to watch netflix on there because there is no issue on ps3. So i think it is the plist or whatever it is for netflix with apple tv 3 that is causing the problem. I have tried rebooting it. I am on latest os for apple tv still no clear answers or solutions. Im bumping this. We need a solution.

  • nttx Level 1 Level 1

    I have same problem as described above. Some additional info hopefully helpful to somebody:


    + I am visiting Chicago from Dallas, for a week. Never have problem there, now my iPad mini and iPhones 4 freez playing Netflix and even iTunes Radio!


    + Mac Book Pro seems to be OK or at least I don't remember any.


    + Just bought a brand new Apple TV (here in Chicago) and it freezes playing Netflix, PBS, Yahoo! Screen .... Happens with Wifi or wire (Ethernet). I can not watch any show longer than than 5-10 minutes without problem.


    + I was blaming the ISP and Wifi router until find out my wife's Windows 8 laptop has no problem what so ever -- via wifi! Neither her Samsung Galaxy S4 via wifi.


    Apparently this happens to some of us and it may depend on where we are. Perhaps problem is with Apple servers that serves your area? And Apple is too big to care for problems that do not make it to national news!

  • mkovler Level 1 Level 1

    I have the same problem now for the past few weeks.


    Another symptom is that movie previews steam fine - nice and fast - but the rentd and purhased movies take forever buffering every 8 or so minutes. I have 3 Apple TV's and since the last update - which killed one of them - performance has been very slow.


    Any assistance would be grealty appreciated.

  • MelissaK24 Level 1 Level 1

    Hi. So is this a problem Apple never intends on addressing? I have made numerous calls to Apple and they act like this is an isolated issue and "haven't heard of this issue affecting anyone else." I really hope they fix this soon!

  • JMcclure13 Level 1 Level 1

    I have the same issue. And it started right after Apple put out the update for Apple TV. There is no fix unless they do something about it. My ATV is hardwired and every other device in my house operates wirelessly. My smart TV doesn't have this problem, my Ipad, IMac, MacBook... NOTHING has this issue. It's at the point where it buffers longer than it plays.


    <Edited By Host>

  • RonEdwards Level 1 Level 1

    I had the same issue, but have found the latest update has fixed the problem on all my ATVs.....

  • MelissaK24 Level 1 Level 1

    So I spoke with my IT guy from my job and he told me to delete some of the devices I authorized in my iTunes account. Turns out I authorized the max amount of devices. I'm not sure why this all of a sudden started giving me problems since the update but once I deleted a few devices that I no longer used/had my ATV was completely fixed. All my movies/tv shows played instantly. Hope this works for everyone else.

  • cabvip Level 1 Level 1

    I have only 1 device and it is still jittery. Tried all solutions, only issue is it is still netflix conflicting with the apple tv (3). Not with my ps3 or on my laptop or on my phone. Just the apple tv. -.-

  • abovat Level 1 Level 1

    My apple TV has been doing the same while my Roku works with no issues so It does not appear to be the connection.  I can't figure out the issue either but I have noticed speed issues with all of my apple products recently.

Previous 1 2 3 Next