5 Replies Latest reply: Oct 21, 2013 11:57 AM by nvssm
azartguy Level 1 Level 1 (0 points)

Hello one and all, I'm back with the same problem. Using Aperture 3 I kept getting "unsupported file format" error messages for PSD files edited in Photoshop CS4. Nobody had a solution, but Apple Tech Support said the problem wasn't with Aperture but CS4 and strongly recommended upgrading.

 

So I did. Now when I use Aperture 3 and "Edit with Photoshop CC" this is what I get. Looks like the same problem. Notice the green labeled file in that stack? If I use Photoshop to save-as to my desktop, then drag the same file into Aperture, no more error message. While waiting for a Tech Support suggestion, any ideas from the Forum?

Brian

 

Screen Shot 2013-09-16 at 8.04.14 PM.png


iPad 2, OS X Mountain Lion (10.8.2)
  • dbmoore Level 1 Level 1 (105 points)

    I'll try.   in PS preferences make sure  file handling is set for backwords compatibility.   Sometimes you can fix unsupported file formate by reprocessing in AP.  Go to menu bar under Photo and Reprocess Original.  If that doesnt work and your images are reference then go to file and Show in finder.  In the finder double click on the file to open it in PS and make some minor changes like spotting for dust, save and allow AP to rebuld the thumbnall. If they are managed files you could try exporting the originals and reimporting.  Or make an album of the files in question and export them as a library and reimport. If it is from a PS 4 issue then opening them, making a change or crop and saving should take care of it.   If that doesnt work and Im sure I have forgotten something you might have to consider the files as damaged and not usable. good luck and let us know.

  • azartguy Level 1 Level 1 (0 points)

    As shown below, the original file (BAL4899) was imported into Aperture and it's fine. Then it went out to PS to edit and the problem occurred:    folder>Aperture>Edit with Photoshop CC > Save

    The file came back "unsupported", then I tried Aperture > Export Original > Preview and now the file is fine:  it can be opened in  Photoshop, it can be dragged back into Aperture but without the edit Badge.

     

    I think I've elminated the variables, so unless I'm missing something, the problem is Aperture reading it's own versions? Regardless of what Apple Support says, this is an Aperture problem that they can't/won't fix.

    Brian

    Screen Shot 2013-09-27 at 1.31.11 PM.png

  • nvssm Level 1 Level 1 (10 points)

    I just had this happen to me --- first time I've seen this in a long time --- using Aperture 3 and Photoshop CC

  • azartguy Level 1 Level 1 (0 points)

    David,

     

    I trashed Aperture. The $80 lost wasn't worth the ongoing frustration.

     

    There was no help to be found here that solved the problem and no solution from Apple techs after three tries other than the clunky work-around of deleting the apperture.plist file then rebuilding Preferences over and over. I went back to Bridge CC to organize. It isn't as elegant, as easy or as flexible, but it works. Good luck,

    Brian

  • nvssm Level 1 Level 1 (10 points)

    I didn't have to trash Aperture. I just disabled the "Use Adobe RAW" option, saved the photoshop file again and it showed up in Aperture immediately.

     

    I have many thousands of images in Aperture, mostly cataloged. It would be non trivial to move.

     

    However, the real takeaway here is simple (for others who may run into this problem).....after saving a file in Photoshop, don't quit Photoshop immediately. Instead just switch back to Aperture and check that the saved version is now visible. Once you've checked that it is, you can safely quit Photoshop. If it isn't, you can go back and save the image again, perhaps with a different name, and reimport to Aperture (worst case)