7 Replies Latest reply: Nov 27, 2013 4:26 PM by JacksonML Branched to a new discussion.
Hunter18228 Level 1 Level 1 (35 points)

I don't understand why it can't get ios 7 I know it can support it because it may be sluggish but the Iphone 4 can get it but the ipod touch 4 can't


iPod touch, iOS 6.1, iPod touch 4g
  • lllaass Level 10 Level 10 (157,390 points)

    All the iOS devices compatible (iPhone 4 and later, iPad 2 and later, and 5G iPod touch) with iOS 7 have at least 512 MB of memory. The 4G only has 256 MB

  • Hunter18228 Level 1 Level 1 (35 points)

    I know but they could just have a dumbed down version just for the ipod touch 4g. Right??

  • lllaass Level 10 Level 10 (157,390 points)

    You have it, it is iOS 6.1.3

  • doyall Level 1 Level 1 (0 points)

    It's not really the lack of support for iOS 7 with the Touch 4 that I am concerned with ... it is the fact that there are some 80 (yes EIGHTY) vulnerabilities that presumably exist in iOS 6 that were fixed with iOS 7 that may not be addressed in iOS 6 at all that bothers me. Some of the vulns are pretty nasty.  Rise to arms ... contact Apple at Apple - iPod touch – Feedback and let them know the issues need to be addressed in iOS 6.  I accept the fact that the hardware limitations on the Touch 4 preclude use of iOS 7 but cannot accept the fact that Apple might decline to fix them just because they do not feel like it.

  • Hunter18228 Level 1 Level 1 (35 points)

    Thanks for giving me the feedback link I gave them a suggestion to maybe just push an update out and just have iOS 7 look and maybe some security features and not really any new features just look.

  • Akaslips Level 1 Level 1 (0 points)

    Some apps I can't install on ios 6.1.3 they say you have to have ios 7. How is that fair to the people that have 4th gen iPod touchs? It's not like the 4th gens are that old yet.

  • JacksonML Level 1 Level 1 (15 points)

    I had an iPod Touch 3rd generation since 2010. I've used it, even though I couldn't download half the apps I wanted, because I couldn't get iOS 6. I finally got an iPhone 4S, but I survived with the old device. And its because with every new update, there's new programming capabilites. Because apple doesn't provide an update for older devices containing at least some of the new API's, then we can't get the apps that use them. And normally apps that need them wil use them to better their apps. Its the (problem) with today's technology. Its changing so quickly and it makes you upgrade constantly. Its sort of like the upgrade every year or whatever plan commercial. The guy's phone is gettting old, but he can't upgrade because of the contract. Its sort of the opposite though. We're being forced to upgrade to get newer and better things. Just like normal computers