Previous 1 3 4 5 6 7 Next 124 Replies Latest reply: Jul 10, 2014 10:47 AM by pggrg1 Go to original post Branched to a new discussion.
  • walshalexm Level 1 (0 points)

    i had the same problem, installed ios7 on my iphone 5, then facetime and imessage wouldn't work and everytime I went onto whatsapp, snapchat, instagram, facebook, twitter etc i got the notification "connect to itunes to use push notifications". I followed Buggerlugs61 instructions (where he has attached the screenshot) and it has fixed my problem! thank you so much

  • dmayo2 Level 1 (0 points)

    I skipped the 7.0 update, and just started with 7.0.2 and have encountered this issue of push notifications not working and the notice that it's not, continuously looping. Grrr.


    Following instructions provided....backed up phone, restored 4S to factory, restore from backup (as asked from within itunes).


    Had to re-sign-in with many apps:



    Kindle (and re-sync all media)








    1 hour 12 minutes to complete. All seems ok.

  • jjdeberry Level 1 (0 points)

    I'm an Apple Advisor, and what we do to get around this issue is by creating an itunes or icloud backup, then restoring the phone to factory settings using iTunes, and restoring from that backup. That should work. Best of luck!

  • fabin69 Level 1 (0 points)

    Hi jjdeberry,


    I didnt quite understand something you said in your last reply:



    You said:



    I'm an Apple Advisor, and what we do to get around this issue is by creating an itunes or icloud backup, then restoring the phone to factory settings using iTunes, and restoring from that backup. That should work. Best of luck!"


    My question is, just to be sure, restoring the phone to factory settings can be done by either iTunes and the iCloud, am I right?



  • saintmykel Level 1 (0 points)

    i am also having the same issue...  using iphone 4s on ios7....  such a hassle since i always use iMessage....  all my apps no longer push notifications.... 


    Apple please fix this!!!!

  • tanaahides Level 1 (0 points)

    help.png So i know this is way late considering when you and everyone went through this update problem. But I had updated my phone last night, said i needed to connect to itunes pluse imessage refused to activate. I tried every possible solution besides restoring it to its factory settings. But now i figured it's worth a try. I clicked where it said restore iphone. But at the top it says it is dowloading sonething. My phones plugged in and working like nothing is happening and its been connected for awhile.. is this what it does when it restors to factory settings or?

  • crappapaul Level 1 (0 points)

    OK, finally got push and messages working. Had to upgrade iTunes in computer first to match ios7. Then I backed up the iPhone5 to iTunes. Restored to factory settings, then restored from backup. Did this on the iPhone hotspot. Had to do the restore part using my wife's iphone as the hotspot. I can send and receive imessage texts now. I am not getting the "connect to itunes for push notifications" warnings anymore. Even though I did a sync before I started this, I now have over 50 apps to update. Will wait until I can get to wifi before doing that.


    As a temp fix, my wife and I both turned off imessage so our texts went via cellular account.  This did eliminate the iPads from the loop however.

  • colasmar Level 1 (0 points)

    Hello, sorry because i'm a french user and I'm not sure To understand all.

    I have the same problem with push notifications with my new iPhone 5s and IOS 7.02. I'm using IPhone since a long time and I'm sure to know how to configure the notifications center.

    Also, after a call to AppleCare I restored my new Iphome 5s to factory settings and reinstalled the backup from ICloud. I have always the problem.

    I hope to find a easy solution because It's a long time to reinstall all... Is it definitively a bug or have you a solution ? If it's possible I would like a "step by step help" to be sure to understand.


    Ps : for example, actually, i receive notifications for meeting, tasks, App Store, the game "Culimot", prixing, but nothing from Allocime, Weather pro, Figaro...


    Thanks for your help

  • Hameedsh Level 1 (0 points)

    take a backup and restore your phone it will work, my phone was totally ****** up after upgrading to ios 7 too many issues, but restoring solved em all

  • colasmar Level 1 (0 points)

    Thank you for this answer but it's exactly what I did previously and I have always the problem...

    Perhaps the apps are not compatible with IOS 7 notification system...

  • ChloeLovesJesus Level 1 (0 points)

    Having the same problem..... I know it says to back up to icloud and restore to factory but my problem is that I don't have ANYMORE icloud storage left and I can't buy more so I haven't backed up in over 40 weeks... Is it possible to clean up my ickoud storage? HELP!!!

  • BangkokDangerous Level 1 (0 points)

    Then back up to your computer if you have one using iTunes. If you don't have a computer then the only option is to buy one or borrow a friends. Then back up your phone there. As for your music, music, videos, and apps hopefully you can redownload them to your friends computer from apple using icloud. All purchased content is stored in icloud for free as long as it is still available in the App Store. For any content not purchased from the App Store you would have needed a computer to load that content onto your phone using iTunes so I would assume you still have those files on your computer or the computer you used to load the files to your phone. Hope this helps!

  • Hameedsh Level 1 (0 points)

    no it has nothin to do with the apps, its gonna fix it, give it a try, I had many other problems and my phone was out of order sort of, but restoring fixed everything, I hope it works for you as well

  • ClionaM Level 1 (0 points)

    Followed exactly what you said and still lost everything...apps etc not showing on itunes even, now. So fecked off with this whole ios7 mess. Your fix seemed so clear and had fingers crossed. I'm not even getting a choice to restore to the back up I did earlier today before the whole restore to factory settings thing. Feel like throwing the phone out the window!

  • Lahwiz Level 1 (0 points)

    Thanks a lot man (buggerlugs61) it took me  **** of a long time but ur instructions worked perfect! Thanks again G!

Previous 1 3 4 5 6 7 Next