Previous 1 40 41 42 43 44 Next 653 Replies Latest reply: Apr 13, 2015 1:34 AM by Also29 Go to original post Branched to a new discussion.
  • westlakesteve Level 1 Level 1 (0 points)

    Resetting Network Settings worked for me.  Thank you.

  • katharineanne Level 1 Level 1 (5 points)

    Thank you!  I tried everything but finally this worked! 

  • bbean177 Level 1 Level 1 (0 points)

    Thank you so much for reposting this. After trying different things for an hour or so, this one worked (although I did have to keep an eye out for the message popping up on my macbook asking if I was okay adding my phone number to the account).

     

    It's definitely worth a try to logout of iTunes, turn off the phone, turn it on again, log back into iTunes and then try logging into iMessage/Facetime again.

  • Rob Bowers Level 1 Level 1 (0 points)

    I was unable to login to FaceTime or Messages on iPad. Turns out, I had not associated my icloud email on iPhone for FT or iMessages, and I could not activate the email addresses via WiFi.

     

    So, using 4g/LTE on iPhone, I associated my icloud account with these apps. Then, I repeated on iPad while connected to WiFi, badda-bing.

     

    Not sure if iOS 7.1 unlinked email from iphone number... I did a restore recently, maybe that is what did it.

  • shanny. Level 1 Level 1 (0 points)

    THIS DID IT! My computer got sent in, clock was off and not automatic. Been working on this for hours and this was the fix to everything.

     

    THANK YOU!

  • Jazzmast3r Level 1 Level 1 (0 points)

    Thanks to "Fidged." This worked the first time I tried it!

     

    GO AND CHECK AND MAKE SURE THE TIME AND DATE IS SET TO "AUTOMATIC"

     

    Somehow, after the update to ios 7.1 my date setting was reset to "Manual." After setting it back to "AUTOMATIC" I was able to active my iMessage and FaceTime almost instantly.

  • Haitham.mostafa Level 1 Level 1 (0 points)

    Hello All,

    I work in a mobile operator in Egypt, I faced the same problem, and I tried many solutions but found out at the end that it's something related to the operator...

    Some operators have what called "SMS Anti-Spam". to monitor the imcoming SMS traffic originated from different countries (to prevent spam messages targeting their customers, or for security and political reasons).

    Sometimes these network nodes are blocking the activation messages from being delivered to you if these messages are originated from a country (or a network) that is not trusted by your operator. and the problem that apple is not using the same network to submit the activation message all the time so that operators all over the world can trust this network.

    Apple should notify all operators allover the world if they are changing the originating operator to avoid this case.

     

    I solved that problem by contacting the operator and made sure that they originating network is allowed to terminate SMS to my network.

     

    Please be cautious as if this is your case, you will be charged for an international SMS everytime you try to switch off/on the iMessage toggle.

  • Chague62 Level 1 Level 1 (0 points)

    After many attempts I finally figured it out. You have to go to >settings, >messages, > send & receive. Make sure your Mac email (me.com) is selected. You have to set same accounts on all apple products you want to sync to each other.

  • henthornferguson Level 1 Level 1 (0 points)

    I did that and it asks for a 4 digit password and it's not the pass lock I have on my phone. How else would I know what the pass code is?

  • henthornferguson Level 1 Level 1 (0 points)

    When I try to reset my network settings it asks for a 4 digit pass code? I thought it was the pass code lock on my phone and it's not. How else do I know what the pass code is??

  • Jackiefromirl Level 1 Level 1 (0 points)

    Same thing happened to me and I checked the time and date in settings, turns out I was set at an American time zone. When I changed it to Ireland. Dublin. I tried again and it worked straight away. Hope this helps guys :-)

  • timothy62 Level 1 Level 1 (0 points)

    This solution worked for me. It turns out I needed to was activate my apple ID under Setting>Messages.

     

    Thank you

  • getvladimir Level 1 Level 1 (0 points)

    Thank you all for sharing your knowledge and experience here!

     

    I have been having issues with iMessage and FaceTime activation before, and I wanted to share the information and experience I gathered from it and put all the solutions in one place.

     

    I've created a video tutorial with a step-by-step procedure that will fix most iMessage and FaceTime activation issues, including being stuck on "Waiting for activation..."

     

    https://www.youtube.com/watch?v=Mu7K7XLlZ6E

     

    Because it covers most situations, you might find that some of the steps are unnecessary for your particular issue, but it doesn't hurt to do them all.

     

     

    I hope you'll find it useful

  • Tinkerbellipod Level 1 Level 1 (0 points)

    iMessage and FaceTime are wonderful, empowering, enabling technologies that... can frustrate the crap out of you at times. One of those times is when you update or restore your iPhone, iPod touch, or iPad to a new operating system - like millions of people just did with iOS 7 - and it stops working. If you're having trouble with iMessage or FaceTime, if they won't activate or simply won't work, here are some things you can try!

     

    How to turn FaceTime or iMessage off and then back on in Settings

     

    Launch Settings by tapping the icon on the Home screen

    Scroll down to Messages or FaceTime

    Toggle the switch from on (green) to off (white)

    Wait a minute

    Toggle the switch back to on (green)

    Wait for it to re-activate

    How to hard reboot your iPhone, iPod touch, or iPad

     

    Make sure you're on Wi-Fi

    Hold down both the Home button on the front, and the Sleep/Wake button on the top of your device

    Wait for the Apple logo to appear

    If it still doesn't work, repeat step 1 (turning FaceTime or iMessage off and on)

  • smcrage Level 1 Level 1 (0 points)

    This is another shout-out to Mahler444's procedure, November 8 2013, currently on p. 36

     

    I am in Turkey, on a Turkish cell phone number, but I am from the US and my Apple ID is based there. Apple kept sending SMS's to England (at my cost!) and not getting the response (see Haitham.mostafa, above). I had restarted, reset the date & time, gotten on WiFi, gotten off WiFi, reset network settings

     

    Mahler444 suggested:
    1) Make sure your date & time is correct. (He said make sure it's on automatic, but if automatic isn't getting it right for you, try setting it to the correct place manually. Apple's iMessage support page says it has to be correct, not on automatic.)


    2) Get out of Apple ID accounts

    -log off of iTunes & App Store (Settings->iTunes&App Store)

    -delete your iCloud account (you can't just log off. On my phone the delete button's at the bottom of the Settings->iCloud screen. If you use FindMyPhone you have to enter a password to deactivate it.)

     

    3) Turn off the phone for a while

     

    4) Turn the phone back on (and unlock your SIM card if you have to)

     

    5) After iMessaging successfully activates--I could tell because the Send & Receive menu item came back--log back on to your accounts. (iCloud automatically asked me if I wanted FindMyPhone.)