Previous 1 6 7 8 9 10 Next 184 Replies Latest reply: May 28, 2015 4:43 PM by HeySteven Go to original post Branched to a new discussion.
  • decemo Level 1 Level 1

    Worked PEEEERFECTLY Thanks Shanev44






    You need to delete your current hotmail account set up on your iphone.


    Once this has done click 'Add Account' and select the new '' tab.


    Set  up your hotmail account again from scratch and this will then allow you  to select how many weeks/months of emails you sync to your phone.


    Im  not sure if anyone else had a similar problem to me prior to iOS 7, but  if i deleted an email from my hotmail account on my iphone - it wouldnt  sync with my actual hotmail account. So when i logged in online all the  emails I had deleted on my phone would still be showing as unread.


    But by setting the account up as above, they now sync perfectly.

  • colory Level 1 Level 1

    Lucky you, but the problem isn't only for Hotmail. I cant update to ios 7.0.3 because I have not enough space fot the 10.000 and more emails downloaded! ***!! I hope apple will resolve this ridicolous problem!

  • netzach63 Level 1 Level 1

    With all due respect, people, limiting you iOS device to the last 50 messages encourages sloppy inbox management. 20K messages in an Inbox?!?  Your goal should be zero.


    This is just a guess, but now that Apple is getting into the email business its ownself, it would be to their advantage to encourage people to manage thier inboxes better.  For heavens sake, people - set up some archive folders on the server.  Keep the messages you think you'll have to refer to some day!  Delete everything else!


    If I looked at the physical inbox on your desk at work, would it be piled floor to ceiling, with junk?  Of course not! You keep it empty and either file, toss, delegate, or act on everything that gets dropped into it.  Your email inbox should be no different.


    See: -in-24-hours/

  • kobimaru Level 1 Level 1

    Hey.. what gives with the reply.  I don't need you telling me how to run my email life.  I have reasons for what I do and I don't give a rat's butt about what you think I should do. If you want to make a useful comment on how to fix an apple issue, then fine.  If not, then shut up.  I guess you want to limit transfats and limit my use to 16 ounce drinks as well. 

  • BittenByAZebra Level 1 Level 1

    Apple has done some stupid things before and this is definitely one of them.


    Until Apple fixes the problem, I've been using AltaMail, which you can buy in the app store. I like some things about the app better than iOS mail but iOS mail is worthless if it will just suck up storage space on my iPhone. Unless, of course, I want to delete each of the 2000+ emails one by one.


    Good times, Apple. Why not get your act together and really LISTEN to the people who are talking?


    In the meantime, go here and let Apple know how much you hate that they removed this feature:

  • Yumbo Level 1 Level 1

    This reminds me of protests when they dropped the floppy disk.

    I like what they did then, and now.

    IMAP is what they want people to use.

  • netzach63 Level 1 Level 1

    Far be it from me to limit your transfats and soda choices. All I'm suggesting is that if your clothes aren't fitting properly any more, the problem might not be the responsibility of McDonkadonk's.

  • Mariachi90 Level 1 Level 1

    And what would you think of a 300 message limit for an IMAP inbox - if you spend the whole week visiting customers and only downloading the messages on Fridays. Are you going to call me fat or lazy as well? 300 messages limit is a joke. And it is part of this issue discussed here. If I can limit to 50 so it works then it is better than being a%#l a about my inbox. Emails are ment as a tool not not rule your life.

  • Yumbo Level 1 Level 1

    No IMAP limit here.

  • engmo83 Level 1 Level 1

    I Have the same problem

  • crazyadventures Level 1 Level 1

    Here's what just worked for me for gmail -


    Go to your gmail account on a browser by typing


    Click the gear to the right and select "settings"


    Navigate to "Forwarding and POP/IMAP" and scroll to the bottom where it says, "folder size limits"


    Select "limit IMAP folders to contain no more than this many messages" with 1000 selected.


    Click "save changes"


    Refresh your email on your phone. It will drop to 1000.


    Repeat for every gmail account ( if you have more than one)


    Next, go into each gmail account on your phone and click "edit" then "select all" to "mark as read"


    The number will drop, but not 0 out yet. Go back into your email, scroll as far down as you can go, go back out, refresh. The number should be 0 now.


    Repeat for all additional gmail accounts.

  • scrumbo Level 1 Level 1

    If you are a would realize that looking for an email on your phone from a client that was dated 2 years ago may prove useful.  If you can't locate the email because you deleted it from the server, then you are a fool.  But it's nice to see that you have a nice cushy office job and don't have to work for a living...

  • netzach63 Level 1 Level 1

    Professional enough to understand the difference between deleting a message from the server and moving it out of the Inbox and into a different folder on the server - where it would still be accessible from my iPhone.

  • LoneStarExile Level 1 Level 1

    Same problem among others since I updated to the latest iOS 7 update!  Apple, if I could afford a Droid, I would kiss you goodbye!!!!!!!!!!!!!!

  • charhall Level 1 Level 1

    This problem can mostly be solved by deleting your email account(s) and then setting them up again.  I did this shortly after finding this suggestion here and have not had a problem since.  It does not seem to help with Gmail but they have a proprietary app that I downloaded and now I just use that for Gmail instead of the iPhone mail app.


    Again, to SOLVE this problem, DELETE all of your current email accounts, then start over with a NEW SETUP of your accounts. 

Previous 1 6 7 8 9 10 Next