Previous 1 2 3 4 Next 56 Replies Latest reply: Mar 31, 2014 4:06 PM by George.iD Go to original post
  • Utica Steve Level 1 Level 1 (0 points)

    This problem isn't limited to Comcast.  My accounts are handled by gmail.  When I installed ios7, the badge showed over 30,000 unread emails, even though I had already read them all.  To solve the problem, I had to go webmail, download 100 at a time (that was the limit), mark them "all read," and move on.  That took forever, but not as long as if I had had to do it all using the iPhone, which I tried first.  It seems to me the previous ios only showed "unread" mails for the previous 24 hours.  Now it shows up everything forever.  By this morning the badge total was over 200.  If I am missing some hidden setting, someone please tell me what it is.

  • brcamps Level 1 Level 1 (0 points)

                       

                                                                           
                             Re: Email problem with ios 7                        
                                                    Sep 19, 2013 1:00 PM                                                     (in response to doughboy44)                    

                                               

    Here is how I resolved the unread messages error for my comcast email on ios7 iphone5.  I had to download all the messages in my inbox on comcast's server (read or unread) to the phone.  Then I marked them unread on the phone.  It was very tedious to download all the messages to the phone.  I had to reputedly scroll past the bottom of the iphone inbox which would cause 250 messages to download each time.  Then I marked all unread. 

     

    Now I have 13000 e-mail messages on my iphone, but they do not show up as unread.  The email messages I have received today after I got things straightened out show up unread but normally becomes read once I open them.  It seems to be working noramlly now.

     

    Perhaps if you have a ton of messages in your inbox on comcast's server you could move most of them to a different folder and then only the messages you want on the iphone will be downloaded?  It would be much quicker and easier than what I did and you would not have thousands of messages on your phone. I wish I would have thought of this before I downloaded so many messages to the phone...

     

    I have an email address through Centurylink and I have tried everything to make the "unread" messages badge icon go down to zero. I went to Centurylink's website and marked all of the messages in my inbox as read, but that did nothing to my iphone. I also tried deleting the account from my phone then adding it again, but they all showed up as unread again. So I finally tried what you suggested and moved all messages from my Centurylink inbox via the Centurylink website (shift + click on the box to select all messages in the inbox) to a new folder that I labeled "archived." FINALLY, when I checked my iphone and opened the mail app the unread message number went down to ZERO!!! I am so excited, thank you for your help!!

  • MLadd Level 3 Level 3 (660 points)

    Apple can't fix how your service provider has their servers set up. 19 individual E-Mail address,a cross multiple providers and not a single device had this issue. None of them were Comcast or Hotmail. If you are using POP, the issue is how POP E-Mail works, and not iOS7. Removing the account, and going into your provider's E-Mail and marking all the E-Mails as read, or move to a different folder, then re-add the account typically fixes this issue.... which happenes when the account is added on desktops, laptops, tablets, phones, etc. Not just iPhones running iOS7.

  • brandonfromalbuquerque Level 1 Level 1 (0 points)

    Sure, but my comcast POP mail has worked perfectly on every conceivable device for many years, blackberries, androids, iphones-every ios up to latest ios6.  It failed on ios7.  So yea, if something that works on any mobile platform except ios7 is not an ios7 issue, then yes its my provider's server set-up that is at fault.

  • Utica Steve Level 1 Level 1 (0 points)

    No, that isn't the case.  No previous systems on any previous Apple products, of which I have had many, have had this problem.  Nothing changed other than upgrading to ios7.  So I will blame ios7 since it's the only variable in the equation.

  • Tnnisace Level 1 Level 1 (0 points)

    I continue to get the error message from time to time on my iphone. Sometimes my Comcast email works, and sometimes it just doesn't.  I have never gotten the unread messages issue however to date since upgrading to ios7.

    Still trying to figure out where the inconsitency is to fix it. Cannot figure it out. I know I have all of the correct port settings for Comcas IMAP. Beyond that I'm lost.

  • Amhvillage Level 1 Level 1 (5 points)

    I have had similar issues with my Comcast account and have tried everyting I could find on this thread for fixing the phantom unready emails after upgrading to IOs7. I have been on iPhones since iPhone3 and this IOs7 is definetly doing something different with the unread email count or APIs to fetch external email. That said to recify both the Comcast side and the Apple side -  I did the following....

    1. Go to your email account on Comcast.net and clean house. Mark everything read that you want read - yes including back years. Also clean up all delted items and spam folders. Or create a folder called follow-up and move all open items to that to ensure everyting on the Comcast side is truely all read.

    2. Next delete your exisiting Comcast email account on your iPhone.

    3. Double click iPhone home button and remove email from your open applications

    4. Setup an entirely new account same as before or as you would want

    5. Go back into email settings for this new account and under advanced settings / Deleted Messages - change the option that defaults to "after one week" to "never" - Make sure to save changes

    6. Go into your email and any unread items should now appear so that you can see them

    7. Your choice here - either select "edit" and "mark all as read" or review and remove accordingly.

     

    If you don't want to establish a whole new email account for some reason. Try steps 3 first and then skip to step 5.  Somehow this worked and I'm sure there is a great explanation but for most of us - we just want our email back to normal (whatever that is). Good Luck!

  • tarawithsass Level 1 Level 1 (0 points)

    Thank you so much.  I never knew I could set up my hotmail as an outlook account.  That got rid of all of my 40,000+ unread emails showing up on my phone but not actually being unread.  Also, this took care of the issue where when I read the email on my phone, it finally shows unread in hotmail too.  I've been pulling my hair out for years doing it the wrong way.  Thank you so much!!!!!!!!!!

  • saweeet Level 1 Level 1 (0 points)

     

    Re: Email problem with ios 7

     

       Sep 19, 2013 12:07 PM    (in response to doughboy44

    First sorry for my broken English, I got this problem fixed

    (((If you are using HOTMAIL)))do the following steps

     

    1.go back to setting>email>delete your original mail account

    2.setting your hotmail by choosing the outlook icon from the begining.

    3.it can allow you to enter your xxxxx@hotmail.com in the outlook mail setting, that fix the problem.

     

     

     

    Thank you so much! For whatever reason this worked!

  • Saint357 Level 1 Level 1 (0 points)

    After registering to Comcast IMAP beta I was able to add my account back as an IMAP settings and that seems to work better than POP. Since I already marked all of the messages read the email notification went away.

     

    First you have to register to be a beta tester on this Comcast link: https://xcbetasignup.comcast.net/imap_trial/web/

     

    Registration process takes 72 hours.

     

    Fair warning it's not an easy task to do since you have trick the iPhone to tell that it's going to an a ".com" rather than ".net". So far this is the only way I knew force the phone to not look at the default settings from the server.

     

    Instructions:

     

    1. Delete your Comcast email profile from the iPhone.

    2.  Add it back to your phone

     

    Go to Settings > Mail,Contacts,Calendars > Add Account

     

    3. Select "Other"

    4. Select "Add Mail Account"

    5. Fields to populate

     

    Name: Your name

    Email: your comcast email except you have to use  ".com" instead of ".net", this will allow you to set it as an IMAP otherwise if you leave it as ".net" it will automatically apply the normal pop settings from the server.

    Password: your password

    Description: how ever you want to call it.

     

    6. Once you have populated the fields hit "Next"

    7. The next window should give you indication if you want to use IMAP or POP

    8. Now that you are in you may have to correct your comcast email address from ".com" to ".net"

    9. For settings.

     

    INCOMING MAIL Server

    Host Name: imap.comcast.net

    User Name: your username

    Password: your password

     

    OUTGOING MAIL Server

    Host Name: smtp.comcast.net

    User Name: your username

    Password: your password

     

     

    Once you have properly populated the fields then you're set. Keep it in mind if you haven't been checking your mail over the web then you will come across with a bunch of emails that were unread

  • em71826 Level 1 Level 1 (0 points)

    I was having a comperable problem  hundreds of phatom emails here is what I did to fix it:

     

        Selected the account with the problem opened the trash mail folder

     

         Hit Edit and the select any one email

     

         hit mark and select Mark as Unread

     

         Hit Edit reselect the same email

     

         select Move and then select inbox

     

         Go back to the main email screen and select the inbox of the same account

     

         hit edit and the mark all and then hit mark as read

     

         you can then trash the email

     

    This worked on my ipad with 3 eamil accounts with no actual messages in the inbox but hundreds of phantom emails showing in the inbox

  • two slices Level 1 Level 1 (0 points)

    I have an iPad Mini recently upgraded to iOS 7.  The new OS does not have the  previous OS Mail feature that allowed the user to set a limit to the number of  email messages downloaded from the server.  I previously set 100 messages as the  number to be kept on the iPad. Older messages were automatically  deleted.
    With iOS 7, the device is attempting to download all the old  messages on the server, about 15,000.  This wasteful and unacceptable.
    It is  also impossible to delete the old messages from the inbox other than one at a  time.  That is impractical.
    I went over this issue today with  the Apple iPad support centre.  The adviser was unable to provide a  solution, other than to suggest that I delete all the old messages on the ISP  server.  That should not be necessary.  My laptop computer knows not to download  old, read messages.  Why can't the iPad do the same?
    I think this problem  will affect many customers. 

    To the Apple engineers: Will you fix this?  Thank you.

  • MLadd Level 3 Level 3 (660 points)

    If you use POP, this is what happens many times. The client (desktop, iPad, etc) is what determines if an E-Mail is new or not. If you connect to the mail server directly, try moving the messages to a different folder, and that should resolve the issue. Or use IMAP instead of POP, which allows the server to determine what is unread or read already.

  • swandawg Level 1 Level 1 (10 points)

    According to this tech article, the changing of the default email is intelligent and intentional: http://m.infoworld.com/d/mobile-technology/7-hidden-gems-in-ios-7-226957?mm_ref= https%3A%2F%2Fwww.google.com%2F.

     

    It says, "If you use multiple accounts, you've probably noticed that Mail will reply from the account in which you received the email, no matter what your default account. But when you create a new email, Mail uses your default account, so you may need to change the From field, an easily overlooked step. iOS 7 notes who the addressee is and what server it came from, then automatically adjusts the From field for you. When you send an email to someone in your corporate Exchange directory, the email is defaulted to come from your corporate email account, even if your default account is your personal account."

     

    Personally, I like it.

  • RuRin Level 1 Level 1 (0 points)

    I love having to factory reset my phone DAILY in order to receive emails on my phone said no one EVER!!

    It has nothing to do with settings, or passwords, or push or this or that. I have deleted accounts and reinstalled them. It will collect a couple every day and that is it. It will send out emails no problem. Today saturday my phone told me it had last checked mail LAST Tuesday. Really? It was last night. When I pulled the screen down the refresh and get mail, the circle just spun for hours and never picked up mail. It's rediculous. I factory reset the phone and it is working right now but it will only last for a day or two. (I'm on reset #2) All the other suggestions I have tried and it would last anywhere from a couple days to not at all. I do these things repeatedly so I know. I just upgraded fropm the I4 to the I5 and I wish I had listened to myself and not gone with a second I phone! Now I'm stuck for quite a while. I have had Blackberry and Android and have never had as many problems as I have had with IOS. It really stinks.

    I wish they would fix the issues that people are having and not concentrate on background decorations etc. I'm certainly not interested in looking at the background of a phone that does not work!!