Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Feb 16, 2014 10:47 AM by ApMaX Go to original post Branched to a new discussion.
  • alekb Level 1 (5 points)

    Thank's for your response!


    it's a bit more strange what is happening, because form the disk utility (from the recovery partition) while verification process all seems to be OK, all is green and nice, the permissions are those form itunes.


    But the mac doesn't load the system, so I tried to reset PRAM and SMC, and nothing happends, then I load the safe mode by start with shift+cmd+V so I can see whats happening while loading, and here stuck on repeating this: Disk0s2: I/O error. So I looked about this error and is defenetly the hard drive, and also says it could be about a permissions error (what a coincidence). I also tried the fsck thing... but nothing...


    Finally I decided to use Diskwarrior, I used on one oportunity years ago and saved me once, so I rebuild the disk, and all seems to be succesfully but the computer doesn't load, so all is the same.


    I fortunetly had a timemachine backup, but like a week a go was my latest backup, so I used Diskwarrior to recover some of those new files.


    I also reinstalled the RAM memory cards and it's the same.


    Now I will try your suggestions about th hardwaretest and do you say I can reinstall my operating system and my peronal files are going to remain the same, without using the timemachine backup?


    thank's again


  • Alessandro Catalano Level 1 (0 points)

    Dear All,


    A good news and not good news ... I have downloaded again from the App Store OS X Mountain Lion 10.8.5 and then I formatted the HD. So I did a clean install from a pen drive. After completing the procedure was present the latest version of OS X 10.8.5 Mountain Lion and iTunes 11.1. I started Disk Utility and verified the permissions ... all ok!


    Now the bad news: I upgraded to iTunes 11.1.1 and checking the permissions again are all corrupt.



    In conclusion we need to wait until Apple solves the Bug.



    Best wishes



    Alessandro Catalano

  • TedDetjen Level 1 (5 points)

    This message is for alekb.


    I had this happen to me.  When I ran the hardware test, codes came up to say that the hard drive was about to fail.  Yours may already have failed and the hardware test codes will tell the Authorized Apple Repair Center and/or AppleCare 1-800-MYAPPLE what they may indicate.


    Fortunately, I had backed up my hard drive with Time Machine.  Because I had AppleCare the cost of the new hard drive was covered.  After some gyrations (theirs and mine) I was able to reinstall my Time Machine backup on the new hard drive.


    If you do not have AppleCare to cover the cost of the drive, I would suggest you purchase a solid state drive.  Since that time I have purchased one and it is faster and has no moving parts, so there is much less chance of it failing due to a jolt or something.  It is also very quiet and runs cooler.  You can shop around and find one specifically for your mac model.


    I am hoping that your drive is ok.  If so, you can use he Recovery Partition tools to reinstall the operating system. (I would do that before restoring from Time Machine.)  Reinstalling the operating system will replace bad files and leave your data files and application files (if not already damaged) unchanged.  It there is a problem with one of the Apple application files, reinstalling the operating system will fix that, too.  Reinstalling the operating system will also refresh the Recovery Partitiion.  After you reinstall the operating system, make sure you do a Software Update.


    Once this problem is resolved, I strongly recommend you purchase an 8gb flash drive and create a recovery flash drive.  This recovery flash drive can be inserted in the USB port.  To use it, if your recovery partition is not working for some reason, you hold insert the flash drive, hold down the option key, and hit the start button.  you then choose the flash drive, which will be labeled Recovery Assistant and can use the tools to work on your drive.  You'll have to resolve your problem before you can create the Recovery Assistant Flash drive.  Here is the link:


    By the way, once your problem is resolved, if you haven't upgraded to Lion or Mountain Lion, you should.


    Message was edited by: TedDetjen


    Message was edited by: TedDetjen and is for alekb.

  • alekb Level 1 (5 points)

    Thank's TedDetjen


    finally I decided to reinstall the system, thank's for your advice, for now all works perfect, really much faster, like a new mac, I always thougth that by reinstalling the OSX will delete all, including preferences, files, etc. this was good news for me, so all keep as I left it before the failure, excacty the same (much better than recovery with the timemachine backup)...


    But there is something: I didn't update itunes for 11.1.1 so I can't open itunes because says my library is created in a newer version, so needs to update, but I'm not planning to do so (I will wait until Apple solve the permissions problem), so I can't hear music in this laptop for now!


    For now I'm not experimenting any disk problem, but as something certainly happened with it, I wolud like to do the Apple hardware test, but I can't do that, by the way I'm using a macbook pro 15' 2010 with Mountain Lion updated (initialy came with the installation disk for Snow Leopard). So I put the CD of the old OSX and start the computer pressing D but nothing happends, I read that Mountain Lion has this test inside but I can't found it, where is that?


    Please keep possting! if someone found a solution for the permission problem for itunes even when 11.1.2 is launched.



  • TedDetjen Level 1 (5 points)

    Hello alekb -


    I am glad to hear that reinstalling the mountain lion system got your Mac going again.  I wouldn't worry about having all the iTunes permissions messages listed when you run Disk Utility.  There is obviously a problem with this but at least iTunes 11.1.1 works.  I suggest you run software update and update to iTunes 11.1.1.  There is even a minor 10.8.5 update, which you should do.  In fact, I always update what Software Update says to update.  According to the AppleCare people I have spoken with, you can safely ignore these permissions lists.  I have them, too, and so do thousands of other Mac users who have updated.  By updating, you will be able to have the new iTunes program convert your library of music so that you can enjoy it again.  Go ahead and run Software Update and install the updates.


    As far as the hardware test, here is a trick that works for me.  While the Mac is up and running, insert the Applications Install DVD that came with Snow Leopard.  By the way, my Mac is a mid-2009 MacBook Pro and came with Snow Leopard and the System DVD and Applications Install DVD.  Once you have the Applications Install DVD inserted, it will mount on you desktop.  Next, shut down your computer and restart it while holding down the D key.  The hardware test will come up then.  Run the extended test which will take over an hour.  If you have no hardware issues, when it ends it will state, "No Problems Found."  If it finds problems, it will list codes.  Copy these codes down and report them to AppleCare (1-800-MYAPPLE) and/or your nearest authorized Apple repair center.  The test spends a great amount of time checking your computers memory and this is good.  The test is thorough and if you get, "No Problems Found," you will be more at ease knowing that at least you do not appear to have a hardware problem.  I run the test pretty routinely.  Running it was the way I discoved that my hard drive was close to failing and gave me time to replace it.


    By the way, because we upgraded our older macs from Snow Leopard to Lion and then to Mountain Lion, our older macs do not have the feature for running the hardware test that the newer macs have.  All newer mac owners have to do is hold down the D key while starting their computers.  My wife's newer mid-2013 MacBook Air bring up the test from the Internet this way.  We, unfortunately, must use our Applications Install DVD.  You will see that the hardware test instructions are printed right on the DVD, but bring up the test the way I suggested.  It is a lot easier.


    I'm glad I could be of assistance.




    Message was edited by: TedDetjen

  • CrayonShinchan Level 1 (0 points)

    I have a late 2012 27" iMac and a late 2012 model MBP 13". 


    The update to iTunes 11.1 did not affect my MBP, but it made my iMac into a paperweight.  I did everything according to the advice I read on the net.  I even erased my disk and did a clean install (losing all my files in the process).  I hope there's a repair for this soon.  I live in South Korea so you guys can see it's an international problem.

  • TedDetjen Level 1 (5 points)

    I am so sorry that you lost all your files.  The iTunes 11.1.1 permission annoyance will be with us until Apple releases a fix.  In the meantime, you can safely use iTunes and ignore the permissions list.  Are any of your file backed up on a Flash Drive or DVD or CD?  It would be a good idea for you to either invest in a Time Capsule so backups of your entire system could be made each hour, or at least if you cannot afford to buy a Time Capsule, buy a 32GG or larger flash drive to backup your documents folder and pictures folder.  That way, you can at least restore these items.


    If you have Lion or Mountain Lion installed, you have a recovery partition which will take you to tools to help you fix your mac, but I am afraid if you did a clean install, you have indeed lost your personal files.


    To reach the recovery partition, you hold down the command-R keys and start the mac.  Then you get to Disk Utility to repair your hard drive and/or permissions.  (The iTunes permissions will still be listed, but you can safely ignore them.)  If you have Time Capsule, you can restore your hard drive with the complete mirror image of your system, applications, and files.  If you need to reistall your system, you can do that there, too, and it will not disturb the content of your appllications, settings, or files.

  • RaySat Level 1 (0 points)

    Have the same problem here, but in French !


  • TedDetjen Level 1 (5 points)

    Yes, one good thing about Apple is that they make versions of their products for many different languages.  Again, you can ignore the iTunes 11.1.1 permissions listings for now.  ITunes still works.  We'll have to be patient and wait for an update.  Apple is very good about fixing these kinds of problems with software updates.

  • TTabby Level 2 (200 points)

    Well, I have to add myself to the list here and the iTunes permission issue.

    I was having some difficulties with getting my old scanner working and thought I would give Disk Utility a try, only to be amazed at all the entries with iTunes. WOW.

    I was able to sort out my scanner problem but, what a mess Apple has created here.

    The only thing I can add, is that this thread is over a month old now.

    They must be aware of it, reading through the entries here.


    Perhaps they are just too busy with Mavricks and will just roll a fix in with the new release.

    That's my guess anyway.

  • danielfelman Level 1 (0 points)

    TEngo el mismo problema help help

  • TTabby Level 2 (200 points)

    Apple fijará, él es ACEPTABLE

    Apple will fix it, it's OK

  • pablo andrés Level 1 (40 points)

    Hola, somos muchos los que tenemos el mismo problema. Tanto con el iTunes 11.1 e iTunes 11.1.1. Mis dos Mac lo tienen por lo que es generalizado. A mí ya me causó un problema en el sistema  de uno de ellos y tuve que volver a instalarlo. Hasta que Apple no lo arregle no me meto más a reparar los permisos. Se cree que Apple ya sabe del problema pero ya han pasado más de 30 días y no hay ninguna actualización que lo solucione.


    Solo hay que esperar. Yo creo que esperar hasta Mavericks. No queda otra.



  • TEVillegas Level 1 (0 points)

    11.1.2 does not reslove this issue.  In addition Safari 6.1 introduced some more deffering permissions. Can any verify if they persist with OS X 10.9?

  • SzekiTom Level 1 (0 points)

    In 10.9 look like good. Gone the permission errors.