Previous 1 2 3 4 5 Next 67 Replies Latest reply: Sep 26, 2014 11:21 AM by Howard_K Go to original post
  • sfrav Level 1 Level 1 (0 points)

    Some (little) progress or analysis:  iPod 4th Gen.  none of above worked.  I did a complete restore to factory setting, installed nothing but my itunes id, and yes finally got to view purchased apps.  From there I did a restore to my most current backup, and the problem returned.  So it must be in some combination of my settings, apps, etc. that is setting up a bug.  Not too excited about reverting to factory restore and re installing all apps and songs one at a time, plus all the settings that I have forgotten about over time.  Might have to settle with no purchassed listing till (if) the right app or setting comes along. Maybe somebody will take a factory restore a bit furthar and see if they find the quirk.  Dont forget to get yourself a good backup first, then tuck it away somewhere that it wont get overwritten.

  • cinisini Level 1 Level 1 (0 points)

    Same problem here, updated my 4S to ios7, tried all suggestions without success, logged out/in, selected my purchased app, but the following screen is dead empty. What's the technical explanation of this? caching issue? how long to wait before it refreshes? Would be nice to know. Thanks

  • cinisini Level 1 Level 1 (0 points)

    Assuming you can see the purchased app, instead of selecting the app, select the icloud button next to it!

  • Roy_ipod Level 1 Level 1 (0 points)

    THANK'S FABIAN

  • Sam Cornn Level 1 Level 1 (5 points)

    how is this still a problem?

    Just got 2X 5s's both have this problem.

    restoreed 4s's for the kids and they both have this problem now.

  • alecjacobryan Level 1 Level 1 (0 points)

    SOLVED - If none of the other solutions on this string work for you, try this one: 

    1. On a desktop to to www.icloud.com and sign into your icloud account (you need the "www" else you are redirected to apple.com).
    2. Sign into your icloud account.
    3. In the upprer right, click your name.
    4. Click "Account Settings."
    5. Click "Advanced."
    6. Click "Reset Documents & Data."
    7. Click "Reset Documents & Data," (again).
    8. Click "Reset."
    9. You should get the instruction to power cycle your device to complete the reset.
    10. Once back on your iOS7 device you should be prompted to enter your icloud password again.
    11. Now go to App Store and see your past purchases tab.

    (Fear not, you will not lose any data on your device.)

     

    fin

  • RichD1 Level 1 Level 1 (0 points)

    This did not work for me.  I looked at some other posts and found a suggestion to change the keyboard specification to get rid of the symbol showing a cloud with a downward arrow indicating that an app had been purchased, but not downloaded.  It worked immediately!

     

    Who'd a thunk of this?

     

    Looks like this problem has been around waaayyy too long!

  • AZ88 Level 1 Level 1 (0 points)

    I tried the suggestions here numerous times for my iPad Air but the purchased apps still weren't showing up, even new apps I installed. Finally, I tried rebooting, a suggestion I saw on another site (hold down the Power button and Home button until the Apple logo shows up). The apps finally showed up!

  • fferrary Level 1 Level 1 (0 points)

    Thanks, AZ288!

     

    Works for me! :)

  • Thannaleeya Level 1 Level 1 (0 points)

    I've tried so many times to find out and finally i found your suggestion and completely works ! thank You AZ88

  • moonslug Level 1 Level 1 (0 points)

    Yes, AZ88, FTW!

  • www.MichaelRichardHerzog.com Level 1 Level 1 (0 points)

    You missed one step to always make it work 100% of the time

    because your steps did not work for me.

     

    Solution:

    • 1st: Logout of iTunes: Settings>iTunes & App Store>Apple ID:>Sign Out.
    • 2nd: Close out iTunes, App Store, and Settings.
    • 3rd: Turn off Phone.
    • 4th: Turn on Phone
    • 5th: Login into iTunes: Settings>iTunes & App Store>Apple ID:>Sign In.

    After that, Go back to the App Store, click the Updates icon on the bottom right, and click on Purchased to see your purchased apps actually being visible.

  • sugarmagnolia Level 1 Level 1 (0 points)

    worked for me, AZ88, thank you!

  • Itunes forever promote Level 1 Level 1 (0 points)

    I have solved that problem!

    Connect your iPohne to the PC or Mac and go on iTunes

    go on the itunes store and search the app you already got but its not apearing

    download it onto itunes and then sync your phone with it!

  • gmorgan8603 Level 1 Level 1 (0 points)

    Hi JRector15, I called apple and was on the phone for 15 minutes. They said to do all the stuff already mentioned. They said it may resolve itself over time. They told me to "Buy" a paid app that I had already purchased, and they would refund me if it charged. It didn't charge.