Previous 1 6 7 8 9 10 Next 615 Replies Latest reply: Nov 10, 2015 7:55 AM by NMBob Go to original post Branched to a new discussion.
  • Saffir99 Level 1 (0 points)

    It's like, a lot of these issues have been around forever(smart playlists don't update automatically, waiting for changes to be applied and preparing to update taking forever), and Apple does not address them at all. Most updates seem to be cosmetic at the most. Can't hold our breaths waiting for Apple to push out fast updates that fix these things.

  • DJOTron Level 1 (0 points)

    I have a iphone 4s (7.0.3) and macbook air (OS X 10.9), never had any issues with doing sync between macbook air and iphone. About a week ago I noticed that some photos were not syncing. Since then I've restored my phone 4 times, but can't even get one song or video to sync. Voice memos sync without issue but if I add a playlist or single song (or single song in a new playlist) I get the dreaded "waiting for changes to be applied". I've tried all the tricks turning off wifi, bluetooth, find my phone, deleting icloud account, reinstalling iTunes and even rebuilding my itunes library from scratch (twice). Spinning arrows stop on the phone but itunes (11.1.3) never completes. On accaision it will sync some songs but they are empty. I have no idea what to do next... this bites!!!

  • jwehrman Level 1 (0 points)

    Was having the same issue this afternoon, updated to the latest version of iTunes 11.1.3 and it synced immediately.

  • OldGreyBeard Level 1 (0 points)

    This is idiotic.


    Fix the bug. I should not have to spend hours researching an issue, then re-build my library because of programming incompetence.


    I hate to say it but Apple is becoming more like MS every day.


    What a disgrace.             

  • mezama1 Level 1 (0 points)

    I am  experiencing this problem too i could swear so much right now but i am controlling myself, i really need help with this because i cant put anything on to my iphone and i want to know how to fix it with out deleting everything please help me

  • TokyoD Level 1 (0 points)

    I'm having a similar issue.  After clicking the cancel sync button and waiting for iTunes to cancel sync (which iTunes doesn't do,) I see the following error message in the Console log:


    11/13/13 6:30:58.540 PM iTunes[47952]: BUG in libdispatch client: kevent[EVFILT_WRITE] delete: "No such file or directory" - 0x2


    Not sure if that is related to the cause...

  • francesbean Level 1 (0 points)

    What worked for me was to cancel all unfinished download on my iDevice. Finally. Lost some sleep over this

  • jonathansc Level 1 (0 points)

    Clearly IOS 7.0.3 was not fit for purpose. Just have to hope the long silence from Apple is them working hard to fix and test.



  • mslev Level 1 (0 points)

    You'll all be glad to know that a Senior Support Advisor at Apple is currently helping me and has acknowledged that this issue a serious problem and is communicating the issue to the Apple engineering team. 


    In the meantime, the Advisor is continuing to troubleshoot the issue with me.  He is having me send him screenshots and diagnostic information for the engineering team to use. 


    According to the Advisor, this issue (or a similar one) was spotted by Apple at some point and the engineering team thought they fixed it with the released of iTunes 11.1.2.  That is obviously not the case.  I informed the Advisor of this ongoing support thread and the many others that have popped up, showing that this is a widespread problem.  I'll continue to update this thread with any new info I learn.  Fingers crossed.


    My story is similar to others here.  I have been experiencing the issue since the upgrade to iOS7 and iTunes 11.1 (and carrying through all updates since).   I've experienced the issue across multiple devices - an iPhone 4 and a brand new iPhone 5S - always running the latest versions of the software.  iTunes to iPhone syncing gets stuck indefinitely on "Waiting for changes to be applied," erasing audio content, creating large blocks of "Other" data, and generally behaving erratically.  The best workaround I've found is erasing all audio content and then re-syncing it all back onto the phone, but that fix is only temporary and obviously time-consuming.  Other unsuccessful troubleshooting:  restore iPhone from backup, restore from factory settings, rebuild iTunes library .itl file, reinstall iTunes, reinstall OS X, weed through iTunes library for possible corrupt audio files, etc etc.  Some of these methods cause the sync to work temporarily, only for the problem to return. 

  • RockTheGlobe Level 1 (0 points)

    Good to hear, because iOS 7.0.4 did not fix this issue for me.  I was stuck on "Waiting for changes to be applied" for almost half an hour last night.

  • pritesh.asher Level 1 (0 points)

    This sorted it - had the same issue on an iPhone 5s (7.0.3) and iTunes 11.1.3 - there was a duplicate tone that was delaying the process - easier to sync over USB the first time, then sync via WiFi

  • obgynjo Level 1 (0 points)

    Last week I took my Phone 4S-32GB into the local Apple store Genius bar and explained the situation. They had never heard of this problem and thought it might be a WinXP issue since XP is "on the way out". I explained it happened after the latest IOS & Itunes upgrades. They offered to debug my problem if I brought in my CPU; I sync to and keep my music on my home desktop.


    Took the box in last night. They provided a screen, ethernet cable & keyboard; I took a mouse. Sure enough it did the same old waiting for changes... and the nice Genius lady set out to find the problem. First she checked and found that I had not upgraded to IOS 7.0.4 which just came out. Apparently they also released another ITunes upgrade this week as well, and we upgraded to ?11.2.3? We also did the IOS uppgrade through the Cloud and she did a little digging and surmised that in fact Itunes was NOT backing up my Iphone to the HD even though it claimed it was!! Then she insisted I back up the Iphone to Icloud which worked well (took about 2.5 GB-I have the free 5GB account). However, the music transfer still garnered the same error using the USB wire after both IOS & ITunes upgrades. More checking on their in-house tech line: she said I had a corrupt "permissions file" in my Itunes subdirectory in the Applications folder. SO we uninstalled Itunes and I completely deleted that subdirectory to erase any trace of the previous installation. (She also cautioned me that Voice memos might be screwing this up so we unchecked this in ITunes and later I deleted these from my HD-not sure it's necessary, though). Then I RE-installed Itunes. Guess What....we did a limited music install of a few playlists and they transferred fine. When I got home I installed my entire music library successfully, so it has worked at least twice with 0 errors. BTW if your sync gets to "waiting for changes" and the little circular icon at the top of the phone screen stops spinning-you're dead in the water!


    I suspect the "waiting for changes" hangup is a symptom of several different but possibly related problems and I'm not optimistic that there will be a universal "fix" until Apple has a better grasp on all the different underlying causes. BUT I would be cautious if you think your Iphone is Really getting backed up to your HD as long as this issue exists. Maybe try the Cloud as some insurance..... It's pretty easy and free if you have <5GB of essential "stuff" on the Phone and it completely circumvents this problem-at least it did for me.


    Not sure if this will fix everyone's issues, but I have not seen this posted. Good luck!

  • CalliopeMichael Level 1 (0 points)

    LeoGecko wrote:


    I disabled the auto sync in iTunes like in step 5 of cpaulPHL post. After that I connected my iPhone to iTunes and selected the Devices> Transfer Purchases from "my iPhone".


    This took a long time and seemed to transfer everything.  This completed and then after that I was able to sync with no problem even after turning find my iphone on again.


    This worked for me.


    iPhone 5


    Snow Leopard

  • hansolo415 Level 1 (0 points)

    Glad to know that I am not the only person observing this.  I thought it had to do with the choice of USB port or the cable, but the problem happens from time to time for no reason and goes away for no reason.  It is particularly irksome when it occurs during a RESTORE process which seems to happen a lot for me.  After waiting what seemed 15 minutes it finally started syncing the music (everything else had already synced).  I'm guessing it got hung up with the 2500 songs in the libarary and something in there caused it to take a lot longer than expected. 


    Usually for me once it has synced music the problem goes away.


    My big issue has been that every update to my iPhone 4S since 7.0.2 has crashed the iphone midprocess requiring a total RESTORE before doing the update.  Usually I only have about 1GB of my 32GB of space left when all this is going on.

  • RickS998 Level 1 (0 points)

    I have an iPod 5th gen running the latest software 7.0.4 with iTunes also running the latest software 11.1.3 (8) on a MacBook Pro mid 2012. I cannot get any of my ripped music to install on the iPod. However, all the app store purchased songs can be synced. ITunes can play all of my songs. I've performed a factory reset on the iPod, recreated all music on iTunes and tried syncing with no success. I only have 700 songs with barely any device space used. Coming from windows, I had the impression that with Apple's "closed ecosystem" issues such as this were non-existent. I've tried alot of things and so far, I seem to be dead in the water. I'm always stuck on step 5 of 5...Waiting for changes to be applied. I hope they send a patch soon.

Previous 1 6 7 8 9 10 Next