Previous 1 2 3 Next 115 Replies Latest reply: Mar 17, 2015 6:50 PM by AwildaDion7 Branched to a new discussion.
Poncho_au Level 1 (0 points)

So my iPhone 4s will not restore my backup to iOS7, I am getting the message your backup was corrupt or is not compatible with the iPhone that is beinng restored.


The issue I experienced getting to this point:

- Backups completed twice fine

- Downloaded update to PC fine

- Phone dropped out while restoring iOS 7 to it

- In the "connect to itunes" mode the phone comes up in after failure I applied the update again and it worked fine (removed additional USB devices from PC)

- Chose the backup I wanted to restore to it (backup from the latest iOS6 version for iPhone 4s)

- Restore fails due to "iTunes could not restore the iPhone "*phone name*" because the backup was corrupt or is not compatible with the iPhone that is beinng restored"


I have rolled back to 6.1.3 to restore my backup but I am getting the same error. I have moved the latest backup on my PC from AppData and am trying with an older backup getting the same error.


I cannot afford to not be able to restore my backup as I have favourites data in TomTom that I need and a lot of apps that I am going to loose data from. I need help to resolve.

There has never been any issues with backing up my phone (I have backups done over WiFi and USB) so there should be no reason why my backups would be corrupt. If my backup is corrupt and iTunes hasn't verified it and warned me prior to a restore, **** is going to hit the fan.


Could the fact that I have attempted to restore the backups to iOS 7 caused the corruption and not not able to restore on iOS 6?

iPhone 4S, iOS 6.1.3
Previous 1 2 3 Next