Previous 1 4 5 6 7 8 Next 117 Replies Latest reply: Jan 9, 2016 7:20 PM by manzanatech Go to original post Branched to a new discussion.
  • Kvouri Level 1 (10 points)

    Yes I did the same thing. I lost everything on my iphone after udating to IOS7. I retored the phone and then backed it up from a previous Itunes back up . The on your iphone , do not put that you are restoring it , use the option that says , a  new iphone . All my songs , everything was restored. For those that could not see their iphone on the left hand side in itunes . Go file , show sidebar and mine showed up, hope that helps 

  • Jowayn Level 1 (0 points)

    I also updated to iOS 7, but now my old iTunes backup won't restore. Not sure if's because of the iOS7 or because the iTunes backup is corrupted....so i was redirected here by some forum, i'm not sure whether it's worth it...........

  • im_awesome_1992 Level 1 (0 points)

    You got to encrypt the back up. It worked well with mine and it took 3 min.

  • pmaria Level 1 (0 points)

    I've been plagued by battery issues on my 5 for the last several months.  It would die at ~40%, then come back on and show ~30%, then would quicky drain to ~10% before shutting off permanently.

     

    Hopeing I could correct the issue, I thought I'd try a DFU mode restore, something I do every so often anyway.  As usual, I backed up the phone to iTunes 11.1.4 on a MacBook Air w/ Mavericks, did the firmware restore.  I then chose to restore from backup, selecting the backup I JUST did 10 mins before.  A few seconds into the restore process I get the dreaded "iTunes could not restore the iPhone <Phone name> because the backup is corrupt or is not compatible with the iPhone that is being restored"

     

    So this isn't a case of restoreing a iOS 6 backup from a 4S to a iOS 7 5S, it's the same iOS, iPhone & iTunes.

     

    Really chuffed as when you backup you'd expect there to be a backup.  iCloud data is no problem, but I had some pictures and videos that I REALLY don't want to lose.  Even the pictures are not too much of an issue as most are in my photostream, but not the videos.  Even if I cant sucessfully restore the backup, is there any way at all to retreive the videos from the backup file?

  • pmaria Level 1 (0 points)

    So I found a free application - iBackup Viewer that was able to extract all of my content from the backup files.  Now it would be nice if I could get them back onto the iPhone the same way they were.  Is it possible to put videos back into my camera roll?

  • chelle7i Level 1 (0 points)

    Thanks! The "set up as new phone" option worked for me, oddly. I figured it would take me back to the "Hello" screen, but it worked better than the restore backup.

  • RenMach Level 1 (0 points)

    Just sharing the experience if it helps when restoring from iTunes, I just upgraded iPhone4 from ios4 to ios7.1 the status showed all backups restored and itunes/iphotoes was showing my apps/photos in the Phone,  however when using the iphone ... it ended up with 3 options

    1. Use Apple ID --> Do not have

    2. Restore from iCloud -> not an option Since i did not backup there

    3. Restore from iTunes -> clicking did not proceed ahead ( stuck at connected to iTunes )

     

    To resolve,  used option 1. use Apple ID  but did not proceed to create apple id instead skipped it and HOLA i was able get inside the phone.

  • stevendb Level 1 (0 points)

    *POSSIBLE SOLUTION*

     

    I received the same error as many of you -- "iTunes could not restore the iPhone <PHONE_NAME> because the backup was corrupt or not compatible with the iPhone that is being restored." -- and came across this thread looking for answers.  Unfortunately none properly answered it, and about a day's worth of trial and error I have came to a solution that works for me.  I hope it works for one or more of you.

     

    I performed a Sync in iTunes before upgrading from iOS 7.0.6 to 7.1.  For whatever reason, the upgrade process failed.  A subsequent Restore iPhone process worked, however Restore From Backup (using the most recent backup) resulted in the error above.  Additionally, my backups are encrypted with a password so that ruled out a number of tools from attempting to fix.

     

    Note this process takes time, approximately 2 hours on an almost-full 32GB iPhone 4S.  If you follow this guide, please do so carefully!

     

    I also apologise for the poor formatting.  It may be more readible, especially the indenting, in a text editor with Word Wrapping disabled.

     

    Requirements:

     

    - iTunes 11 (preferably the latest version available)
    - iBackupBot (7-day trial version available)
    - a recent iTunes backup from your prior iOS version
    --- if it's been replaced by your new iOS version, you probably can't follow this guide
    --- if it's still valid, I suggest manually creating a copy of it and giving it a new name
    ----- for example, on Windows 7:
    ------- browse to %APPDATA%\Apple Computer\MobileSync\Backup\
    ------- copy the folder name into the same folder (select folder, right-click, Copy; right-click blank part of window, Paste); it'll have " - Copy" appended to its name, which is fine
    ------- open this "Copy" folder, and open Info.plist in a text editor e.g. Notepad
    ------- search for text >Display Name<
    ------- on the line below, give your backup a new name (mine is now named "iPhone pre-iOS71-install" without quotes)
    ------- save/close Info.plist

     

    Process:

     

    Before proceeding, note this WILL wipe your iPhone.  Proceeding is at YOUR risk!

     

    - *IMPORTANT* ensure Find My iPhone is turned off (Settings > General)
    --- if currently enabled, it requires internet access (3G/wifi) to disable

     

    - close iTunes + open iBackupBot
    - determine which partial backup (system items only) in iBackupBot which will complete without error
    --- process (of elimination!)
    ----- right-click desired backup, click 'Restore to device'
    ----- enter encryption password if required
    ----- select Partial Restore
    ----- expand System Files, tick several items (note which you are selecting!!)
    ----- untick User App Files
    ----- click OK, and the restore will start
    ------- if the restore succeeds, nothing in the selected items was the problem; these can be deselected in the next process of elimination; repeat this process with a new selection
    ------- if the restore fails, within the small selection you had just selected, perform the process of elimination one by one
    --------- in my case, Camera Roll is the culprit!
    --------- in your case, you may have one or more culprits, so don't just stop when you've found one!
    - after the above testing is complete, close iBackupBot

     

    - unplug iPhone from host computer and erase iPhone via the iPhone itself
    --- Settings > General > Reset > Erase All Content and Settings > Erase iPhone > Erase iPhone
    --- provide your Apple ID if prompted
    - once your iPhone has been erased and is at the "Welcome screen", plug it in to the host computer, and iTunes will most likely open

     

    - in iTunes, after a couple of minutes of the iPhone appearing to be busy, it may advise it's been unlocked, and to press Continue; press Continue
    - iTunes may ask to "Set up as new iPhone" or "Restore from this backup"; choose "Restore from this backup" and choose your desired backup to restore from, then click Continue
    --- if it prompts to Use Newer Backup or Use Older Backup, choose Use Older Backup
    --- enter encryption password if prompted
    --- note, this will fail as it had previously (same error); click OK on the error message, the phone will eventually restart and be detected by iTunes, and iTunes starts the app/library transfer process
    ----- this could take a long time: for me, it took around 75 minutes for an almost full iPhone 4S 32GB
    - once sync is complete, with your iPhone selected in iTunes, untick "Automatically sync when this iPhone is connected" then click Apply at the bottom
    - close iTunes

     

    - *IMPORTANT* ensure Find My iPhone is turned off (Settings > General)
    --- if currently enabled, it requires internet access (3G/wifi) to disable

     

    - go into Airplane Mode (to ensure nothing tries to be received by the iPhone, notifications, etc. - merely a precautionary measure)
    --- if you get prompt advising Verification Failed, it is possible Find My iPhone did not properly verify and is still considered enabled; this will become a problem when attempting to restore

     

    - open iBackupBot
    - perform partial restore
    --- right-click desired backup, click 'Restore to device'
    --- enter encryption password if required
    --- select Partial Restore
    --- expand System Files, untick item/s that previously prevented a successful restore
    ----- in my case, Camera Roll
    --- leave all User App Files items selected
    --- click OK, and restore will start
    - close iBackupBot

     

    - *IMPORTANT* ensure Find My iPhone is turned off (Settings > General)
    --- if currently enabled, it requires internet access (3G/wifi) to disable

     

    - go into Airplane Mode (to ensure nothing tries to be received by the iPhone, notifications, etc. - merely a precautionary measure)
    --- if you get prompt advising Verification Failed, it is possible Find My iPhone did not properly verify and is still considered enabled; this will become a problem when attempting to restore

     

    - via your iPhone, confirm app data is present (open apps that you are normally logged into and/or have data e.g. messages/chats for WhatsApp)
    - if data is present, good, you're probably done!
    - if data is missing (was for me), try the following:
    --- open iBackupBot
    --- locate the backup you recently restored and expand it
    --- click onto the User App Files folder
    --- with all items listed in the right pane, select all (excluding items named com.apple.*)
    ----- first sort all by clicking onto the Name column header
    ----- highlight top record, scroll down to bottom, hold the SHIFY key and click the bottom record
    ----- (OPTIONAL) scroll back toward com.apple.* and, while holding CTRL, click each entry to deselect it
    ------- this is suggested as we don't know what changes, if any, have occurred on these locations with the change in iOS versions
    --- click the Restore button at the top
    --- enter password if required (it is for me!)
    --- click OK
    ----- it will first extract items to a temp folder for restoration, then perform the restore
    --- your iPhone will reboot post-restore
    --- close iBackupBot
    --- once again, confirm app data is present
    ----- by this stage, my data was present; for WhatsApp, I had to re-verify my phone, but the former chats had been restored!

     

    Hopefully this works for you!

     

    I also suggest renaming or deleting the backup in %APPDATA%\Apple Computer\MobileSync\Backup\ (not the one with "Copy") as it will still contain the corruption that caused backups to fail in the first place.  Once done, perform a backup in iTunes.

  • KelvinHan91 Level 1 (0 points)

    i surfing youtube google for two days and searching for alot of way or installing lot of new apps to getting my corrupted files back but at the end still not working.  Stevendb Thanks a lot ! your ibackupBot really help a lot ! thanks just 2 hours i get all my back up restored!

  • teyastro Level 1 (0 points)

    Apple have admitted iOS5 restore/backup is not compatiable with iOS7.

     

    This is what I was told after dropping my iPhone 4s and having it replaed with an identical model except with their new operating system.

     

    All my previous backups from the past 5 years have the same corruption/incompatability message. I know this isn't possible as the same data has been used to backup iPhones in the past.

     

    How can you claim to offer customer SOLTUIONS when you are creating problems, sort it out apple....extremely dissapointed.

  • Mat Morris 1987 Level 1 (5 points)

    I too recieved the same error message "unable to restore iphone from backup because the backup was corrupt or not compatible" a few different times.

     

    I went from an iPhone 4S to an iPhone 5 with this issue so had to copy all my stuff over manually.

     

    Then when my hold button became unclickable (a known fault) and Apple replaced my iPhone 5 with a whole new unit. I had backed up my faulty iPhone 5 the night before then when I got the replacement home, I got this message again. As I had to hand my faulty unit in when I got the new unit, I had to start my phone (contacts and all) from scratch.

     

    Then today after upgrading from an iPhone 5 to a 5S I backed up my 5, plugged in my 5S and once again got the same message. Luckily this time I still had my iPhone 5 in case the backup failed again (which it did!)

     

    Here is how I fixed it.

     

    In the iTunes settings/ preferences I unchecked the box that automatically syncs iPhone when it has been plugged in. I then deleted all previous phone backups in iTunes (backups from my old iPhone 4 and 5's) and closed iTunes. I plugged my old iPhone 5 in and backed it up one more time.

     

    When finished, I plugged my iPhone 5S back in (and for some strange reason - despite the box being unchecked - it began to sync automatically). I cancelled the sync as soon as I could, then hit restore from backup and it worked!

     

    Hope this helps some of your guys out there.

  • EaglexPDX Level 1 (0 points)

    Same problem, corrupted iPhone4 backup when upgrading to iPhone5. 

     

    You would think Apple would at least warn people about it and provide a fix vs. letting a know problem where people lose all their phone data continue.

     

    I specifically asked the BestBuy Geek Squad folks about what to do to transition.

     

    They said not to upgrade to IOS7 but back up the IOS6 iPhone 4.

     

    Lesson learned is do not give up the old phone until the new phone is fully restored.  And you would think that is what Apple and their resellers would tell you.

  • zmahmood Level 1 (0 points)

    I managed to solve the issue on my iPhone 4S. I was given a replacement by EE and every time I tried to restore using iCloud I kept getting the error: "Your iPhone cannot be restored because there is a problem with your backup data. Choose a different back to restore from.". The problem lays in the firmware version you have.

     

    I've put together a full tutorial here for anyone who has the same issue: http://www.technouz.com/3033/fix-error-ios-your-iphone-cannot-be-restored-becaus e-there-is-a-problem-with-your-backup-data/

  • Kelly Wilkerson Level 1 (40 points)

    I know this is a somewhat long thread already, but I'm going to toss my hat in...

     

    I work for a copy that does a lot of iPhone/iPad backup work, and in the process, I've emailed with a lot of people who have gotten the iTunes corrupted backup error. I've been experimenting with repairing the corrupted backups, so that they are restorable again.

     

    We just released Decipher Backup Repair, a tool to correct the errors in an iTunes backup so that you can restore in iTunes. The free trial of the program will show you all of the errors it found in your backup, and show you how we can repair them.

     

    If you're getting the error message "iTunes could not restore the iPhone because the backup was corrupt or not compatible," we hope you'll give our new utility a shot. We'd love to know your experiences, so that we can help other people with the same issue as well.

     

    http://deciphertools.com/decipher-backup-repair.html

     

    (Note: As I mentioned, I work for the company I've discussed above, so I stand to benefit, either financially or otherwise, from the links I'm recommending.)

  • toobii Level 1 (0 points)

    I on the other hand have no connection whatsoever to Decipher Tools.

     

    I was hit by this problem yesterday and NOTHING worked. I've wastes 15 hours on this silly problem!!

    I tried the iBackupBot which is a nice tool and it could restore things, one item at a time.

     

    then I tried the Backup Repair tool you described and it works brilliantly!!!

     

    Apple were right, my backups were faulty. There was a file missing from a file copying app and a lot of files had incorrect file lengths in the "manifest".

    never mind, the tool just fixed all of that in a few seconds and then restoring the fixed backup worked right away!!

     

    Brilliant tool! Solves this "corrupt backup" once and for all, I'm sure!

     

    Still think ITunes should do this for us, but then again, easily worth $30 to sort this with no effort.

     

    /Torbjörn

Previous 1 4 5 6 7 8 Next