Previous 1 2 Next 29 Replies Latest reply: Mar 9, 2014 1:14 PM by velophile
Nancy Trainer Level 1 Level 1 (10 points)

Just updated iTunes to 11.1 and my iPhone to iOS7. Now when I sync my phone in iTunes, I'm "hung up" on the last step of the sync, "Waiting for changes to be applied." This message just stays there forever.

 

Help!


iMac, Mac OS X (10.6.8)
  • Nancy Trainer Level 1 Level 1 (10 points)

    Just a bit more information -- I have tried hard rebooting the phone, rebooting the computer itself (after quitting iTunes, obviously), and neither worked.

     

    I tried reverting to the last save (I'm backing up to my hard drive), and now iTunes has removed my photos from the phone and not only won't reinstall the photos, but suddenly cancels the sync when it's supposedly halfway through reinstalling those photos.

     

    When I uncheck the "Sync photos" box, I'm still "hung up" on "Waiting for changes to be applied."

     

    Sigh.

  • Nancy Trainer Level 1 Level 1 (10 points)

    I really don't appreciate the fact that no one from Apple seems to be dealing with the many, many threads that have started on this topic since iOS 7 came out. In any event, I seem to have solved my problem with a full software restoration -- that is, iOS software restoration.

     

    I clicked on "Restore iPhone..." which does a complete reinstall of the iOS but also all apps, photos, songs, etc. Took about 45 minutes, but seems to have worked.

     

    I had previously tried reverting to a backup of my iPhone, but that did not solve the problem. Only a full restore solved it.

  • Alan Mays Level 1 Level 1 (5 points)

    I don't know if this helps, but I had never used passcode before the update.  When I updated I changed that setting.  I started having this problem.  Due to me running an app that accessed data from my iPhone, I could not access the data.  So I turned off the passcode.  Now everything works.  Maybe the passcode blocks access for iTunes by mistake?  I don't know, but this helped me.

  • Helichael Level 1 Level 1 (0 points)

    Worked for me as well on an iPad 3.  Thanks Alan!!

  • bluehawaii19 Level 1 Level 1 (0 points)

    I tried what others have said (restarting, restoring, etc.) and nothing seemed to work for me. Finally, I restored from a backup (from yesterday) so my apps and photos went back on.

     

    Then I tried synching in iTunes and got stuck on the Waiting for changed to be applied so disconnected. I finally found a solution.

     

    I first took my playlist and dragged it over to the right and chose to add it to my iPhone (all the music was gone from my iPhone) and within a minute, it finally started synching to my iPhone. I am doing this slowly with my music library (adding all the A titles, then B titles, etc.) and this seems to work. Choosing to actually sync the phone, doesn't do anything. So far, this has been successful.

  • startswithj Level 1 Level 1 (0 points)

    Same issue. No new apps downloaded for many weeks. Problem did not occur last week, but happens consistently this week. Syncing was fine when iOS 7.0 and iTunes 11.1 first released.

     

    Please remember to file bugs at: http://www.apple.com/feedback/

     

    Cheers

  • startswithj Level 1 Level 1 (0 points)

    I seem to have fixed the problem by un-syncing all non-app content (removing all music, podcasts, photos, etc., but not apps) from the iPod, disabling auto-lock on the iPod, re-syncing all content, and re-enabling auto-lock. Three good syncs today following this.

     

    Possibly related: I'm no longer seeing any device backups listed in iTunes Prefs / Devices, except for only the most recent backup. I've tried toggling backup encryption and autosync, to no effect.

  • GadgetGav Level 1 Level 1 (10 points)

    No one from Apple ever actively participates in these forums. I think we all hope that they read them and use the problems raised here to fix bugs in their software, but I don't think I've ever seen an official reply from them here.

  • startswithj Level 1 Level 1 (0 points)

    It's good to file here on the forums as well as at: http://www.apple.com/feedback/

  • jasonronnie Level 1 Level 1 (0 points)

    This drove me mad, but finally doing a BACK UP now then RESTORE, I finally got my music on. Very disappointed that apple didn't pre-empt this by informing people who downloaded ios7 and itunes 11

  • Prashanth Immanuel Level 1 Level 1 (0 points)

    I have the same problem fed up with this issue...also my apps syncing stops by itself halfway through the sync! And I kept on sycing until it finished... Very disappointed with new itunes and ios 7!

  • MacinNW_Brent Level 1 Level 1 (90 points)

    Nancy, this is a community discussion, not an Apple help line. If you want immediate help, then call AppleCare or take it into an Apple Store.

     

    I've have a similiar problem, and I have been working with a tier 2 tech, and it has been escalated to an engineer. I'm still waiting, because this is probably going to need another update.

  • startswithj Level 1 Level 1 (0 points)

    This problem appeared to solve last week, but it's returned again today.

     

    I tried to sync via USB (it had been a couple of days), but it got stuck on the final step for five-plus minutes. I cancelled the sync, ejected the device, unplugged and reconnected…and now the Sync buttons are greyed/inactive, and the content bar simply says Other (yellow), rather than Audio, Video, Photos, etc. 

     

    iTunes 11.1.1

    iOS 7.0.2

  • MacinNW_Brent Level 1 Level 1 (90 points)

    The fact that you are only seeing Other in th content bar, and other things I have noticed, seems to suggest that iTunes is not properly recognizing content in iTunes on the Mac.

     

    When I try to sync, it hangs on "Importing Photos" or "Analyzing Photos", but it does not import anything. I have 1.03 GB of photos on my 4S. I also have 13.48 GB of music on there. When I change the settings to not sync any music, it pretends to remove it, but all the music is still on the 4S.

     

    For several syncs after that, the lie persists, and when I try add anything else on it gives me a "Over Capacity" warning. It seems to by itself change my settings to add in the music and the over capacity amounts indicate this.

     

    May I suggest calling AppleCare and opening a case? They generally allow free help for 90-days after a major software release. If they want to charge you, just decline.

Previous 1 2 Next