Previous 1 2 3 4 Next 1,011 Replies Latest reply: Aug 18, 2014 1:09 AM by Go to original post Branched to a new discussion.
  • guptavarun Level 1 Level 1 (0 points)

    I Tried but to no vail...Really frustating tht wifi worked fine until ios 6 and in 7 its gone with the wind...

  • Dannymeagle Level 1 Level 1 (0 points)

    I am also having this problem. Wifi was fine at first, but was lost once I started messing with the Wifi control (turning on/off) from the new "control center" pane accessed by swiping up on the screen.


    I should also note it is clearly bugged out because now the Wifi button will not even give me the option to turn on. It is permanently stuck in the off position. Very odd, would appreciate any feedback.

  • wabbitkilla Level 1 Level 1 (10 points)

    Same as Danny here, was on 6.1.3 then upgraded to 7 and poof WiFi won't turn on in general but shows you can turn it on in the sweep up control panel ... But never actually comes on.


    This is the second time an iOS update has done this to me, last time they released a further update days later to fix it. I think I'll be switching away from Apple now they've managed to do it twice.

  • KilaBite Level 1 Level 1 (0 points)

    Exact same issue as you across 3 seperate Apple devices. My Ipad (3rd gen), my Iphone 5 and my girlfriends Iphone 5 all experiencing issues. Worked for around 30 hours and now won't connect at all. All other wireless devices in my household (and there are a few) connect absolutely fine.


    I use a BT Homehub 3.0. I'm going to work in a minute and I'm going to try it there on an industry Netgear wireless network.

  • barbar00 Level 1 Level 1 (0 points)


  • KilaBite Level 1 Level 1 (0 points)

    Update on this: Iphone connects fine to network at work which uses a different wireless device (Netgear).


    Both my workplace wireless network and the wireless on my home use WPA2 so they should be the same. I doubt it's the encryption level. As a test tonight I will temporarily disable the security on my wireless network and see if I still get the same issue. I also have not yet tried assigning the phone a static IP so that's something else I can attempt.


    A colleague of mine updated his phone at the same time as me, he uses a Sky router and is not getting this issue.


    Will update with results as I get them.

  • johnpimm Level 1 Level 1 (0 points)

    Same for me.


    Worked OK for several hours but failed last night - now having reset the network settings I can turn WiFi on via the control panel but the toggle in the Settings is still set to off and the toggle is unresponsive.



  • tonefox Level 6 Level 6 (9,010 points)

    Anybody around here tried rebooting the router?

  • KilaBite Level 1 Level 1 (0 points)

    Yup, turned it off, left it for 5 minutes and powered back on. Tried this twice and no joy.

  • Triviums Level 1 Level 1 (0 points)

    IOS 7 has a wifi bug. Today I recieved an email from the IT Department at my university recommending me not to updgrade to IOS 7 due to a wifi bug. They said that if you upgraded to IOS 7 that they could not help me. The only solution is to somehow reinstall IOS 6. My university uses the newest wifi technology so if you don't want to downgrade your iphone, change your router/modem to a older one you might have lying around.

  • Frombatops Level 1 Level 1 (0 points)

    So my issue with wifi is that it won't even turn on. I can turn it on using the Control Center, but it doesn't actually turn on, it says its on and the little wifi icon is enabled but then when I go into settings Wifi is still off. Then to make things worse, when I am in settings, then click to go into Wifi, I can't even hit the button to turn wifi on. It is as if it is disabled. I can press and press but nothing happens. I tried some of the things on this forum hoping they would work and nothing did. I guess my only option now is to go to an Apple store.

  • berms_248 Level 1 Level 1 (0 points)

    @Triviums - your  IT department is certainly correct. I wish I didn't upgrade. I have now lost all wi-fi ability on my iPhone 4S.


    I updated through iTunes this morning and I did get a carrier update message. Was hoping that would solve the problem but to no avail. This is very frustrating - I have no wi-fi and my iphone doesn't even recognize wi-fi networks in the area.


    Carrier message via iTunes (that did nothing)

  • bam11 Level 1 Level 1 (135 points)

    Yes, it will wipe out all your set wifi passwords.  The issue has returned again today in which I had to follow the same steps again to resolve the issue.  Given that there seems to be a lot of folks encountering this issue specifically with iPhone 4S I can't help but assume this is a bug with iOS 7 and we'll have to wait for a software update to fully resolve it.

  • berms_248 Level 1 Level 1 (0 points)

    Mashable already reporting that Apple working on iOS 7.01 to fix bugs.


  • ColumbusCraig Level 1 Level 1 (0 points)

    Mine didn't work and I tried all of the other suggestions.  I changed the wifi to static IP and then it started to work.  Does not work with DHCP.  Work around for now.

Previous 1 2 3 4 Next