7 Replies Latest reply: Nov 17, 2013 9:05 AM by Jocomo
Mohamed01 Level 1 Level 1



how can I open a PDF attachment in a differant app for example adobe app. previously we had the option to open in

iPad mini Wi-Fi, iOS 7
  • Mohamed01 Level 1 Level 1

    is anyone having the same issue

  • EML1990 Level 1 Level 1

    i am having the same problem, I cannot download any pdfs onto my ipad. I use my ipad for course readings, and the inability to download pdfs is extremely frustrating.

  • baskingridgerealtor Level 1 Level 1



    After reading all the posts about this, and some people deleting ibooks, and others adobe reader, and yet others restoring and fine until all apps are loaded, I updated ALL my apps today, many of which had ios7 compatibility issues, and now my ipad opens pdf files. It used to say tap to download, and now they show that they are pdf files, and one tap opens it right up.


    This was way easier first step rather than trying to  find out which app was causing the conflict, restoring, or doing work arounds.  I hope you all are lucky enough that the app with your bug item has created their fix.


    The problem I had occurred after installing ios7, on iphone and ipad.  Iphone5 worked perfectly from the get go, while Ipad third generation did not recognize pdf attachments, and if lucky enough to open, only first page opened as if it were a single jpeg (embedded to email).  Thinking it was an ipad version of an app as my phone and pad pretty much share all apps.


    So bottom line, update ALL of your apps -- I now made mine auto update, and it should work.

  • Deewee Level 1 Level 1

    It may be fixed for you, but the problem is still there for other people.

    Does anyone know how to solve the problem?


    After the ios 7 update there is no option to "Open In ..." any more for email attachments.


    Basically the pdf attachment downloads, and opens in the email, BUT you CANNOT open it in another app!

    A long press on the attachment just gives the option "Copy" or "Save Image".

  • ppitton Level 1 Level 1

    Ok guys,


    another one "resolved".


    This seems to be the only way to "find out" the "bad" app.

    One more workaround (if you need the "bad app" and cannot delete it): if you have GoodReader: this can "connect to your email-account via POP or IMAP and you can then open the PDFs directly in GoodReader what I for the most of times did anyways.


    Not the perfect solution, but......


    Reportet this to Apple's BugReporter and via a personal "high-level" contact (I talked to personally) to the engineering guys already.









    Problem solved!

    I compared what "open-in" - capable apps I had "more" on the iPad than on the iPhone (or iPad mini) [both no problem].



    Started to delete one by one:

    1) Aviation Docs

    2) PDF Master

    3) Kindle

    4) Mediacenter (T-Online)

    5) Team Viewer

    6) WebEx (Cisco)

    ... no changes



    eh voila!!!!!

    7) iPreFlight

    Now, PDF - open-in in Mail.app (Apple) works again.

    For confirmation re-installed iPreFlight and it stopped working again and after de-installing again everything works fine.



    Good enough for me to know and work with, bad enough for Apple's mail.app do get confused by third-party-app......






    thought to let you know, guys.









  • Deewee Level 1 Level 1

    OK, problem solved also! One app is not ios7 compatible!


    You can't see which apps will open an email PDF attachment because of this incompatibility.

    So download and open a PDF file using safari - this will give you a list of apps which can use PDFs.


    You may be surprised to find some document reader and scanner apps you didn't know worked for PDF files. Just make a note and delete them until email PDF attachments work properly.

  • Jocomo Level 1 Level 1

    Have run into the same issue since the iOS 7 update. I can no longer open PDFs attached to mail in an alternate app on my ipad. The "open in" dialogue is missing. No luck deleting all of the PDF reader apps and reinstalling. I can transfer PDFs from Dropbox, however, via my laptop, so that's my fix until Apple or the deviant app fix the bug. Please address this problem. (No issue with Safari PDF downloads. It seems to be a Mail bug.)