Previous 1 5 6 7 8 9 10 Next 145 Replies Latest reply: Jun 20, 2014 10:23 AM by Vince Egan Go to original post Branched to a new discussion.
  • SteveYates Level 1 (5 points)

    The size of the inbox might indeed be a factor. My inbox is around 1500 messages.

     

    ... trashing the very first message in Inbox is successful (without the message re-appearing a couple of seconds later, as happens with any other message but the first).

    My inbox is only 230 messages.

     

    Interesting observation on the first message...it took a few days until I wanted to delete the first message, but I did that just now and you're right, the first message in the inbox did not reappear after being deleted.  I actually did it twice, deleting two messages one after the other.  Then after deleting the now-fourth message, that one reappeared.  I wonder if that's why I thought that the 7.0.2 upgrade fixed it, earlier.

  • Steven Jones3 Level 1 (15 points)

    And still no change in 7.0.4, at least not for me, the problem persists. At this point I'm wondering whether it'll take a change to UW IMAP to fix this, I'm kind of giving up hope.

  • larryfromelizabethtown Level 1 (0 points)

    I had this issue fixed when I manually re-entered my passwords into each of my SMTP server settings and IMAP settings.  Then I upgraded to iOS 7.0.4.  It's back again and re-entering the passwords doesn't help.  I had to switch off SSL on all my accounts to get any email via wifi (it works via 4G/LTE).  Extremely annoying and frustrating.

     

    I'm seeing similar issues on my Mac Pro with Mavericks but not anywhere near to the same extreme.

  • johnsbramhall Level 1 (0 points)

    Yesterday's update did NOT fix the IMAP-Mail problem of zombie emails that return from the dead (deletion) on both iPad and iPhone running 7.0.4. I should note that other email apps that I have been forced to try out (such as Sparrow and AltaMail) do not show the problem - I strongly suspect that the solution lies with correction to the Mail app rather than to any settings on the IMAP side. It's a very frustrating issue, and since it affects one of the core functionalities of the devices (email) it really should be a priority for Apple to find a solution. IOS 7 broke something that had previously worked well - this is not progress!

  • blofgren Level 1 (0 points)

    Just to add a negative data point... I'm using iOS 7.0.3 on a 4S with about ten IMAP accounts, varying number of mails in the inbox from a handful to thousands. I've not experienced any of the problems described in this thread. The server is Courier-IMAP with either self-signed or "real" SSL certs. Also, refreshing my largest inbox with ~2000 mails of which ~1200 are marked unread takes about 3 seconds.

     

    I'm guessing that they have started to rely on some IMAP feature that isn't implemented across the board, although I haven't dug deeper into the issue (since I don't have the problem... sorry guys).

  • JuhaVSV Level 1 (0 points)

    Just to add some of my observations (iPhone4, iOS 7.0.4) and using IMAP with SSL to mail.kolumbus.fi.

     

    Deleting the first mail (latest mail on top of the list) works, but mails in between others reappear if deleted after the phone does its resync. If I put the phone into flight mode and delete a message it will reappear when doing the sync although naturally the phone has no network connection.

     

    I also use my imap-account from a PC with Outlook or then with a Webmail using browser. I have deleted messages with these clients from the imap-server i.e. regularly clean up my inbox, but that cleanup is not recognized by the mail app on the iPhone which seems to keep somewhere really old messages that now are not even possible to delete. These messages that the phone seems to see have long been deleted with the other clients I use from the mail server inbox. At least with iOS 6 this annoying feature was possible to be handled by deleting the messages separately on the phone, but now since the delete does not work this is really a problem.

  • SteveYates Level 1 (5 points)

    Another thing I've noticed...if you delete the second message it reappears. If you then delete the first message, the second message disappears. It's like message Tetris! :)

  • Steven Jones3 Level 1 (15 points)

    Maybe it's now connected to the Game Center and I can find a setting there to fix it.

  • Flowingon Level 1 (0 points)

    I have the same IMAP issues.  I have determined that once I delete the newest email any email that was previously deleted by any of my IMAP systems (including the ipad) then no longer show up in the iPad inbox as long as there is no undeleted email newer.  This is really an Apple issue as Outlook, Galaxy all work fine on the same email account.  Galaxy will delete the email immediately (as does the ipad, but the ipad decides to show it as being active in its display anyway!)  If I delete an email on Outlook, it still shows in Galaxy until it does a sync (as you would expect) and once the sync occurs the email is gone.  IPad can resync and still shows the deleted email as long as there is a newer undeleted email in the inbox.... crazy.... doesn't matter where the email is deleted, iPad, Galaxy or Outlook.  you would think it could handle at least the emails it deletes itself.

  • mds1327 Level 1 (0 points)

    I had Push disabled under Fetch New Data in my mail settings. I'm sure that's how I'd always had it, since I prefer to manually request my mail. However, after having had the problem with my message statuses not updating, and with being unable to delete mail, since the release of IOS7, I recently decided to try enabling Push, just for kicks. And it seems to work. My email now updates properly and email stays deleted. I made this change after the release of 7.0.4; it's definitely the setting change, not the patch, that made the difference.

  • JuhaVSV Level 1 (0 points)

    Does not help in my case to have "push" enabled. For an Exchange account the "push" is almost a push, but for IMAP the the "push" then gives the option to fetch the emails with 15min, 30min or 1 hour intervals (or still manual). It seems that the problem exists regardless how many different email-accounts are in use. Even a newest iPhone5 S with one single IMAP account does this. So this is certainly iOS maill app problem.

  • Flowingon Level 1 (0 points)

    Did not help for me either.  Push was on but tried changing it to off and then back on.  No change.

  • Faeron Level 1 (0 points)

    I was running uw-imapd. I replaced it with dovecot and all my IMAP problems are gone! It seems that uw-imapd does things not according to the standard.

     

    IMAP itself also appears to be broken. http://www.courier-mta.org/fud/

  • SteveYates Level 1 (5 points)

    Interesting, thanks Faeron.  There was one other post that upgrading Dovecot versions fixed the issue, but also several other posts that other mail servers have the problem also.  Perhaps Apple only tested with a recent Dovecot version?  Regardless, if it worked in iOS 4-6 and doesn't in 7 it seems more like a bug than a server problem, or else Apple should say it's only compatible with some IMAP servers.

  • mgmead Level 1 (0 points)

    It's maddening that Apple is ignoring this situation.  Having seen a similar effect on the voicemail app (while on a slow connection, delete with a swipe, message reappears), my guess is that it's a flaw in the framework around swipe to delete, etc.

     

    I've already notified my admin to consider upgrading the IMAP server on our corporate box, but I'm really NOT interested in chasing this forever while Apple sits around doing nothing.  Maybe it's time to consider a different platform.

Previous 1 5 6 7 8 9 10 Next