Previous 1 2 Next 20 Replies Latest reply: Nov 30, 2014 5:32 AM by .Ed. Go to original post
  • neainc1 Level 1 Level 1 (0 points)

    We need to at least email Apple, but I'm sure they know about the problem. I just wish they would fix it.

  • Joker242 Level 1 Level 1 (0 points)

    I've got the same problem but with videofiles. The only difference I could find is that the video metadata referencing the kind of file (not the media kind) shows up in a different language. eg: "MPEG-4 video file" and "MPEG-4-videobestand". You might want to check if this is the case with your podcasts. If so, this is a very serious bug in my opinion. I have already submitted a bug report to apple. If we all do the same hopefully they'll fix it. This is in Itunes 11.1.1 by the way.

  • patmart00n Level 1 Level 1 (0 points)

    ver 111232 seems to have fixed the problem -

  • kls67 Level 1 Level 1 (0 points)

    Oh no, after downloading the updated iTunes 12.0.1 I now get the dreaded message "Your selection contains more than one kind of media" if I try and bulk edit my podcasts. This has never happened before so I'm hoping it's a temporary blip. I do wish Apple would stop messing with things!

  • camaro-68 Level 1 Level 1 (15 points)

    With iTunes 12.0.1.26, I had the same problem with an audiobook. It was just the first one I found, so there are probably more in my library. I solved it by deleting the tracks in iTunes without deleting them from my computer's drive. I then added them back into my library. With music I think that's all you have to do, but with audiobooks you need to change the Media Kind back to "Audiobook" under Options (from Get Info).

  • .Ed. Level 1 Level 1 (0 points)

    I just ran into this issue as well and found a free (for 10 days) tool to fix them  http://dougscripts.com/itunes/scripts/download.php?sc=setvideokindofselected 

Previous 1 2 Next