5 Replies Latest reply: Nov 24, 2013 6:04 PM by rjmk265
swandy Level 4 (1,155 points)

When I take a "filtered" picture with my iphone 5/iOS 7 it comes out fine. And when I look at the image either in the camera roll or in Photo Stream on any of my devices it still looks "filtered". However, when I open up Photo Stream on my iMac in either Aperture or iPhoto it is just a normal "non-filtered" shot. Anyone have any ideas of why this is happening?


iMac, Mac OS X (10.7.1)
  • philiphab Level 1 (0 points)

    Experienced the same thing when importing from iPhone 4s to Lightroom 4.2 (win7). Tried all 8 filters & neutral. All photo's came out similar; even black& white photo's were imported as colored originals. EXIF-data were all idenetical (except time-stamp)

  • swandy Level 4 (1,155 points)

    Philip - I had a solution for you before I realized you were using Windows/Lightroom as opposed to iMac/Aperture.

    The only other work-a-round I found was actually emailing the filtered photos to myself and then opening them up on my iMac. They were then filtered.

  • philiphab Level 1 (0 points)

    Swandy, thank you for your quick answer. That works indeed.
    But it would be nice to see this problem solved, because o batch import for a lot off photo's is a bit tedious


    I saw this same problem appear on other fora. Do you think this is an ios7 bug or a dark insight from apple?
    And if a bug, would you perhaps know if I can file a report?

  • swandy Level 4 (1,155 points)

    It's not actually a bug. The filters and adjustments in the Camera and Photo app are non-destructive (sort of like the way Lightroom and Aperture also don't change the original file when you make adjustments).  The filter info is stored in such a manner that the camera app and I believe iPhoto for iOS sees the changes and displays them. But when you import the photos - BTW the same thing happens with Apple software like Aperture - they don't see the effects.

    What is strange is that (1) some other apps on iOS devices also don't see the filters and (2) if I use Apple's Photostreams to transfer the pictures they appear non-filtered to Aperture. But if I set up a shared Photostreams then they show properly.

    I guess only time will tell if it can be resolved - perhaps with a way of saving the adjusted photos.

  • rjmk265 Level 1 (0 points)

    I had this problem too, and after 3 hours of updates i have figured it out. You must have OS X Mavericks and iPhoto '11 in order to actually have the compatability of the iOS 7 filters. Then, you have to turn on iCloud, and all the filters if (and only if) they are in your photo stream. It's really easy to get them into the album, just take a screenshot of the selected pictures and then they will appear in your photo stream. Hope this helps!