13 Replies Latest reply: Sep 21, 2013 10:35 AM by BDAqua
Karyn.Taylor Level 1 Level 1 (0 points)

Hey all, 


Recently I have encountered a problem when using the mail application.

It continues to tell me to check that my password and username/email are correct.
Now, I'm not entirely computer illiterate, and having computer science degrees in the household.. we're STUMPED.

To start off with, it was telling me the IMAP and SMTP servers were wrong, and from there - we double checked these, deleted the accounts, re-entered the accounts and all SEEMED to be working. Now however it is telling me to confirm my email address and passwords, I haven't changed them.  I log in online using the same passwords.  I deleted the account again and re-entered.  Yet the problem still persists. 

Is anybody else coming across this sequence of problems?
Any ideas of how to fix?


Thanks greatly,



MacBook Pro with Retina display, OS X Mountain Lion (10.8.4)
  • BDAqua Level 10 Level 10 (121,185 points)

    Hi Karyn,


    The Password rejection can confuse people since it's a catch all meaning...


    This Password, Username, Authentication method... is not recognized on this Port to this Server, or a server end problem.


    Or duplicate entries in Keychain Access.


    If using a browser to login via WebMail works it's not Name or Password, but one of the other ones.


    The receiving email ports are:


    IMAP is port 143

    IMAP-SSL is port 993

    POP is port 110

    POP-SSL is port 995

    Outgoing ports are...

    SMTP and SMTP-SSL is on ports 25, 587 and 465. Port 587 has to be SSL, and port 465 is enforced TLS-wrapped and is generally used by Outlook users.

  • Karyn.Taylor Level 1 Level 1 (0 points)

    Yeah I have all the ports correct,
    The only issue is the IMAP.
    I had the same issue with my gmail account on the mail application.
    However that one has resolved fully when we deleted everything and just re-entered.
    Is there something else I could be missing, I've followed up on a few issues other people have had with rocketmail, and they all seem to say something along the same lines as my issue, but nobody seems to have a solution.


    I've only just recently jumped aboard the apple bandwagon, so it could be quite possible that there is something so blatantly obvious that I have missed while getting used to it.?

  • BDAqua Level 10 Level 10 (121,185 points)

    I don't think it's you, rocketmail & Yahoo have frequent outages, the webmail server & eMail servers sre different, I really suspect it's on their end, I don't havwe an account there, but maybe you can test yours here...



  • BDAqua Level 10 Level 10 (121,185 points)

    Oh, is it using SSL or not, & the correct Authentication?

  • Karyn.Taylor Level 1 Level 1 (0 points)

    Claims to be working..



    and using SSL if i don't it just throws a major temper trantrum - regardless of what port I try that on.

    Authentication is right as far as I can tell, use the exact same to sign in on the yahoo site itself.
    But mail has just decided that my password is wrong and refuses to connect to IMAP.
    STMP works fine on the same authentication.


    - Thank you greatly for your time.

  • Karyn.Taylor Level 1 Level 1 (0 points)

    This is the only error that shows in the connection doctor if that helps..



    "READ Sep 20 13:16:40.601 [kCFStreamSocketSecurityLevelTLSv1SSLv3]  -- host:imap.mail.yahoo.com -- port:993 -- socket:0x7fcccc17dbf0 -- thread:0x7fccca8328b0

    2.40 NO [AUTHENTICATIONFAILED] Incorrect username or password. (error 999)"


    But as I said... I am 100% certain that the password and user are correct.

  • BDAqua Level 10 Level 10 (121,185 points)

    In Mail>preferences>Accounts>Account Information>Account Type, did Mail set it up as POP or IMAP?


    Here are the IMAP settings in one place, works for Apple Mail and iOS with Yahoo and Yahoo Plus mail, also works with Win7-Outlook 2010.

    To set up IMAP on Yahoo and Yahoo Plus use these settings:

    Incoming Server - imap.mail.yahoo.com

    Outgoing Server - smtp.mail.yahoo.com

    Incoming Port - 993 (requires SSL)

    Outgoing Port - 465 (requires SSL/TLS)

    Username: full email address (for example, bill@yahoo.com or bill@rocketmail.com)

    Password: the password you login to Yahoo! with.


  • Karyn.Taylor Level 1 Level 1 (0 points)

    It set up as IMAP.


    Yeah I have those - is working again randomly for now.
    touch wood the problem wont resurface again though.


    From what I could tell, there was something interfering between the mail application and sending the information through to Yahoo.


    The last warning I got from Mail stated that it could not send my user and password across a secure connection to IMAP.mail.yahoo.com and that sending the information posed a security risk to my confedentials. It then requested I send the information to Yahoo manually and provided me with a weird link - I don't think so. I Disconnected from my home network, "forgot" the network, connected to my mobile network, managed to set mail up, then reconnected to other network - all seems fine now.

    Honestly - I thought macs were supposed to be user friendly haha.


    Thank you again for your time and effort!!!!!!!!!!!!!!!!

  • BDAqua Level 10 Level 10 (121,185 points)

    Hmmmm, almost sounds like a Router problem, did you restart the Router?

  • Karyn.Taylor Level 1 Level 1 (0 points)

    I was connected to a university network, there was nothing the IT department could figure out would be wrong.

    Now I'm at home, and now all IMAP and SMTP for all my accounts are having problems. :(

    Was fine until midnight last night. (New Zealand time).

    From that point onwards, connection dr just couldn't connect. Have shut down mac and turned off router to see if that helps - no success. :(

  • BDAqua Level 10 Level 10 (121,185 points)

    Who is your ISP at home?

  • Karyn.Taylor Level 1 Level 1 (0 points)



    Again... In New Zealand.


    Seems to be working now though. *fingers crossed*

  • BDAqua Level 10 Level 10 (121,185 points)

    Great to hear, it does sound like there was a problem on there end... good luck!