5 Replies Latest reply: Jun 8, 2014 5:56 PM by CAINTX
sschulte21 Level 1 (0 points)

My 2013 Mazda3 will not allow me to change songs wirelessly on Bluetooth through the steering wheel.


iPhone 4S, iOS 6, Solo Beats
  • jason269 Community Specialists

    Hi, sschulte21

     

    Thank you for visiting Apple Support Communities.

     

    Here is an article you may find helpful when experiencing this issue. 

     

    iOS: Troubleshooting car stereo connections

    http://support.apple.com/kb/TS3581

     

    Cheers,

     

    Jason H. 

  • MadMikePDX Level 1 (5 points)

    I'm having what sounds like the same (or very similar) issue with my aftermarket Kenwood KDC-MP745U stereo. iPhone 4S, iOS7.

     

    What works:

    • iPhone pairs with the stereo, phonebook downloads, stereo unit can display music info
    • I can initiate/terminate phone calls from the stereo head unit, and I can answer
    • Music/sounds/calls play through the stereo
    • Controlling music via the iPhone (play/pause, next, back, etc)

     

    The above items rule out a connectivity issue.

     

    What doesn't:

    • Controlling music via the stereo unit (play/pause, next, back, etc) This worked prior to updating to iOS7.

     

    The stereo unit doesn't appear to have a BT firmware update available from the web site, and the only thing that changed in this situation is upgrading to iOS7.

     

    I have read in other discussions here that restoring the iPhone will do the trick, so will be trying this tonight.

  • MadMikePDX Level 1 (5 points)

    Turns out all I had to do was power the phone off and then back on. I figured I'd give that a try before going through the whole Restore process, and it works fine now.

  • JulieHooker Level 1 (0 points)

    Thank you so much MadMikePDX, I was having kittens as my bt was not working in my madza. It would not come on by it self, I had to go to my phone and select a song and then it would not change songs at all. I rang the dealership, they told me I had to come and see them (I live an hour and a half away) so I googled, read your post and powered my phone on and off, and hey presto by bt is working again. Thank you again.

  • CAINTX Level 1 (0 points)

    On another forum I found the solution: check your contacts, if any have an Emoji in the contact info remove the Emoji. Then completely delete ( unpair) your phone and reconnect and IT WILL work. No idea why but it worked for me..