Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone 5 iOS 7 can't send from gmail account

I've been using my iCloud account to receive push notifications from my gmail emails, my gmail emails are being forwarded to my iCloud account. I've set the outgoing server settings that it won't use the iCloud SMTP server, but it will use smtp.gmail.com so it will send using my @gmail.com address.


Setting -> Mail, Contacts, Calendar -> iCloud -> Account -> Advanced Mail -> outgoing mail server -> Turned off iCloud SMTP server and added smtp.gmail.com as other outgoing server.


Since I've updated to iOS 7 it's not sending with my @gmail.com anymore, but it's now sending with @icloud.com. On my iPad I've the same settings, but I've not updated yet to iOS 7 and on my iPad it still sends with @gmail.com.


Does anybody know if they changed something in iOS7 and if there is a workaround for this?

iPhone 5, iOS 7

Posted on

Reply

Page content loaded

Oct 13, 2013 11:29 AM in response to IndoGer007 In response to IndoGer007

The following workaround in another thread helped me and was the solution:


https://discussions.apple.com/message/23364948#23364948


niijonodhg

Re: Problem with iOS 7 and smtp Gmail

Oct 11, 2013 6:02 PM


Yup sure;


MY ICLOUD ACCT DETAILS:


IMAP ACCOUNT INFO:


Name: "Jono Bradley"

EMAIL: (MY ICLOUD EMAIL ADDRESS)

Description: Icloudgmail


INC SERVER:


Host Name: imap.mail.me.com

Username: (MY USERNAME)

Password: (MY PASSWORD)


OUTGOING SERVER:


Primary Server:


(OFF)

Host Name: smtp.mail.me.co (TOOK THE "M" off .com)

Username: (MY ICOULD EMAIL)

Password: (MY PASSWORD)

Use SSL: ON

Authentication: PASSWORD

Server Port: 587


OTHER SMTP SERVERS:


(ON)

Host Name: smtp.gmail.com

Username: (MY GOOGLEMAIL EMAIL ADDRESS IN FULL)

Password: (MY PASSWORD; I DO NOT HAVE TWO STEP VERIFICATION. IF YOU DO, YOU WILL NEED TO GENERATE A PASSWORD SPECIFICALLY FOR THIS)

Use SSL: ON

Authentication: Password

Server Port: 587



Thats all the details and it works fantastically!

Oct 13, 2013 11:29 AM

Reply Helpful

Oct 13, 2013 12:04 PM in response to IndoGer007 In response to IndoGer007

I have spent about 4-6 hours working directly with folks from Tim Cooke's office, various support levels, and through them their engineers.


As much as I tried to convince them their logic is flawed, the engineers for iCloud come back and say this is expected behavior because somehow it helps secure iCloud from being a spam source. The fine and helpful gentleman from Cooke's office now understands how it is a MobileMail.app client issue, having nothing to do with iCloud servers (because we are in fact trying to bypass their servers) still totes the "it's expected behavior" line from the server engineers.


I have implored him to follow up with the iOS MobileMail app programmers and not the iCloud programmers. I am hopeful he will. Until then you have to choose between having iCloud push and losing your online identity, or losing push email and keeping your preferred address.


Fun to try: turn off all smtp servers. Send email. Gets stuck in outbox. Turn on your preferred smtp server. That one email will use your preferred alternate address, but subsequent ones revert back to the old .me.com smtp servers. Personally I believe this points to a client programming error more than reinstating a preferred behavior. Aggravating!


I spend $500 on a new phone. Google takes away my exchange client ability and apple makes me choose push email vs outgoing email address.

Oct 13, 2013 12:04 PM

Reply Helpful

Nov 21, 2013 1:25 PM in response to KiltBear In response to KiltBear

I am having the same problem...


Now I can not send emails for work form my phone. I can only send email via Gmail, but if I try to send from my work address, which nowmally I also send via Gmail, it tries to send it through a non existent SMTP server using my work domain even though the default SMTP is set to Gmail...


This has wrked fine for literrally 5 years with 3 different iPhones and now I am screwed.

Nov 21, 2013 1:25 PM

Reply Helpful

Nov 22, 2013 4:34 AM in response to creator0 In response to creator0

I spent 1.5 hours on chat with Apple support and found the resolution to my problem... Hopefully this helps some others as well.


When I updated iOS to 7.0.4, for some reason it changed a setting in Mail and turned off the secondary SMTP servers.


If you go to Settings>Mail,Contacts,Calendars> Then choose the mail account that is not working, then click on the Outgoing Mail Server, you should see a Primary server and at least 1 "Other SMTP Servers".


In my case, all of the Other Mail Servers were Off. Apparently the upgrade somehow caused thes to toggle off.


All we needed to do was to toggle it back on and that did the trick.


Now I can send mail from my work email again and it sees the proper SMTP server.


Hope this helps you all as well!

Nov 22, 2013 4:34 AM

Reply Helpful (1)

Nov 22, 2013 4:55 AM in response to IndoGer007 In response to IndoGer007

I'm glad this helped you to solve the problem on your phone, but with me it doesn't work, while my primary server (iCloud) is already off and the gmail smtp is already on, but it still send with @icloud.com.


Btw the workaround I posted on 13 October also don't work for me anymore, it is sending with @gmail.com with this workaround, but I don't get push notifications.


So I'm still waiting for an update from Apple where they fix this, my iPad with iOS 6 still works good, so I'm not upgrading iPad yet till this is fixed.

Nov 22, 2013 4:55 AM

Reply Helpful

Dec 3, 2013 11:41 AM in response to IndoGer007 In response to IndoGer007

My fix to this problem (gmail not sending from the defult email in iPhone 5s) was the one given on the gmail help page:

"If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending mail, try configuring your SMTP to use port 25 (with SSL)."


No problems after switching the outgoing SMPT port to 25 :-)

Dec 3, 2013 11:41 AM

Reply Helpful
User profile for user: IndoGer007

Question: iPhone 5 iOS 7 can't send from gmail account