0 Replies Latest reply: Sep 20, 2013 4:32 AM by maybel-kay
maybel-kay Level 1 Level 1 (0 points)

It is because my ipod cant sync to a certain itunes,and it says on the back that i need itunes 10.5 or later,but when i downloaded the latest program,it said "A required Itunes component is not installed. Please repair or Reintstall Itunes." (-45019) Plus it cant even slide to get the wi-fi on. it would be a great relief If you could help me.


iPod touch, Other OS, Need help with turning on wi-fi