6 Replies Latest reply: Apr 19, 2014 11:26 AM by GMan6000
PuppetArt Level 1 Level 1 (0 points)

IPhone 4S (AT&T) updated to ios7 is not receiving texts. I can send texts but they aren't iMessages like they were before the update(they are green, not blue). Anyone find a fix for this yet?


More info:

I do see the texts on my iPad 2 which was also updated to ios7.


  • AgentJoshH Level 1 Level 1 (70 points)

    I would just like to clarify, are you not being able to send or receive anything from the iphone or is it just imessages

  • PuppetArt Level 1 Level 1 (0 points)

    I can send a text message from my phone. It is not an iMessage, just a regular text message. As I understand it, the iMessages are in blue and regular text messages are in green.

    I went into settings-messages and under iMessage it said "waiting for activation." I entered my Apple ID and password and then I got the message:

    "iMessage Activation

    Could not sign in. Please check your network connection and try again."


    I get the same message when I try to sign in to Facetime.


    My network connection is up and running just fine. Just in case I turned off the wifi on the phone and tried again. same message.

  • PuppetArt Level 1 Level 1 (0 points)

    This fixed it for me:


    back up iphone using iTunes

    Go to:



    erase all contents & settings

    restore backup

  • doug123a Level 1 Level 1 (0 points)

    Fixed! (My situation anyway....) It was maddening—only some messages were not coming in, depending who it was.


    SO: Settings > Messages did not show my apple id as "activated." I reentered the data and tried a couple times until it started working.


    Be careful that people are writing to your corrrect apple id, which is associated with your phone number on the server. Also, your phone number should be entered in the settings. You can use the Messages application on a computer to test message delivery.

  • mendenhk Level 1 Level 1 (0 points)

    Another solution- one that has been working for me:

    First off, I got a galaxy note 3 last week after being an iphone user since the very first iphone came out.  Was unable to receive texts from iphone users (specifically my girlfriend).  I tried lots of things suggested (turning off imessages on my iphone, removing my iphone from my apple account, removing my iphone from icloud through itunes, etc.) and nothing worked.  What worked: thought it is by no means a perfect solution, i had one of my iphone friends try sending me a text and it went through.  When I asked her how she did it, she said she just tapped on the undelivered message and it gave her the option of sending it as a normal text, rather than an imessage.  After doing this twice, all of the texts she sent to me went straight through.  So I got my girlfrind and another friend to try this, and voila, it worked.  Like I said, a pain in the butt imperfect solution, but it did work. 

  • GMan6000 Level 1 Level 1 (0 points)

    I've just had this same problem and found the solution. Partly thanks to your guys posting on here.


    I realised that is someone sends a text to me it's fine, but if they send an imessage i'll never receive it.


    Go to Settings

    Scroll down to Messages

    You will see that imessage is turned on but says something like "waiting for activation" or some other message that implies its not working right.

    Turn imessage off then on again. It will say waiting for activation again but there will be an option you can press just underneath it that allows you to signin using your apple id, that's the key. Do this.

    Once you're signed in with your apple id imessage will work again and the problem is solved.


    I hope that helps people as it's just taken me 2 hours including calls to O2 customer service, software updates and all sorts before I found the solution. Hopefully this will save some of you the same frustration I just had.