Previous 1 2 Next 18 Replies Latest reply: Jul 5, 2014 9:44 PM by jcereola
Squizzel Level 1 (0 points)

Since I have upgraded to ios 7, for what ever reason my front facing camera will not work. Regardless of this been tried on the camera App or Facetime. When I switch to it, it just blurs the screen and hangs. Nothing else happens. Is anyone else having this same problem since upgrading? And if so has anyone got a solution to this?


Many Thanks



  • BackgammonThatUp Level 2 (350 points)

    I am not experiencing the same thing, but I think you should try quitting the camera app and also resetting your iPhone.


    Reset: Press and hold the Sleep/Wake button and the Home button together for at least ten seconds, until the Apple logo appears.


    I hope this helps!

  • Squizzel Level 1 (0 points)

    Firstly many thanks for getting back in regards to my problem. I should of really stated what I have already tried. But I have tried many times what you stated.


    Again though I appreciate your time in helping to resolve this matter!


    Kind Regards.

  • BackgammonThatUp Level 2 (350 points)

    Have you tried resetting all settings?  Go to Settings>General>Reset>Reset All Settings

  • THEcheesewire Level 2 (365 points)

    I didnt get this happening to me when I upgraded and was thinking tht you should try, if you havent already, restarting your phone after you close all the running apps.

    1. Double-click the Home button.
    2. Swipe left or right until you have located the app you wish to close.
    3. Swipe the app up to close it.




    If that doesnt fix it may need to restore the phone again. unless, wait...maybe I misunderstood your query

  • Squizzel Level 1 (0 points)

    Yeah I have tried that as well. Again many thanks for your efforts in helping me with this matter. However I shall try another restore to see if this resolves the problem. I take it no one else is having the same issue?

  • Andy_W_T Level 1 (0 points)

    The same has happened on my Phone. The flashlight has also stopped working. I have restored my phone to factory default and restored IOS7 a second time. This didnt work. Once my phone had been restored from the backup before IOS 7 I  did an erase all content and settings. This did not do anything initially. When I tried to restore my own settings it failed and the phone was locked in restore mode. I eventually disconnected it from my laptop. The phone rebooted and when it came back on the camera and flashlight were both working. I have now managed to restore my own settings/contacts/calendars etc. The camera worked for about 12hrs bur has now gone again as has the flashlight.

  • Klaas Koopmans Level 1 (0 points)

    Same here on my iPod 5th Gen.

    Camera works fine, but switching to front camera blurs the picture and the app freezes.

    Wenn I kill the app and start it up again, the back camera does what it has to do, but switching to front freezes the app again.

    I restored, reset in all possible ways several times, but nothing helped me get the front cam back.

    And Facetime is crippled too of course, as it uses the front cam. Only black. Sound is well of course.


    I'm happy I didn't install IOS7 on my iPad yet...

  • CZ_2011 Level 1 (15 points)

    hello all,

    I can confirm the same behaviour with an iPhone 4S, white, 64GB. We own 3 iPhone 4S in our family. 2 of them work flawlessly after the update to iOS7. The only visible difference is the white colour. With the white iPhone 4S we cannot use the front camera any longer. The camera app freezes, switch back to the rear side camera only works, after removing the camera app from the multitasking pane. Reinstalling with iTunes or via DFU mode or via settings-general-reset-contents&settings didn't help. A staff member of an Apple retail shop tried again, but again without success. We both agreed that it must be a software issue. All apps using the front camera (Facetime, Tango, Skype Camera+ etc.) do not work.

    The front camera worked well before upgrading to iOS 7.

    But 2 other iPhone 4S working without a problem even with the identical iOS 7 leads me to the question if Apple used different camera modells or even different suppliers for the front camera for production of the iPhone 4S. My only  explanation from an engineering point of view is that there were different cameras used in production and one of it now has a problem to connect correctly to the iOS 7, which indicates in this case a driver problem.

    2 possible solutions:

    1. wait until Apple releases a new version of the iOS which hopefully also covers this problem.
    2. let the front camera replace in a repair shop which will cost between 49 and 69 EUR (this morning I have investigated into some Internet shops offering this service)

    Cheers, Claus

  • taxipalm Level 1 (0 points)

    I too, am having this problem and resetting all settings did not work

  • Anthonyfromswe Level 1 (0 points)

    Ok guys, i got the weirdest solution for this which worked for me. After frustration of this problem i simply opened the camera-app, physically pressed on te front lens with my left thumb, while switching from rear lens to front lens, and viola! It worked!


    Dont ask how or why, but maybe, just maybe there is a glitch of some sort with the parts of the camera.


    Once again:

    Open camera app, make sure its on rear camera mode (normal camera)

    Press with the thumb and indexfinger (like pinch it)

    Switch to front lens


    Hope it works. I tried it for snapchat and camera app

  • taxipalm Level 1 (0 points)

    Weird, didn't work for me, but I was able to turn my vibrate on and off by pinching that spot?! LoL

  • jip121 Level 1 (0 points)

    Exactly the same problem on a white iPhone 4S.

    DFU did not fix, but I'm fairly sure it's software....


    Any news on dates for iOS update??

  • Dan___S Level 1 (0 points)

    Just for the record I have a white iPhone 4 with the same problem. I just bought it today. Again this started with an update to iOS 7. The rear camera works just fine but when I change to front camera it goes black and freezes the app. I can get the back camera working again only by closing the camera app and restarting it.  I have done a factory reset and don't have any additional apps installed. The only redeeming thing for me is I bought it cheap from someone who was fed up with fighting with the phone and Apple.  He is now proud owner of an Android phone.  I'm hoping 7.1 fixes the problem.

  • JustinLAO Level 1 (0 points)

    Hi I think I found a solution to this if you still need one.


    I have an iPhone 4S and this happens a lot. This is mainly a hardware issue ivolving the front facing camera connector disconnecting from the main circuit board. I recommend taking it to an Apple Store or if you feel you are up to it disassmembling the iPhone yourself to snap the connector back in place.


    This continously happens to me because I haven't actually done this but mine becomes loose every now and then. Referring to a previous reply from Anthonyfromswe where you push down on the front facing camera lens actually works in mine and his case.


    Below I have a picture of what I do. Enter a camera app, apply a good amount of pressure to the first red circle and then the second circle is where you switch to front facing camera and it should switch to your front facing camera. This is a quick fix and you will probably have to do this most of the times you decide to use your front camera.



Previous 1 2 Next