Previous 1 2 Next 17 Replies Latest reply: Jan 18, 2014 7:08 PM by Kapp610
ERock69 Level 1 (0 points)

Touch ID will work to unlock my phone, but not with iTunes or App Store. It keeps asking for my iTunes password. I have turned on 'Use your fingerprint instead of your Apple ID password when buying from the iTunes & App Store'. I am running IOS v7.0 (11A466)


iPhone 5s, iOS 7
  • vinny1575 Level 1 (0 points)

    Same thing is happening to me.

  • delarouch Level 1 (5 points)

    I've post this question & no reply from anyone. Apple?

  • Alive_84 Level 1 (0 points)

    I've figure it out what the issue is. Assuming you've all updated to iOS7.0.1. What you probably have done (which I also did) was setting restrictions in settings so password is required every time a purchase is made instead of the default 15mins. You'll need to leave that setting as it is which is the 15mins then it should work. Cause if you choose to use you fingerprint for all itunes/App Store purchases then it'll ask you to scan every single time anyway ignoring the 15mins rule. Hope this helps.

  • vinny1575 Level 1 (0 points)

    So that works, but for some reason it cannot be changed when you have age limits on for the App Store. I put age limits down since my kids use my phone a lot.

  • Alive_84 Level 1 (0 points)

    Vinny your right. Setting restrictions shouldn't stop it from working. There're bugs to be fixed.

  • officer_m168 Level 1 (0 points)

    Getting the same issue here as well. Works on opening the phone but for buying apps it doesn't.

    Have tried turning the touch id off and resetting it.

    Have tried a full re install of the phone as a new phone.

    I've even been to the apple store and they are stumped.

  • dchint Level 1 (0 points)

    Ive had same problem even after 7.0.1 update.  I think it has to do with turning off restrictions.

  • aldrums Level 1 (0 points)

    I am having the same problem with the app store and itunes continually asking for my password even though touch ID is enabled.  I've tried closing all the apps and restarting and it still doesn't work.

  • JakubFedyczak Level 1 (0 points)

    Same here. Unlocking the phone works fine, but during purchase I'm being asked for password as usual.

  • kb4200 Level 2 (235 points)

    It's not a bug it was meant to be that way, either use it with the setting as 15 minutes or don't use it that's your option.

  • officer_m168 Level 1 (0 points)

    Hi i never updated my experience with the genius & applcare.

    Well one issue we found was that my card that i use for itunes was out of date and i had not updated the card details. Now it seems that unfortunaly if you have not used the app store for a while then you will need to always add your password.

    Try putting in the password then going to another app and installing that. It then should ask for your print.

    Also you have to have the Require Password selected to 15 mins in restrictions.

  • stuart-from-clowdy.com Level 1 (0 points)

    I was having this issue too, it was always asking for the passcode even though the setting was on for iTunes & App Store. To fix it I turned it off and then back on again, it asked for my password and then it worked.

     

    Steps:

    - Go to Settings -> General -> Touch ID & Passcode -> Touch ID

    - Disable iTunes & App Store

    - Re-enable iTunes & App Store

    - Enter your passcode one last time

    - It should work

     

    Also as others mentioned, under General -> Restrictions -> Require Password might need to be set to 15 minutes.

  • Matt-UK Level 1 (0 points)

    It doesn't work though.

     

    On my phone once you enable touch for unlocking the phone, the password required changes to immediately and there are no other options to be selected, so its not possible to set it.

  • Matt-UK Level 1 (0 points)

    Spent a long time on the phone with Apple this morning, and they confirmed to me that there is an issue with 7.03 relating to this.

     

    In my case, the issue arose because I restored a configuration from iPhone 5 onto the iPhone 5S.  The touch / purchasing was working fine when setup as a new iPhone, but as soon as I restored on top, then it stopped working, and all the restriction settings were screwed up and you couldn't change them.

     

    The fix, was to restore the iPhone and set it up as a new iPhone (which in my case isn't possible due to some of the applicatons I have installed and the additional configuration they need) but hopefully there will be a fix coming in 7.04?

Previous 1 2 Next