1 2 3 Previous Next 41 Replies Latest reply: May 21, 2014 3:35 PM by rickfromwoodbury
thingo Level 1 Level 1 (5 points)

Hi,

I have a problem connecting my iPhone 4S to the ad-hoc wifi connection my macbook creates when "sharing" the ethernet internet connection through wifi, with iOS6 it worked flawlessy. I have no problems connecting in wifi to my router though.

 

Anyone experienced that? Could you try?

 

Thank you


iPhone 4S, iOS 7
  • 1. Re: ios7 can't connect to wifi ad-hoc network
    HamidKniber Level 1 Level 1 (0 points)

    hi

    me too i have same thing on my iphone 4 ios 7

    pls any one help for that

    thank you

  • 2. Re: ios7 can't connect to wifi ad-hoc network
    tulrich2 Level 1 Level 1 (0 points)

    I've been having the same problem. I had created an ad-hoc network on my work iMac so that I could use my iPad 2 as a second monitor via Air Display, but since installing iOS 7 on the iPad I haven't been able to make a connection. The iPad keeps saying that my password for the ad-hoc network is incorrect, even if I set the network up without one.

  • 3. Re: ios7 can't connect to wifi ad-hoc network
    sherifelabd Level 1 Level 1 (0 points)

    I have the same problem with iOS 7 and 7.02 on both iPhone 4S and iPad 3, moreover connecting through the cellular data is becoming also very annoying. Everything was working flawlessly with iOS 6.

    I tried everything I can think of deleting network, soft/hard restart and restoring nothing worked.  On the other hand my notebook connects to the same wifi easily, so it's not the wifi problem it's the iOS 7.

     

    Apple please help

  • 4. Re: ios7 can't connect to wifi ad-hoc network
    thingo Level 1 Level 1 (5 points)

    So I'm not the only one having this, and it's not an hardware problem. It's most possibly a bug.

     

    But it's strange that only us, with older, non ios7's airdrop compatible devices, are having this issue. I hope there is nothing in ios7 preventing this to work, that used to work with ios6.

  • 5. Re: ios7 can't connect to wifi ad-hoc network
    Alias7 Level 1 Level 1 (0 points)

    Same problem here. In WiFi settings, the ad hoc network shows up in "Devices." In ios 6 it appeard in "Choose a network." When I click on the network name to select it, a warning pops up saying: "NetworkName is Not Connected to the Internet. Are you sure you want to use this network?" and it gives me the options of Cancel, and Join Anyways.

     

    My Macbook Pro can join the network, but the network shows up in Devices as well oddly. Hopefully joining ad hoc networks will keep working when Mavericks comes out!!!

  • 6. Re: ios7 can't connect to wifi ad-hoc network
    tulrich2 Level 1 Level 1 (0 points)

    For what it's worth, I contacted the support team at Avatron (the developer of Air Display) and asked whether they had any workarounds. Here's what they came up with:

     

    Thanks for contacting us at Avatron support about the issues that you've been seeing when connecting via an ad hoc network. I was unaware of this problem but after doing some testing this morning it seems to happen with one of our iOS 7 iPad 2s as well.

     

    While this definitely seems like something that Apple needs to address, I was able to get Air Display working over the ad-hoc network if I disabled internet sharing from the Mac System Preferences > Sharing pane. Obviously the drawback of this is that the iPad will no longer be connected to the internet when you are using Air Display in this manner.

     

    Please let me know if this is able to serve as a temporary workaround while Apple investigates the problem.

     

    Cheers,

    Aaron
    Technical Support
    Avatron Software, Inc.

     

    Clearly this is not a full fix as I can't access the internet when connected to my ad-hoc network, but at least I got Air Display running.

     

    Their reply also suggests that this isn't a blanket issue covering all devices running iOS7, as only "one of [their] iOS 7 iPad 2s" was having the same problem.

  • 7. Re: ios7 can't connect to wifi ad-hoc network
    Disgraceland Level 1 Level 1 (0 points)

    +1 on this. Drivimg me mad!!!

  • 8. Re: ios7 can't connect to wifi ad-hoc network
    thingo Level 1 Level 1 (5 points)

    Hi guys,

    with Mavericks and iOS 7.0.3 the problem is solved, now everything works.

     

    I don't know if it depends on mavericks or the 7.0.3 though..

  • 9. Re: ios7 can't connect to wifi ad-hoc network
    DSJon Level 1 Level 1 (0 points)

    Having the same type of issue.....ad hoc network for iPad to print to wireless printer (no home network).  Worked flawlessly in iOS 6, but since upgrade, I can connect, I can web to the printer, will system will not 'find' any airprinters.  I've reset the network on the iPad, reset the configuration on the printer, upgraded to 7.0.3....still no luck.  If there isn't a fix, is there a way to go back to 6?

  • 10. Re: ios7 can't connect to wifi ad-hoc network
    Disgraceland Level 1 Level 1 (0 points)

    I'm not sure that they did address it in that build. I looked at the release notes and could not find anything relating to this issue, unless I am missing something?

  • 11. Re: ios7 can't connect to wifi ad-hoc network
    Disgraceland Level 1 Level 1 (0 points)

    What is interesting in all this is that it does seem to depend on what application you are using.

     

    e.g.

     

    I connect using Lemur and can make an ad hoc connection without any issues at all. All I do is create the network, connect the ipad to it and start lemur - everything works perfectly.

     

    However if I wanted to connect an ad hoc connection to the Arturia iMini - fails immediately. Same with apps such as Touchable.

  • 12. Re: ios7 can't connect to wifi ad-hoc network
    AmishCake Level 5 Level 5 (6,605 points)

    Has anyone here tried rebooting both the computer and/or phone?

  • 13. Re: ios7 can't connect to wifi ad-hoc network
    tulrich2 Level 1 Level 1 (0 points)

    I certainly have many times over many days.

     

    BTW, the Avatron semi-workaround that I posted last month stopped working.

  • 14. Re: ios7 can't connect to wifi ad-hoc network
    Disgraceland Level 1 Level 1 (0 points)

    Re-booting isn't the issue here, I'm afraid.

     

    I am sure that this linked to the IOS7 upgrade as it worked fine before, then didn't after.

     

    Personally, I shut down every day and have re-built the iPad since the issue first manifested itself to no avail.

     

    I can also create one using my iPhone  which indicates that it's iPad specific as well

1 2 3 Previous Next