Previous 1 2 3 4 5 Next 73 Replies Latest reply: May 18, 2015 12:08 PM by Calculus_Entropy Go to original post
  • Benxine Level 1 Level 1 (0 points)

    Hi Andy,

    Did you make sure to EMPTY YOUR TRASH before you restsrted your computer?

  • IMRAN Level 2 Level 2 (475 points)

    Count me in with this group of people suffering from flaky behavior of iTunes despite latest greatest updates on everything.

     

    In my case, brand new MacBook Pro Haswell retina 16GB 1TB SSD. It will sync an iPhone but after that has been ejected and an iPad connected will refuse to see the iPad 3.

     

    The iPad will flicker screen and the power charging icon will flick constantly between charging and not charging while iTunes will keep shoving the error on screen saying:

     

    iTunes could not connect to this iPhone. This device is no longer connected.

     

    Then it will say an iPad was detected but could not be recognized. I quit iTunes and rebooted the iPad but the same problem happened. Ironically, I unplugged the iPad from the left USB port and plugged it into the right USB port and iTunes synced it just fine.

     

    Until next time of course.....

  • andyindian Level 1 Level 1 (0 points)

    Hello Benxine,

    thank you. I searched in the wrong folder, in the software library. After finding the harddrive library, the solution was there in a few minutes. I didn't know about the second folder an the harddrive. I phoned with the apple hotline nearly 6 times. My operator wanted to give up on the 6. call. At the end of the call he said, please wait a moment, I will talk to a college. After 2 minutes he said we have it, go to the library folder in the hard drive and follow YOUR instructions!!!!!

    Now my mac is perfect again and a few day's ago I loaded mavericks.

    Thank you again.

    Greetings from germany, Andy

  • rodeman Level 1 Level 1 (0 points)

    Unfortunately I do not have a file called com.ghughes.wifisync.root.plist.  I have many other ones, some from Adobe, some from Microsoft, MacPaw (which is a the manufacturer of some software I own) but nothing from ghughes.

     

    Plus, if you search in the finder, it doesn't show you these so I can't type part of the name to have the computer look for it.  I guess it doesn't index this stuff???

     

    Anything else that can be done?

  • Benxine Level 1 Level 1 (0 points)

    Dear Rodeman,

    I'm not sure what your original problem is but it doesn't sound like the same problem we have all been having here.  Is there error message you are receiving say "could not allocate a resource"?  If not, perhaps you can find your solution in another thread.

    -B

  • Praveensharma Level 1 Level 1 (0 points)

    Thanks Benxine for your clear instructions (but am somewhat amazed that no one at Apple knows about this issue or has even tried to address this issue - unless of course you are working at Apple!!).

     

    Anyway I am grateful to you for sharing your knowledge and expertise with the community.

     

  • Benxine Level 1 Level 1 (0 points)

    Thanks for your note Praveensharma,

    No, I don't work for Apple, but if Apple is listening, I wouldn't mind 

  • hemalkpatel Level 1 Level 1 (0 points)

    Thanks Benxine....

     

    Your instructions worked perfect -- I was able to get rid of that annoying wi-fi sync which I could not get rid of for years and now itunes on my macbookpro can recognize and connect to my ipad/iphone with and without cables.

     

    U rock....

     

    Thanks again.

     

    Hemal.

  • hemalkpatel Level 1 Level 1 (0 points)

    Perfect solution.

     

    Thanks

  • Lien Nghiem Level 1 Level 1 (0 points)

    Hi everyone,

     

    I have tried all steps that Benxine suggested, but everytime I empty trash and restart the computer, all the deleted folders are still there. Is there anyone experiencing the same problem as me. Please advice. Thank you:)

     

    Lien

  • Benxine Level 1 Level 1 (0 points)

    Dear Lien,

    I know how frustrating it is when you see that everyone else has found a solution that works, but it doesn't seem to work for you.  Please try the following:

    1) make absolutely sure you have the same problem that everyone else is describing.  This only works for this very specific problem.

    2) you MUST MUST MUST find the folders from the LIBRARY folder that is directly under your HARD DRIVE icon.  Sometimes there are many different Library folders in many different places.  Make sure the folders that you are sending to the trash are from the LIBRARY folders directly under your hard drive.

    3) Is it possible that you are restarting your computer without actually EMPTYING your trash?  Please let me know if any of these work for you.

    Best of luck,

    B

  • Lien Nghiem Level 1 Level 1 (0 points)

    Dear Benxine,

    Yes it works now, and without empty trash.

    Thank you so much. Thank for ur CAPITAL MUST, that was my problem didnt look for the folder under the hard drive. Plus it required password to delete those folders.

     

    Cheers,

    Lien

  • coreynr Level 1 Level 1 (0 points)

    I have this same issue as Rodeman. the file "com.ghughes.wifisync.root.plist" does not exist on my computer, but I have the same issue as everyone else on this thread. I have Wi-Fi Sync on my computer, and I can't get it off. Any idea why? Any other thoughts on what I can do to fix this? I've been trying to get this off of my computer for years now

  • Calculus_Entropy Level 1 Level 1 (0 points)

    With all due respect to Benxine, I found that nothing described helped to solve my issue. I tried the following and have documented it here in order to potentially help some others.


    BOTTOM LINE: I had to reinstall the OS to solve the issue

     

    Original issue described below:

    I cannot connect my iPad to iTunes and receive the error "iTunes cannot connect to this iPad. Could not allocate a resource".  Same for my iPhone but the error reads "iTunes cannot connect to this iPhone. Could not allocate a resource". It shows the triangle caution sign with an exclamation mark and the iTunes logo with the error message.

     

    The basics:

    iPad is running iOS 7.1.2 and iPhone is running iOS 8.3 (each has own iTunes library)

    Mac is running OS 10.9.5

    iTunes is version 12.1.2.27 

     

     

    • Tried different cables. Issue still exists

     

    • Rebooted Mac as well as both iPhone and iPad.  Issue still exists

     

    • Added the “lockdown” folder as it was missing. The file /var/db/lockdown is empty except system configuration folder. Issue still exits. Please see note below ***

     

    • Started in safe mode and have the same issue.

     

    • Download and reinstalled iTunes (12.1.2). Issue still exists.

     

    • Deauthorized/reauthorized computer. Issue still exits.

     

    • Backed up iPad to iCloud and reset the iPad to factory settings. Restored from iCloud backup. Issue still exists.

     

    • Created new iTunes library for iPad. Reset iPad to factory settings. Basically, made it a new iPad. Same issue.

     

    • Looked for file com.ghughes.wifisync.root.plist in Library>Launch Daemons but it was not there so could not throw it away. Same issue.

     

    • Looked for Wi-Fi Sync folder in Library>Application Support folder but it was not there so could not throw it away. Same issue.

     

    • When iPhoto opened (as it should when a device is attached either iPad or iPhone), it gave an error message “Photos on the device <name of device> cannot be imported because the device is locked with a passcode” “you must unlock device to import them” BUT THIS IS INCORRECT as the iPad has no lock or passcode.

     

    • The "trust computer" is hit on the device yet nothing changes.

     

    ***PLEASE NOTE that when looking at my other MAC computer that sinks other family devices fine (also running 10.9.5 and iTunes 12.1.2.27), there is no /var/db/lockdown file on that computer......

     

    Searched the internet and found so-called solutions but none of them worked. I do not understand why one cannot reset a device to factory settings and then start from scratch. It tells me that something is wrong with iTunes or the OS. I do not want to reinstall the OS but I fear that is the next step.


    Ultimately, reinstalling the OS solved the issue.


    Hope this helps those who did a google search and landed here first as I did.



Previous 1 2 3 4 5 Next