1 Reply Latest reply: Sep 22, 2013 12:33 AM by atomicgram
atomicgram Level 1 Level 1 (0 points)

Hello, My dad is using his iPhone 4S on ST (straight-talk) and he has a problem with his data, so he tried everything. His last resort was restoring the phone, so he did and he re-installed his APN settings using the iPhone configuration utility. His data works but with ST you can't send pictures to non-android users so my whole family uses iPhones, and since iMessage uses data he can send pictures to us. But for some reson it keeps telling him this:

 

photo 1.PNG

 

 

He pressed ok and it gave him an option to sign into his iCloud account but while he puts his password it takes him back to the main page. And when the error does not pop up it says "Waiting for activation":

 

photo.PNG

 

All we tried was to turn the phone off and on... but that did not work.. Any tips would be appreciated!! Thanks!


iPhone 4S, iOS 7
  • atomicgram Level 1 Level 1 (0 points)

    **UPDATE**

     

    I was looking through threds and I think I may have found a solution thanks to firey05

     

    I have been having the same problem since activating and have tried all the steps provided by everyone

     

    - Reset Network Settings

    - Erase All Content and Settings

    - Restore from backup

    - etc etc etc

     

    I was at the shopping centre today and popped into the Apple Store

     

    I was informed the following;

     

    "We are aware that there have been some issues with iMessage activation. Those on Optus and Vodafone are ok, it is mainly affecting those on Telstra"

     

    Apple also advised that if iMessage activates with your apple ID and not your phone number then this means that the APPLE SERVERS ARE WORKING FINE.

     

    The phone number is ONLY activated through your carrier and due to the demand it's SLOW

     

    Just wait it out, try an obsure time of day to activate like 3AM when most are sleeping

     

    DON'T BOTHER restoring, resetting etc etc.

     

    BE PATIENT!!!