Previous 1 2 3 4 Next 49 Replies Latest reply: Jul 19, 2014 12:56 PM by Bosoxrl Go to original post Branched to a new discussion.
  • RC@CCDA Level 1 Level 1 (0 points)

    That worked for all of about an hour on my 4s. Would anyone representing Apple like to chime in to offer a permanent fix or give us all an expectation that this bug is recognized and being worked on?

  • alancraigmackie Level 1 Level 1 (0 points)

    I too have been having this problem since moving to iOS 7 on my iPhone 4S.

     

    Siri reponds as if going to make the call, but then says she is sorry she can't. However, if I read out the numbers to dial, then the call is completed.

     

    I have tried the fixes suggested here and they work temporarily, but then I'm back to the future.

     

    Let me add my voice to the chorus requesting Apple fix this bug a.s.a.p.

  • RDustinB Level 1 Level 1 (0 points)

    Thanks Plasmo, this seemed to work for me after my previous workaround of "turn off contacts, then back on" no longer had any effect. I also deleted all my relationships prior to re enabling Siri, so maybe that helped clean things up as well. :)

  • schro3f Level 1 Level 1 (0 points)

    I tried it couple times on my 4s, for me this doesnt help.

     

    Did you mean deleting all your contacts by "deleting your relationsships prior". This will be hard to do cause i synced it with google contacts    

  • RDustinB Level 1 Level 1 (0 points)

    Hey schro3f, no by "deleting my relationships" I mean editing *my* personal contact card in my contacts. Siri learns who your brother, mother, spouse etc are and I deleted those fields out of my contact card.. Then I turned off contacts and Siri, and when I turned off contacts that is when my iPhone asked if I wanted to keep the contacts on my phone or delete them. Since I have them all in iCloud I chose to delete them.

     

    For your situation it'll be a bit different, you may have to turn off contacts in your Gmail account under Settings -> Mail, Csontacts, Calendars and then turn Siri off, reboot the phone then turn them back on. The iPhone May not ask you if you want to keep all your contacts on your phone and  I'd be careful of this, making a backup of your contacts first off of Googles servers, as I'm not sure how the syncing will work if you have to manually delete all  contacts off your  before turning off Siri and rebooting.

     

    Does that make sense? Respond if you have questions or need help, I don't want you to loose your contacts trying to fix this!!!! :)

  • RC@CCDA Level 1 Level 1 (0 points)

    I uploaded the new ios7 update for my iphone and mini last night and that seems [so far] to have fixed this bug. would be interested to know if others have the same result. My siri is now as responsive as it was before the initial 7 update and works well via bluetooth as well.

    ,r

  • schro3f Level 1 Level 1 (0 points)

    Hi man, i tried this trick by turning off google contacts and turn off siri. Than turning of iphone and enabling siri. Still nothing

  • Ciddy14 Level 1 Level 1 (0 points)

    Many of you had the issue recur, which in the end happened with me too.

     

    My solution only worked for a few days.

     

    I went to the Apple store and received a new Iphone (refurbished), that eventually solved (or should I say avoided) the problem.

     

    Issue occurred on my old phone with IOS7, no clear reason why. Phone was reset, reinstalled and in the end only my temporary solution worked (for a bit)

  • PapaSeth Level 1 Level 1 (0 points)

    This solution worked for me, at least for now.  I'll report back of changes. 

  • FriskyinMN Level 1 Level 1 (10 points)

    Curiously - I ran into this issue this morning - Siri won't call my wife's number like it always has!  It either returns the "uh oh" statement, or a "Sorry, (my name), but I cannot make the phone call" message.  Disabling  Siri, rebooting the phone and reenabling Siri seems to have fixed the issue for now.  But boy this was/is annoying.  keeping my fingers crossed hoping it won't re occur.

  • AppsandOranges Level 1 Level 1 (0 points)

    This worked for me.

     

    Settings > General > Siri > My Info

     

    Select yourself from your contacts.

     

    Turn Siri on and off.

     

    Voice dial.

  • 7201969 Level 1 Level 1 (0 points)

    I found that if I list a phone number as "iPhone" in contacts, Siri will not be able to dial that number.

     

    When I changed the number back to "mobile" Siri had no problems dialing. Looks like it may be a bug.

     

    Hope this helps.

  • texasgatitomama Level 1 Level 1 (0 points)

    This worked really well on my new iPhone 5C with IOS 7. Thanks for the tip!

  • jl-atl Level 1 Level 1 (0 points)

    I have the same problem.  When asking Siri to dial by name (contact) it will say "calling ....." then respond with the dreded "Uh oh, I can call ....".  Starts doing this randomly.

     

    At first I tried the reboot process and it worked for a while, not even that does not work.  Last night had the problem, tried rebooting multiple times but no luck.

     

    Then this morning it is working again.

     

    Apple - are you listening?  Are you working on a fix for this bug?

  • FriskyinMN Level 1 Level 1 (10 points)

    After a couple weeks, the problem came back - Siri won't dial my wife's number.  ANNOYING!

    The steps below worked for me, but surely, it will not be long before Siri/voice dialing acts up again!  APPLE, ARE YOU LISTENING!?!? 

     

    Settings > General > Siri > My Info

     

    Select yourself from your contacts.

     

    Turn Siri on and off.