14 Replies Latest reply: Aug 1, 2014 5:45 AM by James Dylan Branched to a new discussion.
jjkraw Level 1 Level 1 (40 points)

I am downloading all of my podcasts to my iPhone 4 (iOS7) through iTunes on my iMac. Before iOS7, I did this and listened to them in the Music app - it was all really straightforward. iOS7 forces me to use the Podcast app. I'm still not sure if I'd doing the sync/download from iTunes correctly as sometimes the episodes appear on the phone and sometimes they don't (and I'm the one who usually figures these things out and tells my other family members how to do it), but that's a whole different story.

 

Because I do not want any podcasts automatically downloaded to the phone, especially over Verizon's network, I turned off Settings -> Podcasts -> Use Cellular Data. I have also turned off Sync Subscriptions.

 

Whenever I am not on a WiFi network and I unlock my phone while it is in the Podcast app, I get a popup that says:

 

Cellular Data is Turned Off for "Podcasts"

 

You can turn on cellular data for this app in Settings.

 

And I have to "OK" it to make it disappear. It is getting annoying. I know cellular data is off. I did it on purpose.

 

My goal is to get rid of the popup but I've had no luck yet after tweaking a few settings. I don't know exactly what Sync Subscriptions does, but one educated guess is that as long as I have that off, no podcasts will be downloaded to the phone unless I do so via iTunes on my iMac. Is that correct, and would that allow me to turn on Use Cellular Data (to get rid of the popup)?

 

Any other ideas about this?

 

And if someone can explain all of the different permutations of how to manage Podcasts between iTunes and an iDevice (or even when a computer isn't in the picture), I'm all ears.


iPhone 4, iOS 6.1.3
  • Nestofc Level 1 Level 1 (0 points)

    This is driving me nuts! Has anyone found out how to disable the pop up notification. I'm with jjkraw, I know it's off! I specifically turned it off!!

  • PDub52 Level 1 Level 1 (0 points)

    Try going to Settings/Cellular and turn ON Cellular Data for Podcasts.  Now, go to Settings/Podcasts and turn OFF Use Cellular Data within the app.  So far it's working for me

  • jjkraw Level 1 Level 1 (40 points)
    Try going to Settings/Cellular and turn ON Cellular Data for Podcasts.  Now, go to Settings/Podcasts and turn OFF Use Cellular Data within the app.  So far it's working for me

     

    OK, I just did that, but I got the little "wheel" communication indicator while in 3G mode when I opened Podcasts, so it looks like there is some sort of communication happening.  Maybe I'll leave it like this and keep a close eye on my data usage.

  • Nestofc Level 1 Level 1 (0 points)

    Seems to have done the trick. I actually started downloading two podcasts while I had both switches ON. When I turned cellular OFF in Settings/Podcasts, I can see in the app thay the downloading stopped. So I think this solves it. Thanks PDub!

  • PDub52 Level 1 Level 1 (0 points)

    You're welcome.  I was searching for a fix for this online, but couldn't find one.  When I figured it out I couldn't leave others hanging.  Speaking of Podcasts and iPhones.... There is a podcast on the TWiT network called "iFive for the iPhone".  Quick and dirty review of apps and iPhone tricks.

     

    Also, under Setting/Cellular is the amount of cellular data used for each app.  I too new to iOS 7 to know if its a lifetime accumulation of cellular data for each app, an automatic reset on a time period or a manual reset.  I haven't been able to find a specific reset, or information on what, if anything, resets it.

  • 59Strat59 Level 1 Level 1 (0 points)

    thanks for the answer. i'm trying this. it has been driving me crazy too. also i think the data size under apps in settings is the size of the app. not sure.

  • BryanAyala Level 1 Level 1 (0 points)

    I may be late but today I seem to have found a solution! What I did was go into settings then notification center and for all apps that I turned cellular data off for, I also completely took off all form of notifications! I even got to change the fact that notifications for those certain apps appeared on my lock screen and the pull down notification center!

  • fxitwill Level 1 Level 1 (5 points)

    I hope the people at Apple can reincorporate some of the "Jobs" era, where customer/user experience was paramount, or at least in the top echelon. I believe it’s currently a "back seat" consideration. The irritating message that “Cellular Data Is Turned Off For %Appname%”, discussed here in this Apple.com discussions public forum, and Apples refusal to change it, is case in point. This “feature” may be performing as Apple and the cellular carriers designed it too, but it is not what consumers want. In fact, this “Feature” lacks the ability to perform as the consumer asked. If the user SPECIFICALLY takes the time & trouble to learn where the settings are to limit data consumption & control cost, they should not be constantly bombarded by an annoying message regarding a situation they are already financially & painfully aware of, and went so far as to manually turn data use off. Take a moment to recall the Apple ads where the annoyance of the User Account Control feature included in Windows Vista sold many Macs. I guess the tables have turned. So, here are my questions; Are Apple & the wireless carriers colluding to cause users to consume more data? Is there some contract the carriers have over Apple that prohibits this message from being permanently disabled?  If the answer is truly “NO” on both counts then there is a simple solution I would like to suggest. Simply include a checkbox in the setting for each app that cellular data has been turned off for, that instructs iOS to “Do Not Warn That Cellular Data Is Turned Off For %Appname%”, or maybe a “global” setting for all apps, that instructs iOS to “Do Not Warn That Cellular Data Is Turned Off”.  So, I would like to challenge EVERYBODY at Apple to stand up and have the guts to fix this super extremely annoying & downright dangerous alert message. PLEASE give us the ability to permanently dismiss this alert message.

  • fxitwill Level 1 Level 1 (5 points)

    I hope the people at Apple can reincorporate some of the "Jobs" era, where customer/user experience was paramount, or at least in the top echelon. I believe it’s currently a "back seat" consideration. The irritating message that “Cellular Data Is Turned Off For %Appname%”, discussed here in this Apple.com discussions public forum, and Apples refusal to change it, is case in point. This “feature” may be performing as Apple and the cellular carriers designed it too, but it is not what consumers want. In fact, this “Feature” lacks the ability to perform as the consumer asked. If the user SPECIFICALLY takes the time & trouble to learn where the settings are to limit data consumption & control cost, they should not be constantly bombarded by an annoying message regarding a situation they are already financially & painfully aware of, and went so far as to manually turn data use off. Take a moment to recall the Apple ads where the annoyance of the User Account Control feature included in Windows Vista sold many Macs. I guess the tables have turned. So, here are my questions; Are Apple & the wireless carriers colluding to cause users to consume more data? Is there some contract the carriers have over Apple that prohibits this message from being permanently disabled?  If the answer is truly “NO” on both counts then there is a simple solution I would like to suggest. Simply include a checkbox in the setting for each app that cellular data has been turned off for, that instructs iOS to “Do Not Warn That Cellular Data Is Turned Off For %Appname%”, or maybe a “global” setting for all apps, that instructs iOS to “Do Not Warn That Cellular Data Is Turned Off”.  So, I would like to challenge EVERYBODY at Apple to stand up and have the guts to fix this super extremely annoying & downright dangerous alert message. PLEASE give us the ability to permanently dismiss this alert message.

  • Dundle Level 1 Level 1 (0 points)

    I tried the suggestion:

     

    "Try going to Settings/Cellular and turn ON Cellular Data for Podcasts.  Now, go to Settings/Podcasts and turn OFF Use Cellular Data within the app.  So far it's working for me"


    to no avail...

  • Andrew E Level 1 Level 1 (25 points)

    None of the tips suggested above worked for me. I still had that infernal message about connecting to the internet. But I have apparently (crossing my fingers) found a solution which works for me.

     

    In the good old days I had iOS6 on my iPhone 5 with iTunes 10. I created a Podcast playlist in iTunes and I could cheerfully listen to it on the Music app driving around Europe (I'm on a UK tariff) with no 3G or wifi.

     

    I now use iOS7 on my iPhone 5, syncing with iTunes 11 on Mavericks. I can now listen to the same Podcast Playlist with the Podcast app, wifi and Cellular Data turned off, Cellular Data and Notifications turned on everywhere and not a trace of the warning message. All the Podcasts play in sequence with no problem. Victory?!

     

    The problem turned out to be in the syncing with iTunes. Although the Podcasts, whether in the Playlist or not, appeared to be syncing, in fact they were not imported fully into the phone. Thus when I selected a Podcast to play, the full file wasn't actually on the phone and so it wanted to stream it.

    My solution was achieved by doing the following.

    1. Create Podcast playlist in iTunes and drag some podcasts into it.

    2. Wiith phone connected to iTunes device, highlight the iPhone in the left hand column and swivel the little arrow to expand the list of contents. You can then check the actual contents of each section on the phone. Music, Movies, TV Shows, Podcasts etc.

    3. Hit iPhone in left hand column. Hit Podcasts tab at top of window. Uncheck everything in and out of sight and Apply/Sync to remove all Podcasts from phone.

    4. Hit Podcasts section of expanded iPhone contents list in left hand column. That should be empty. Similarly there should be no sign of the Podcast playlist below it.

    5. Now return to the Podcasts syncing section. Check 'Sync Podcasts'.

    6. Scroll to bottom of page to 'Include Episodes from Playlists' and check the Podcast playlist you created. Apply/Sync.

    7. Now check that the Podcasts in the playlist are in the phone by hitting the Podcast label in the expanded contents list. It should match the contents of the Playlist which should also have appeared in the list of playlists in the phone.

    8. With WiFi and Cellular Data turned off, go to Podcast app and, if you're as lucky as me, you should be able to play any of the Podcasts in the playlist without that infernal message being displayed. Displaying 1 or 2 fingers at your mobile provider is optional!

  • DLR Level 3 Level 3 (680 points)

    I am on an iPhone 5s with iOS7.1

     

    I have the same problem but with the reverse desire. I want podcasts to download with cellular data when I leave the house and I do not want the annoying alert. I could not figure out why it kept asking me to temorarily turn on cellular data for Podcasts when I had already turned in on in Settings > Cellular > "USE CELLULAR DATA FOR:"

     

    The problem seemed to be that the setting was not sticking or just not registering. So I thought about it and decided to look in the Podcast settings in Settings > Podcasts. Well low and behold, it was off. I then went back to the other settings and it was on. So it looks like we have competing toggle switches that do not sync. I turned them both on and voila!

     

    I hope this helps you for whichever way you want to use the switch.

  • jjkraw Level 1 Level 1 (40 points)

    I started seeing this again with iOS 7.1.  I found that Setting->Podcasts->Refresh Podcasts was set to "Every 6 hours". I changed this to "Manually" and that seems to get rid of the pop-up (for now).

     

    I'm also seeing this message with Music in 7.1. I haven't quite nailed down why or what might make that one go away. More later if I figure that out.

  • James Dylan Level 1 Level 1 (5 points)

    I sent this message to apple:

     

    Can you guys PLEASE stop with these annoying little pop-up that appear everytime I open an app that say "Cellular Data is Turned Off for "xxxxx". I have an iPhone 5S, and I use a "pay as you use" plan, so I have my data off for most apps, usually only use it for iMessage. So now, every time I open an app or a game, I get that stupid annoying message! Yes, I know I have "Data turned off"! I don't need to be reminded of it 50 times a day! Is this because the phone companies or app designers made Apple put that in, so we consumers use more data? Regardless, I am getting very tired of it and hope you fix this, ie. give us the option to turn it off.