Previous 1 7 8 9 10 11 Next 255 Replies Latest reply: Apr 11, 2015 9:07 PM by umsanpra Go to original post Branched to a new discussion.
  • Sunnshyne12 Level 1 (0 points)

    Hey Everyone,


    I have found a solution that worked on my iPhone 4S. I have had wifi working continuously for a week now. I can come and go from my house and it connects right back up every time. Before it wouldn't detect or was greyed out and couldn't even turn wifi on.


    So this is what I did.

    1st - I did the heating your phone trick, except I didn't use a blow dryer. I placed it under a lamp that gets super hot for about ten mins. Until my screen said "iphone to hot has to cool before use".

    I then waited tell it cooled off tried the wifi and no luck.

    2nd - put my phone in airplane mode did a hard reset

    3rd - still in airplane mode took my SIM card out and did another hard reset

    4th - with SIM card still out turn airplane mode off, once again I did another hard reset. This time as the apple sign came on I never let go of the home button, the phone just flashed the apple button for awhile I think I held it for 30-45secs.

    5th - I then let it boot all the way up, I left the SIM card out and tried my wifi it connected no problem. I then put my SIM card back in and haven't had a problem since.


    Since I've done this I have had to reboot my router for computer purposes and my iphone never had issues connecting again. It comes on and off as it should.


    Hope other people have success with this. So Glad I have save myself $199 on buying a new phone.

    Good luck everyone!

  • dwayner Level 1 (0 points)

    Same here.  Wifi  greyed out problem.   Tried several solutions and no  fix.  Its intermittent so difficult to know what works and what does not.  Sometimes turning if off for a couple minutes then turning on and it works.   But after a few minutes of wifi it goes back to 3g.      

    Very annoying.  


    This is the second iphone 4s with the problem.     This one is a month old.     I will take back and try one more.


    My older one worked good for 2 years before wifi problems.     The second one a couple weeks. 


    You cant make millions of gadgets without having some duds.    They have acceptable  failure rates.    How they treat people with failed devices is what matters. 


    Will have to get new phone.   See how what they will do for me. 

  • zenzen1812 Level 1 (0 points)

    My ex has been complaining for some time now that his wifi and Bluetooth haven't worked since the iOS 7 update. Stupidly, I didn't really believe the two were related, so I updated my 4s from iOS 6 to iOS 7 last night. OMG big mistake!!!! (for so many reasons, but this is the by far the most serious) IMMEDIATELY my wifi stopped working. You cannot tell me that this is some kind of coincidence, especially since so many people are having the identical issue. I am now going to go through everyone's helpful suggestions above, and try every one of them. Hopefully one works as this is kind of a panic situation for me. Wish me luck.

  • sasygrl31 Level 1 (0 points)

    Ok, so I tried putting my phone in the freezer.......with hesitation....and holy moly, it actually worked.  (for now). I really thought everyone was full of it when I read the suggestions. 

    But seriously, why should apple customers have to resort to such nonsense to fix something that should be addressed anyways?? 

    Oh, and someone mentioned their phone getting very hot when wi-fi died.........yes, that happend to me.

  • I really dislike Itunes Level 1 (0 points)

    I tried all that you reccommended. The last thing I tried was turning on airplane and do not disturb mode then pwering down the device. When I turned it back on the screen is flashing non stop for whatever reason. This is a brand new problem and I still can't turn my wifi on, (it's grayed out), and my bluetooth is inaccsesible as well, (the pinwheel is turning and I cant turn it on or off). Please help!

  • joebrice Level 1 (0 points)

    I'll add my name to the long list of people who can't access wifi.  I refuse to accept a technical Apple issue should be resolved via the freezer.


    Does anyone from Apple ever bother to grace this forum?  It seems to me that they owe us a note on how to solve it.  If they don't have the answer then at least give some idea as to when a solution will be forthcoming.........

  • JoeBlow2444 Level 1 (10 points)

    Does anyone from Apple ever bother to grace this forum?



    It seems to me that they owe us a note on how to solve it.

  • manny46064 Level 1 (0 points)

    Crazy as it sounded, i gave this a try too.  Put in fridge for half hour, reset network settings and my networks came back.  Renewed the lease just to be sure, also.  So far, its good.  Had to be careful about moisture bringing phone back into the warm room.  Oh well, its the wife's phone, so spending time on this kept me from doing real work around the house.

  • kblackw Level 1 (0 points)

    Made the big mistake of upgrading to IOS7 on the iPad tonight. WiFi now NOT working correctly. Sometimes no connection, sometimes connected briefly (several minutes).


    Finally read all the posts to this thread. What worked for me is :

    1. iPad Network Reset,
    2. Power cycling my cable modem and network router.
    3. Did NOT do any of the heat, cool, etc shenanigans.


    1. Now working correctly. Thanks Apple.
  • Lawrence Finch Level 7 (34,045 points)

    Step 2 is what actually fixed the problem, so you should be thanking your router manufacturer for their buggy firmware.

  • Sycamore Ken Level 1 (0 points)

    Thank you for posting a solution to this APPLE issue. My phone stopped connecting with my router yesterday after working fine. Since none of our other wifi related items had issues I have to lay the blame witht he phone not the router.


    Again, thank you.

  • Lawrence Finch Level 7 (34,045 points)

    This is a ROUTER issue. Many consumer routers (particularly Linksys and Netgear) have a bug where the DHCP server that assigns IP addresses to new devices and devices whose lease has expired crashes after several weeks of continuous running. Devices that already have an IP address are not affected, but new devices, like your phone, request an IP address but don't get one. So they connect for about 30 seconds waiting, then disconnect. The test of this is to tap on the "i" to the right of the network name in the iPhone after it disconnects and look at the IP address. If it begins 169.254 this means that the ROUTER failed to assign an IP address within 30 seconds, so the phone made one up for ad hoc networking.


    The reason I emphasize this is that it is going to happen again, and not necessarily with the iPhone. And the solution will be to reboot the router.

  • Sycamore Ken Level 1 (0 points)

    I understand you are probably correct, your response to the previous poster just seemed like another off handed defense of the apple product with the blame being thrown once again on everything but apple's issues. Sorry to let my own issues which have not been resolved cloud how i took your response.

  • PAFISE Level 1 (0 points)

    This is not the issue I have been having and I am assuming it is true for most people in this thread. Our phones are not connecting to any wifi, at work, at home, or at the local coffee house. Everyone of us have had this issue start after updating. Our issue is not a router issue but a faulty component within the phone. If apple would to just except blame for this I would continue to buy apple products, but since they are not I am forced to go to another tech company.

  • jemunroe Level 1 (0 points)

    Well, after months of no wifi I finally got it going again.  I was taking pictures on my iphone and ran the battery dead.  That seems to happen very quickly sometimes with ios7.  Not having my charger, I waited an hour or so and tried turning the phone on again.  It came back to life and I noticed the bluetooth symbol in the upper-right corner.  That prompted me to check the wifi button (like I have a hundred times before), and believe it or not it was active and I was able to turn it on.  I then messed up my password on my home network, so to clear everything out I had the bright idea to "reset network settings."  Bad move.  Doing so killed the wifi again.  So....I then let the phone discharge once again, plugged it in, and the second it came back to life I was able to turn wifi back on again.  Phew!  It's been working for the last week or so.  I don't mess with it now...wifi and bluetooth will be on from now on because I'm afraid to touch them again.  hehe

Previous 1 7 8 9 10 11 Next