2 Replies Latest reply: Jul 23, 2014 10:42 AM by tmaag
lolbecx Level 1 (0 points)

Ever since updating to iOS7, my iMessage would not connect. I finally backed up my phone to my cmoputer and erased all the data on it. I then restored it and iMessage worked. Now I have the problem that its sending my messages only through my email. In the "iMessage -You can be reached by iMessage at" it shows my phone number and two emails. My emails at checked but it doesn't give me the option to check my number, it's simply greyed out. Someone please help. I never had trouble with this and it'd be annoying to texts all of my contacts through my email.


iPhone 5, iOS 7
  • linds146 Level 1 (0 points)

    go into send and receive in messages, turn off your Apple ID and then sign back in, it will ask you to choose an email, uncheck both emails and it will automatically go back to your phone number!

  • tmaag Level 1 (120 points)

    To get the number activated,

        The iMessage server sends a silent SMS message to the iPhone phone number.

              That can be blocked by your carrier.

    If that fails you might want to check with your carrier to make sure those type of message going through.