Previous 1 2 3 4 Next 47 Replies Latest reply: Jun 23, 2015 6:50 PM by mechelly
sok123 Level 1 Level 1 (0 points)



I seem to be having a strange issue using my Belkin Keyboard folio for my iPad mini since upgrading to iOS 7. For some reason, my backspace key has starting to work like a delete key (i.e. deleting characters after the cursor, not before) and will only work normally if I hit CTRL. I thought it was an issue with the keyboard that just arose; when I paired it with another iPad that hasn't been upgraded to iOS 7 it seems to be working normally. Has anybody had other strange issues with external keyboards and their iPads since upgrading? I've heard it could be an issue with Bluetooth and the new operating system. As I rely heavily on my keyboard for editing and writing, having a dysfunctional backspace key is fairly annoying.

iPad, iOS 7, Bluetooth keyboard issues
  • Grantfromsk Level 1 Level 1 (0 points)

    I have the exact same problem, have emailed Belkin, and have been searching the web for an answer. Have also tested my keyboard with my iPod which is still on OS6, and it works normally. So it's not the keyboard. I also use my keyboard heavily too and can't live with a two fingered delete.Need a fix ASAP.

  • GeekBoy.from.Illinois Level 4 Level 4 (2,805 points)

    I will guess that the problem you are experienccing is specific to Belkin, as I use the Apple wireless bluetooth keyboard with my iPad 2 (iOS 7) and I didn't have any change in the backspace key behavior.  Backspace still deletes the character before teh cursor, and if I want a "delete" function, I need to hit "Fn-Backspace" to get it to be the forward delete.  This was/is the same as on my wife's iPad 2 still running iOS 6.1.3.

  • sok123 Level 1 Level 1 (0 points)

    If you hear from Belkin let us know. I'm not sure if it is something they can resolve or whether Apple needs to update iOS 7 first.

  • Grantfromsk Level 1 Level 1 (0 points)

    Installed the iOS 7 update 7.0.2, but didn't solve the problem for me. Haven't heard back from Belkin. Suspect I won't as they want you to pay for support.

  • sok123 Level 1 Level 1 (0 points)

    Same with me RE: the update. I've read other forums where they say Belkin needs to provide a firmware update in order to fix this issue (apparently many others have had other ios 7 issues with Belkin keyboards). Personally I hope they do so soon.

  • GeekBoy.from.Illinois Level 4 Level 4 (2,805 points)

    One thing to check is if your Belkin keyboard has a switch for "iOS / Android".  Some 3rd party keyboards do have such a switch, and it is possible that they keyboard you are using has the switch set in the improper mode.  It might be worth a check.

  • sok123 Level 1 Level 1 (0 points)

    WIth my keyboard folio, unforutnately, I onlyhave the on/off and pairing buttons. Nothing else.

  • mprice1962 Level 1 Level 1 (0 points)

    This is not just a Belkin issue... The Zaggfolio (bluetooth) keyboard has lost some functionality as well... The search button, web button, and slideshow button have all stopped working with the iOS 7 upgrade

  • Grantfromsk Level 1 Level 1 (0 points)

    Similar to sok123, my keyboard did not have any switches for iOS/android, just the power on and pairing buttons. But thanks for the suggestion GeekBoy.from.Illinois, it was a good idea. Today I took my Belkin back to the store (Future Shop), tried a different Belkin in the store with the sales assistant and got the same result. Returned it and bought an Apple wireless keyboard instead. I know there may be an update in the coming weeks for the Belkin, but I couldn't wait - need it for classes and can't live without the backspace. I've tried for the last week through 16 hours of classes and 6 hours of group work. Also didn't trust that Belkin could/would do anything about it. Too bad, because I liked the little Belkin product. It was nicely designed. But so is the Apple keyboard, so I'm pleased to move on.

  • BC2010 Level 1 Level 1 (5 points)

    I am having an issue from the lock screen.  On iOS 6, if I entered my passcode, hitting the key for the last digit would trigger submission of the entered passcode for authentication.  Intermittently, on iOS 7, after entering the last digit the lock screen will just sit there with all four "dots" filled in, indicating I have indeed entered for numbers.  The screen does not shake to show invalid entry nor does it allow access to the lock screen.


    If I hit the backspace key and then touch the screen for the final digit on the on-screen keyboard, the iPad unlocks just fine.


    However, sometimes this works without a hitch.  I have yet to figure out the scenario that triggers the issue.  But it definitely started with my first attempt to login to the iPad via bluetooth keyboard on iOS 7.

  • electricidiot Level 1 Level 1 (0 points)

    This is not Belkin only, as earlier posters have said. I have a Zaggmate keyboard and I've seen most of the problems described here.

    The search button on the keyboard does nothing.

    The slideshow button does nothing.

    When typing in the passcode on the keyboard, all four dots will fill indicating that four numbers have been pressed, but it doesn't unlock the iPad and I have to delete the last digit and enter it on the screen.

    The up and down navigation arrows don't work while typing paragraphs of text but only in some programs. (yes in Pages, no in iMessages)

    And sometimes in Pages while I'm typing, if I start a second word, change my mind, and start to delete that word using the delete key, it will go past where I stop pressing the key and delete the space between the second and first words (so if I was typing the phrase "bluetooth keyboard" and I had gotten to "key" then decided to delete those three characters, three taps of the delete key would go all the way back to the h, not delete it, just the space between words. It is an odd little glitch and not something I am causing, not that often.

  • JenniferRT66 Level 1 Level 1 (0 points)

    Same problem here. I have an iPad mini with the Belkin bluetooth keyboard folio/case and my backspace key now functions like the delete key. I was going mad these past few days wondering what happened...I also updated to iOS7.

  • remark6 Level 1 Level 1 (0 points)

    I'm using a Belkin Ultimate Keyboard Case and it doesn't work at all after updating to IOS 7.

    The only function that is working is the virtual keyboard-switch.

    Thanks Apple

  • nrota999 Level 1 Level 1 (0 points)

    yep, I have the Logitech ultrathin bluetooth keyboard and when I delete an entire word character by character, it also deletes the space before the word. I'm a writer and this drives me crazy! Does that mean all bluetooth keyboards need an update or does apple have to change something on its end?

Previous 1 2 3 4 Next