Previous 1 2 3 4 Next 46 Replies Latest reply: Aug 20, 2014 7:20 PM by Diamondprarie Go to original post
  • Hallucinatory Level 1 Level 1 (0 points)

    Yes, same problem, the backspace becomes delete. My bluetooth keyboard is rocketfish. It also works perfectly on IOS6. And the upgrade doesn't help at all.

  • Hallucinatory Level 1 Level 1 (0 points)

    Upgrade to IOS 7.0.2 the backspace still becomes delete. I would rather have backspace forever than the stupid delete, if there is a way to downgrade to IOS 6, I would definitely do it.

  • samedens28 Level 1 Level 1 (0 points)

    Hi, I also have the bellkin bluetooth folio and my backspace doesn't work unless I hit ctrl backspace as well, it is quite annoying, hopefully a future ios 7 update will fix it

  • n1cky83 Level 1 Level 1 (0 points)

    I can't even get my bluetooth to pair with anything since getting IOS7 and I have tried resetting and reinstalling etc etc

  • remark6 Level 1 Level 1 (0 points)

    Reboot your Ipad. I did and my Belkin works again.

  • sok123 Level 1 Level 1 (0 points)

    I've tried rebooting. Doesn't fix the backspace issue. Still acting like delete.

  • Grantwillreply Level 1 Level 1 (0 points)

    Ssame issue. Belkin Ultimate Keyboard (tried 2 of them) randomly works. Brand new IPad with latest OS and brand new keyboard. Home button and space bar always seem to work. But nothing else...  Rendering it a door stop.  I tried most other alternatives and it is the "one" that suits my needs best. Hoping for a quick remedy for m Apple or Belkin!!!

  • ZakfromATX Level 1 Level 1 (0 points)

    I too, have a Logitech ultrathin keyboard. I contacted Logitech and they went as far as sending me a new keyboard with the same effect - latency, unable to unlock using the keyboard, scroll keys not working...

    I contacted Apple only after going through the exhaustive efforts of resetting bluetooth settings, wiping the iPad and setting up the device as "New" - total time suck. I even compared the behavior between my iPad 4 and my wife's iPad 2 - no difference.

    I've got the troubleshooting and issue fully documentated in a trrouble ticket as well as logging it into Apple's magical Feedback we portal... Bottom line is we all have to make noise that an actual bug is out there and a patch is needed asap.

     

    **BTW, I found a short term workaround to the lock issue - after your last character, touch any number on the screen - acts like the <ENTER> command

  • BC2010 Level 1 Level 1 (5 points)

    Hey folks, this is going to sound crazy, but I thought I would share.

     

    The only issue I was having with my bluetooth keyboard on iPad was from the login screen.  Entering the fourth digit to unlock the iPad from the keyboard would not trigger the unlock.  I had to enter the fourth digit on the touch screen.

     

    I called Apple and the tech said it would sound crazy, but he wanted me to turn off "Find My iPad", go back to the lock screen and and unlock via bluetooth keyboard, and then turn "Find My iPad" back on again.

     

    Since then I have had ZERO issues with my Logitech Ultrathin Keyboard Cover.


    I hope it fixes stuff for your guys, but it fixed my issue.  Best of luck.

  • Grantwillreply Level 1 Level 1 (0 points)

    BC2010 - That is crazy.. and points to Apple knowing there is some kind of issue if they give you that kind of "work-around" advice.

     

    With my Belkin Ultimate on OS7, I just reset the iPAD every 4-5 days (which is the time it seems to take for the keyboard to no longer properly function...  see my earlier post for definition) and it works like magic.  I'd still say it's a Bluetooth/OS issue on the iPAD if the same issue is happening across hardware/OS and keyboards.

  • ZakfromATX Level 1 Level 1 (0 points)

    Didn't change a thing - was worth a try.

  • David Shanahan Level 3 Level 3 (700 points)

    I've got a Logitech Ultrathin keyboard cover that I'd not used since upgrading my iPad 3 to iOS 7.0.2. When I came across this thread just now I turned it on and tested it out.

     

    No problems at all aside from the fn+1 (search) key not working anymore. (Not really surprised about that given the changes in iOS 7 to search.) Pairing works, delete key works as normal backspace (and does not delete space before word deleted one char at a time), cut/copy/paste keys work, lock key (fn+del) works, media keys all work, home key works and all typing appears fine. I can unlock it using passcode entered from the keyboard as usual, don't need to tap extra key or anything onscreen, and there's no noticable latency when typing.

     

    Whatever problem(s) you are encountering are not universal, not every BT keyboard has them. I bought my Logitech  only 2-3 months ago, could be it has a later firmware version I guess? (A label on the box says 2012 though, so it can't be all that recent).

  • kilauea88 Level 1 Level 1 (0 points)

    I have a Belkin Folio keyboard and iPad2 that is having intermittent issues connecting since iOS7.  Rebooting the iPad seems to be the only fix, the problem will then recur in a day or so.

     

    I do not have the issue of the Delete key becoming a Backspace, so clearly there are different issues going on.  When the keyboard stops responding, MOST apps will not accept keyboard input, BUT the iPad still knows the keyboard is there because the HOME button works.  I've seen that sometimes the issue seems to be elicited by one app, which then causes most other apps to fail to recognize keyboard input (the Salesforce Touch app seems to be an example of this).  Once the iPad gets in this mode, a reboot is the only thing that fixes it (temporarily).

     

    This is my second keyboard I started with a Zagg and I've grown quite attached to using a keyboard with my iPad, so a fix from Apple will be greatly appreciated!

  • I_AM_BK Level 1 Level 1 (0 points)

    Same issue and I am starting to get really angry. I have a Belkin keyboard case folio that I paid over $100 for in mid August. I connected it via Bluetooth and it was working just fine until I updated to iOS 7. Now the keyboard will not connect via Bluetooth at all. I have tried everything including rebooting the iPad. I also had a Belkin USB splitter on my iMac and that is no longer working with iTunes and my iPad after working for years.

     

    I am starting to think that Apple gave us all a case of "Planned Obsolescence" and is forcing us to re-buy Apple only products. This is really lame as I just purchased the Belkin keyboard case on recommendations from the Apple tech in-store.

     

    Need a fix here Apple. Please help your customers. Thank you!

  • kilauea88 Level 1 Level 1 (0 points)

    Try a reboot  I've now gone 3+ weeks without a problem.