Previous 1 2 3 4 Next 47 Replies Latest reply: Jun 23, 2015 6:50 PM by mechelly Go to original post
  • Kyool Level 1 Level 1 (0 points)

    This is beyond frustrating having to press ctrl-delete to get the old backspace behavior from my keyboard case! How has this not been fixed yet, or at least allow users to select an option under Keyboard settings to swap delete and backspace?! Who even uses delete to delete from the right of cursor?!

  • Gschiada Level 1 Level 1 (0 points)

    What is most disturbing in seeing all of the issues since updating the iOS and the associated BT problems is that in all of the posts there isn't a real fix and that apple is silent on this. Are we now headed to the crazy inept world of Microsoft?

     

    I am having a catastrophic issue.  When opening a window in safari and attempting to type the iPad locks up completely and the only way to remedy the problem is with a hard reboot. My keyboard is totally useless.  As a matter of fact I am typing this post on the native keyboard so as to keep from locking the iPad up.

     

    Come on apple, make good on all for the great things that got you hear or we the consumer will bail on you as fast as we have from the blackberry and the PC.

  • lizdance40 Level 4 Level 4 (2,375 points)

    Just to make sure ....

    have you checked in settings to make sure the keyboard type is correct?

     

    In my case, US english Qwerty

  • ticino80 Level 1 Level 1 (5 points)

    I agree, my Belkin Folio and the new ipad mini with Retina show the same disturbing Backspace-Delete failure.

    In other words typing without the backspace is a pain in the fingertips.

  • darkdune Level 1 Level 1 (0 points)

    I figured it out.  Please all try this to confirm it works for you as well.  It seems the "Backspace" now deletes items to the right of the cursor.  You can verify this behavior too by putting the cursor in the middle of a sentence and tapping the "Backspace" key. 

     

    In order to delete things to the left of the cursor, you need to use either of the following two key combinations:

     

    Ctrl-Backspace, or

    Alt(Option)-Backspace

     

    I have not figured out how to change that to just using "Backspace", but at least now you should be able to delete items to the left of the cursor again!!!

     

    My Thanksgiving gift to you all!!!

     

    Regards,

    Matthew

  • Kyool Level 1 Level 1 (0 points)

    I already mentioned that 4 posts above in this thread--the frustration is having to press 2 keys now to do what you always used to be able to do with just one!

  • Abdullah Mohd Nawi Level 1 Level 1 (0 points)

    I'm having the same problem as well! It's so unnatural to have to press 2 buttons to backspace!

  • shezcrafti Level 1 Level 1 (0 points)

    Having the same problem on my brand new iPad Air. Really disappointed to come here and read this has been going on for months and no official response. Come on, Apple, please do something about this.

  • ticino80 Level 1 Level 1 (5 points)

    My solution:

    I returned the Belkin with no issues in the shop and bought a logitech ultrathin folio. All keys work fine, it also uses the magnet to wake-up / set-asleep the ipad.

     

    One more hint from my side: buy the darker colors. Unfortunately, the bright green version is the only one with the white keyboard, however the green cover is like a dust-magnet and will soon have a vintage look.

     

    --

    ipad Mini with Retina works well with Logitech Ultrathin Folio Keyboard.

     

    @ shezcrafti

    since I also bought an ultrathin keyboard folio for my girlfriends ipad Air, as christmas present* - I justed paired it, out of curiosity, with the ipad Mini Retina - it works like a charm. Hence I believe it is also compatible with iOS7 and your ipad Air.

     

    *Officially she doesn't know about the present ... so please don't tell her.

  • pixelheresy Level 1 Level 1 (0 points)

    It looked around various places and generally strugged with this forever (since I like waking up my iPad was something I used to do in IOS 6). After trying and trying, I eventually guessed at it (#4 below was never suggested). I have a Logitech Zagg iPad 2 Keyboard, fyi.

     

    Anyway, after trying what seemed to be everything, I did the following [warning, there may be a step or two that is unnecessary]:

     

    1. Go to Settings > Bluetooth and forget the device
    2. Hold Lock and Home to reset the iPad
    3. Go to Settings > Bluetooth and reconnect the device
    4. Go to Settings > General and Lock/Unlock

     

    From now on, the Home button the keyboard wakes the iPad and goes straight to the password screen without needing to swipe.

  • Teapat Level 1 Level 1 (0 points)

    I have a Logitech Ultrathin and have tried everything in these posts (and from various other sites.) My problem is that I get the Ultrathin to pair to the iPad okay, but certain keys (specifically t, y, and delete) do not ever work even following pairing. The same exact behavior occurs when pairing the keyboard to iPhone 5S. Prior to IOS7 it all worked beautifully and it was a great asset. Now it is just an expensive screen cover. Something went wrong in IOS7 but no one seems to acknowledge what happened. There is something that has changed in the Bluetooth interface.

  • DianneP Level 1 Level 1 (0 points)

    I have the same problem as Teapat. My Logitech Ultrathin keyboad is paired, but the 't', 'y', and 'delete' keys (and sometimes the combination keys to show the native keyboard on the iPad, fn+3) do not work. If I tap at them endlessly, they will sometimes start to work. This only started within the last two weeks, however, and I didn't notice any problem coinciding with the iOS 7 update.

  • DianneP Level 1 Level 1 (0 points)

    Thanks, David. I hadn't read this since mine didn't seem to be tied to the iOS 7 update (which was back in September 2013 and my problem only started 2-3 weeks ago). The keyboard does seem to be working better since I updated last night to version 7.1. Instead of having to tap the 't' key at least 50 times to get it working, I've only had to tap it 2-3 times now.

     

    I went through the steps in the link you sent anyway, except for resetting my iPad. Right now the keyboard works well. All keys are performing as they should. I will monitor it. Thanks again for you input.

  • Teapat Level 1 Level 1 (0 points)

    Just downloaded 7.1 yesterday, and got all excited because at first the problem seemed resolved; "t", "y" and "delete" all working correctly. Then for no reason it started acting up. Then it started working again. Unfortunately I don't think the problem has been solved, but it is working at least SOME of the time (which is perhaps more frustrating than not at all.) I wish I could figure out what makes it stop or start up again. Clearly an issue with Apple and bluetooth because the 7.1 release did have an impact when nothing else did. And yes, I have tried all the other suggestions, but none seem to completely resolve the problem.