Previous 1 2 3 4 5 6 Next 89 Replies Latest reply: Aug 9, 2014 8:30 AM by required desired alias Go to original post
  • baked Level 1 Level 1 (0 points)

    I did this as well and it worked for a short while.  but it's back to not working properly.  It usually happens right after it wakes up.  After a few minutes of being awake, it works properly.  Still frustrating that it doesn't quite work properly.

  • scirica Level 1 Level 1 (0 points)

    I just did the full reboot after "forgetting" my keyboard (Logitech Ultrathin).  Right now it's working, but it seems like I did this once before.  Fingers crossed this works until a fix comes from Apple.

  • Picnicmetoo Level 1 Level 1 (15 points)

    Thanks so much.  I tried the technique once and I got only "keyboard" as before and wouldn't pair.  Tried it the second time and Apple Bluetooth keyboard popped up, I  hit "pair" and got the code and it paired.   Now all 4 of my BT devices are in the list and all is well LOL (including my Logitech Ultrathin keyboard case with arrows working).

  • rmacbeth Level 1 Level 1 (0 points)

    I have 7.0.2 and a Zagg keyboard and it still did not fix the problem on my iPad 3 re-link the keyboard it will link up but not work also have similar problems with my striive device with my 5s and Bluetooth when can we get a fix.

  • tistafford Level 1 Level 1 (0 points)

    I did a hard reset on my iPad (holding the power and home keys down until the apple logo comes up) and this fixed my keyboard problems.

  • Landhawker Level 1 Level 1 (0 points)

    Apple what is the deal with this problem!!!!??? IM sure thousands are having the Bluetooth keyboard issues with iOS 7. PLEASE FIX ASAP!!!!!!!,

  • ProfSJ Level 1 Level 1 (0 points)

    I have had a keyboard problem with a just-purchased Belkin ultimate keyboard case - some keys worked -- e.g. the function keys worked and there is a separate Siri key and that worked -- but the lettered keys did not work. This did not happen when I first used it two days ago. I tried upairing several times as suggested in one of the posts, but that did not fix it. I finally got through to Belkin support and they had me do the following:

    - unpair the device (Settings app)

    - turn off Bluetooth (Bluetooth section in settings)

    - completely turn off the iPad (hold down both the home button and the sleep button)

     

    When I reversed the process, all the keys now worked. And I tried the keys in several programs because of the posting about the Belkin keyboard not working to type in all programs.

     

    I was told that Belkin is reporting issues with this keyboard and OS 7. They are in the process of updating, and this process apparently resulted in updating. So, the steps above are worth trying if you are having difficulty.

  • shpaul Level 1 Level 1 (0 points)

    I got the same problem with my foldable elecom. Now i found out if we press CTRL and Delete together, the delete function will be workable again.

  • TLA90 Level 1 Level 1 (0 points)

    I was having the same problem.  My Belkin ultimate external keyboard did not work with Notes after I upgraded to IOS 7.0.2.  I went to settings.  I turned on Bluetooth.  I re-paired the device by hitting <...> pair on the belkin keyboard with the Fn key.  The iPad said "Connected" and now the keyboard is working with notes.

  • Huey_uk Level 1 Level 1 (0 points)

    There's a distinct possibility that iOS 7.0.3 has fixed this issue.

     

    I have just installed it and tested a few of the 'funnies'I had before with my Logitech ultraslim keyboard, and this now seem corrected.

     

    One issue was having to select a number (any number) on screen after I typed in my passcode c=lock number from the keyboard, to get the iPad to recognise I had entered all the required numbers. No need to do this now, the passcode is accepted from the keyboard, and the iPad unlocks without further input.

     

    A second issue was that the up and down keys would not work within the description fields of Trello cards. The arrow keys now work as expected in the description field.

     

    All good so far.

    H.

  • Josephine Harris Level 1 Level 1 (0 points)

    This happened with my ZAGGkeys profolio.  I did as you said and deleted its profile in bluetooth. Switched it off and then made it disocverable again.  It worked.  Thank you.  What on earth is Apple up to?  Evrything used to run seamlessly and now it seems I am always updating my software and fixing bugs in the new versions.  I switched to a Mac years ago to avoid all Microsoft's nonsense.  Rant. Rant.  Thank you eefbee!

  • SimonJCarr Level 1 Level 1 (0 points)

    I'm also having all sorts of problems with my Apple BT keyboard and my iPad with iOS7 (7.03). What I have found so far is

    • My iPad cannot get a successful connection to my BT keyboard;
    • When I access the BT settings in my iPad, it detects all the other BT kit in the house, but just hangs, failing to detect the BT Keyboard; This makes it impossible to 'forget' the BT keyboard;

    To get the BT keyboard running again, I have to switch off bluetooth EVERYWHERE in my house, restart the iPad and hope to get the connection.

     

    This is really frustrating: like Josephine I moved to Apple 10 years ago to have error free and bug free work and home computers, yet the recent slew of updates have had dreadful quality control. The new iWork suite is buggy and a step down in functionality and usability from the old suite, and my iPad has been very unstable since upgrading to iOS7. Come on, get your quality control working properly! These are not complex issues, but ones that the typical user faces within 5 minutes of working on Apple devices: these should not have been things that Apple were not aware of.

  • mkral Level 2 Level 2 (220 points)

    Simon, I had the same issue &amp; found a solution online, although I don't have the link handy. Basically you need to hold down the power button on the keyboard throughout the entire process of syncing with the iPAd. Keep it pressed until you see that the keyboard is actually synced to the device. This solved my problem.

  • Clarkfong Level 1 Level 1 (0 points)

    Hello all, my problem is even weird. The backspace and space button don't work properly in many situation. When I key-in space after typing a word, it has no effect. I had to do this in order to add a space :

    1) press backspace once. No effect

    2) press backspace 2nd time . One character removed

    3) insert a space

     

    This issue happened after iPad got upgraded to 7.0.3. I tried to pair up my Logitech keyboard with my iPhone which is on 7.0.2. It works too. I am so annoyed now. Anyone get the same issue?

  • Huey_uk Level 1 Level 1 (0 points)

    Update:

    Whilst the editing functions in some apps are improved, iOS 7.0.3 does nothing for most of the keyboard connection problems, including typing the PIN number on the lockscreen.