Previous 1 2 3 4 Next 50 Replies Latest reply: Sep 28, 2014 7:58 PM by ChrisJ4203
pthickett Level 1 Level 1

So I recently moved to Android from iPhone - just wanted a change, I am not saying Android is better or anything so don't hurt me!

 

I still have an iPad and Macbook - not sure if they could be the cause of my issues here.

 

But basically, my contacts who use iPhones still send me texts as iMessages, even if they have the toggle switched to send as SMS when iMessage isn't available. I have got it to work on certain people's phones by asking them to turn iMessage off and back on and eventually it figures it out. But this obviously isn't ideal as I don't want to have to ask every one of my contacts with an iPhone to do this.

 

So I scoured the forums and found a few suggestions but none of which seems to have worked. Including changing my iCloud password, unauthorizing my iPhone online, etc etc. Also before I traded my iPhone the AT&T chap didn't ask me to log out of/turn off iMessage on the device, which I think may be the root cause of the problem.

 

I am hoping someone here can let me know a definitive way of getting my cell number removed from this iMessage database I keep reading about. I would be really grateful.

 

Thanks!

Reply by Kilgore-Trout on Sep 26, 2013 6:52 AM Helpful

Are you still using the phone number as a send and receive for the iPad?

Reply by Kilgore-Trout on Sep 26, 2013 7:01 AM Helpful

The iPad being WiFi only doesn't matter. It is still possible to use your phone nubmer as an address if it on your AppleID. Check the send and receive for the iPad (and the MacBook) to see it it is there.

All replies

  • Kilgore-Trout Level 7 Level 7
    expertise.ipad
    iPad

    Are you still using the phone number as a send and receive for the iPad?

  • pthickett Level 1 Level 1

    My ipad is only wifi - so it doesn't have a cell number linked or anything. But I have since turned off iMessage in the settings to see if that helped.

  • Kilgore-Trout Level 7 Level 7
    expertise.ipad
    iPad

    The iPad being WiFi only doesn't matter. It is still possible to use your phone nubmer as an address if it on your AppleID. Check the send and receive for the iPad (and the MacBook) to see it it is there.

  • pthickett Level 1 Level 1

    I just checked my ipad and its only email addresses on there as send/receive. I am at work so I don't have access to my macbook at the moment so I will have to check that later.

     

    Other than that - do you think there is anything else I can do?

  • Kilgore-Trout Level 7 Level 7
    expertise.ipad
    iPad

    What address(es) are the senders using?

  • pthickett Level 1 Level 1

    Just variants of my email address linked to my apple ID, from my original @mac, to @me and @icloud.

  • iOS *08* Level 2 Level 2

    Have you turned off iMessage for your mobile number before inserting it to your Android phone?  If you have not turned it off before using it on another mobile phone not iOS, then your number will still be detected as registered in iMessage.

     

    Related support article: http://support.apple.com/kb/TS2755

     

    Under "Additional Information":

     

    • If you plan on transferring your SIM card or phone number from an iPhone to a device that does not support iMessage, turn off iMessage in Settings > Messages first. If you do not, other iOS devices may continue to try to send a message using iMessage first, instead only using SMS or MMS.
  • pthickett Level 1 Level 1

    I was worried about this - as I was not notified about this happening before I had my iphone taken away from me in the AT&T store during the upgrade procedure.

     

    Knowing that that is the root cause, what can I do now?

  • iOS *08* Level 2 Level 2

    If you have access to an iPhone, insert your SIM then activate iMessage.  Once activated, deactivate iMessage again.  This is to somehow trigger the registration and de-registration of your mobile number from iMessage service.  If still not working, call AppleCare.  Hope this helps.

  • Kilgore-Trout Level 7 Level 7
    expertise.ipad
    iPad

    pthickett wrote:

     

    Just variants of my email address linked to my apple ID, from my original @mac, to @me and @icloud.

    For your new phone, they should be using your phone number. That is the only thing assocaited with your SMS service with yor carrier.

  • pthickett Level 1 Level 1

    While I am sure that by jumping on someone elses iphone will fix this, I feel like its going to mess with their settings/email stuff as I will have to sign into icloud on their phone etc etc.

     

    I will try the applecare route and report back...

     

    Thanks for the help so far.

  • Michael Black Level 7 Level 7

    Whatever you do, do not let anyone convince you to install the iMessage App for Android now in google play.  Numerous reports are now out that the app has several serious security flaws in it and I gather people are trying to get it removed from Google play if possible.

     

    Just a heads up in case some Android users chimes in suggesting to try it.

  • iZayk Level 1 Level 1

    All you have to do is change your apple id password it sounds point less but it works

  • pthickett Level 1 Level 1

    Thanks for the heads up about the iMessage app!

     

    I just finished with Apple Support, they suggested simply to do a password reset. This means that anyone texting me will get a failure, followed by a prompt to send as SMS.

     

    Then they will just need to remove my contact from their address book and re-add me and it should be ok after that....

Previous 1 2 3 4 Next