Previous 1 2 3 4 5 Next 996 Replies Latest reply: Mar 18, 2015 1:49 AM by Rahul_Does Go to original post Branched to a new discussion.
  • chronicon helveticum Level 1 Level 1 (0 points)

    I think you're right turfstuf - I really struggled to come up with the right combination of keywords for my google search to end up here. This suggests that we're the tip of the iceberg.

     

    Rick7, did you have any luck at the Genius Bar?

  • rick7 Level 1 Level 1 (0 points)

    Ok, my report-back from the Apple Store Genius Bar:

     

    Earlier, while I was waiting for my Genius, I'd worked in an app, then switched to some other apps and worked there for a while so the problem would be ready for him when he got here.  Then he did arrive and I explained to him what was happening.  He told me he had never heard of the problem -- disappointing, but maybe not surprising, right off the bat.  Anyway, I then showed him my iPad and switched back to my original app that I'd had in suspension, and -- wouldn't you know it? -- it did NOT reset.  Grrr...

     

    But then I switched to another app again did some work there, came back -- and he did see it reset.  He saw it, and was surprised.  He said something about "well, maybe some apps need to reset because ...", blah blah blah.  OK, whatever. 

     

    I showed him our discussions here and he did read quite a bit of our messages and I think he was convinced there was indeed a problem.

     

    I told him about our theory of running low on memory, and he hooked up my iPad to a diagnosis machine and did find that my iPad was quite low on "application memory".  He noticed that on my 16 GB machine according to Settings -> Usage I had only 1.3 GB free.  He commented that that is extremely low and that they recommend always keeping at least 10% of disk space free.  He suggested that could potentially be causing the problem: we all know that sometimes RAM needs to access and draw a bit from disk space in order to work correctly if it's low on actual RAM (well, I'm doing this from my knowledge of Windows but according to him the same principle holds).

     

    He also noticed that I have 109 apps installed, which he said is extremely high (really?) and wondered if that could be contributing to the problem.

     

    He suggested clearing out some disk space when I got home, and seeing if that takes care of the problem.  So in the last day or so I've uninstalled some large apps and deleted some data for some apps, and I'm now pleased to report that Usage -> Storage now tells me that I have 2.8 GB available and 10.9 used.  Definitely more than 10% free now.  And ...[drum roll here]....  I'm still having the problem.  No difference at all.

     

    Does having 109 apps steal memory also?  I'm not sure why it would as they're not loaded.

     

    Back to the drawing board.

     

    Additional thoughts welcome.

  • chronicon helveticum Level 1 Level 1 (0 points)

    Thanks for the feedback from the Apple store. I must confess I didn't expect a resolution of the problem. I'm dubious about the available space issue and even more dubious about you having too many apps. If these had been problems they would have manifested themselves on millions of iPad 2s in the past. It must be an iOS 7 related problem.

     

    It still sounds like a bug or new 'feature' in the memory management of apps that impacts on those of us with 512MB (or lower?) machines.

     

    I can only see two options now: (1) wait in hope for 7.0.4 (I cannot believe that Apple don't know about this - admitting they know is a different matter), or (2) very carefully back everything up then reset to factory settings and start installing your apps from scratch.

     

    Like many other users I suspect, I use less than a dozen apps regularly and hang on to the others because 'you never know when they might be useful'. A clear out might be useful anyway. But option 2 is an uncomfortable one. And might not fix the problem anyway ...

  • rick7 Level 1 Level 1 (0 points)

    Right.  I'm completely disinclined to do any sort of factory reset.  He suggested "reinstalling the operating system" which apparently entails making sure everything is backed up to iTunes, then doing a restore from that iTunes backup.  I'm not sure why that gives you a new OS -- aren't you just restoring the OS you backed up from your machine?  But whatever that does, I'm not going to be doing it.

     

    I also wrote to a tech writer who reviewed iOS 7 back in September, and asked her if she'd be interested in investigating the issue.  Haven't heard back from her.

     

    I'm highly tempted to go back to the Apple Store to have a follow-up meeting to proceed with some sort of escalation with them.  Are others in a position to do the same?

  • rick7 Level 1 Level 1 (0 points)

    Hi TurfSurf -- welcome to our still-small group.  Appreciate your posting here.

     

    For me the problem is not so much a frustration with 'refresh delay' but that the refresh (almost like a restart) takes place at all. I think I have a couple of apps that after a (slow) refresh may go back to where they were, but the main problem is that for most apps after the refresh the app loses its place and doesn't go back to where it was.

     

    I'm curious: when you're switching back to, say, iBooks, after the slow refresh does it successfully take you back to where you were in iBooks, or does it lose your place in the app completely?

  • paulfromstone Level 1 Level 1 (5 points)

    Thanks for trying the Apple Store route rick7. Unfortunately there's not one near me to try the same.

     

    I don't think low free flash space is responsible - I've got over 20GB free on my 32GB iPhone 4. Also, my (admittedly limited) understanding of iOS is that usage of flash memory for swap space is only used for paging app code, not app data, so it doesn't rely on there being free space.

  • turfstuf Level 1 Level 1 (0 points)

    When I return to iBooks, it briefly shows the page I was viewing THEN takes me on a tour back up to the library screen and then back to the book...with a bunch of spinning cursors & unresponsive taps telling me to wait in between. 

     

    In the eBay app, it takes me back to the item I was viewing but the app is unresponsive (just like iBooks) until it goes back up and dumps me at the eBay home screen...losing my place entirely.

     

    In Twitter, sometimes it takes me back to the tweet I was reading.  The longer I wait before returning to Twitter, it will refresh and put me at the most recent tweet (top of the feed), not the one I was reading...losing my place entirely.

     

    NEVER had this issue before ios7.  Must be my fault, ha.

  • rick7 Level 1 Level 1 (0 points)

    Yep, I never had this before iOS 7 either.  The puzzling thing we haven't figured out here is why this issue hasn't been written about and why this thread isn't buzzing with replies.  Maybe it happens on some models of iPad and iPhone and not others.  I have an iPad 2.

  • Filmphil Level 1 Level 1 (0 points)

    Ok my turn now, I've been reading this thread for a few days now hoping for an answer. I too am having the exact same problem and have no clue what to do. I am on an ipad mini. It is hard to describe this problem to others.  I am in a unique circumstance in that I work for a tech repair company. For the last week I have asked everyone who comes in with a iproduct if they too have had the problem. They either respond with "never noticed" or they don't seem to care. I'm joining this discussion because you are the only group of people that seem to understand.  I have tried all the options that you have suggestion and none of them work. I think we are all on to something though with the low ram theory.  That is just my two cents for now.

  • rick7 Level 1 Level 1 (0 points)

    Hi Filmphil -- Glad you sent a message, and you raise an interesting point: is it possible that some number of people actually have the problem but are so focused on their task at hand that they haven't even noticed this?  Or that they just take it for granted and assume that's the way it should be?  It's strange because anyone who's switched from iOS 6 to 7 would definitely notice.  Or maybe, as you say, they just don't care.

  • chronicon helveticum Level 1 Level 1 (0 points)

    The iBooks behaviour I get is identical to that described by turfstuf. I briefly see the page I had been on then then I go back to a bookcase then the book opens again and I get back to the page I had been on. Except very occasionally, maybe if the book has been idle for hours, the book just closes and I see the active book shelf and the book stays closed.

     

    I will be in Bristol next week and will try and get an appointment to see someone in the Apple store there. I don't hold out much hope of getting anywhere since I suspect the iOS dev team does know about this but is keeping quiet. I expect to be fobbed off with reinstall-everything-from-scratch and I imagine the Geniuses are more versed in configuration issues and app usage than obscure iOS 7 bugs. But it doesn't hurt to ask.

     

    So far in this thread we've seen reports of problems on the iPhone 4, iPad 2 and iPad mini (1st gen, Filmphil?), all of which have 512MB RAM. So at least we are seeing a pattern.

     

    I've been ditching old apps to claw back some space but it has made no difference, as was phaulfromstone's conclusion too.

     

    I won't be the only one to be intensely annoyed if iOS 7 implicitly demands a more recent machine, particularly with no downgrade path to iOS 6 (and to think of the abuse I used to throw at iOS 6 ...)

  • chronicon helveticum Level 1 Level 1 (0 points)

    Sorry, paulfromstone, finger trouble.

  • Ericandleanne Level 1 Level 1 (0 points)

    Having the same issues on IPad 2. Only since upgrading to iOS 7. It's a real pain. I'm a believer that most people don't care. I find it such a waste of my time.

  • rick7 Level 1 Level 1 (0 points)

    Ericandleanne -- Curious to know what apps it's happening to you on.  For me it's pretty much everything except Mail.

  • spacom Level 1 Level 1 (0 points)

    I have the same problem when updated mine Iphone 4s and Ipad2 to IOS7.

    Switching between applications makes them to refresh/restart.

    Battery doctor says the phone is low in memory.

Previous 1 2 3 4 5 Next